Microsoft.WebMatrix.Extensibility Namespace

[image]

Microsoft WebMatrix 2 Beta
Microsoft.WebMatrix.Extensibility Namespace

Classes

 | Class | Description
Public class | CommonCommandIds | Common command IDs: Composed of the GroupId which is a guid separating the group. and the Id enum desribing the individual command.
Public class | ContextMenuItem | Class that represents an item in a context menu.
Public class | ContextMenuOpeningEventArgs | Class that represents the event arguments for a context menu opening event.
Public class | DashboardItem | Class that represents a dashboard item.
Public class | ExtensionBase | IExtension implementation that provides a convenient starting-point for creating a WebMatrix extension.
Public class | HelpInvokedEventArgs | Class that represents the event arguments for a help request.
Public class | ProtectPathInfo | Class that specifies information about protected paths.
Public class | RibbonButton | Class that represents a Ribbon button.
Public class | RibbonContextualTab | Class that represents a contextual tab on the Ribbon.
Public class | RibbonGalleryCategory | Class that represents a category in a Ribbon gallery.
Public class | RibbonGroup | Class that represents a group on the Ribbon.
Public class | RibbonMenuButton | Class that represents a Ribbon menu-button.
Public class | RibbonSplitButton | Class that represents a Ribbon split-button.
Public class | RibbonSplitButtonGallery | Class that represents a Ribbon split-button that expands to a gallery.
Public class | RibbonToggleButton | Class that represents a Ribbon toggle button.
Public class | Utility | Class that exposes a variety of helpful utility methods.
Public class | VSConstants_Ids |
Public class | WorkspaceChangedEventArgs | Class that represents the event arguments for a WorkspaceChanged event.

Interfaces

 | Interface | Description
Public interface | ICommandId | Class that defines a command ID.
Public interface | IContextMenuItem | Interface for representing an item in a context menu.
Public interface | IDashboardItem | Interface for representing an item on the dashboard.
Public interface | IDialogContent | Interface for providing custom content for a dialog and having control over when it closes.
Public interface | IEditorContainer | Interface to pass into the GetIEditor command
Public interface | IEditorExt |
Public interface | IEditorWorkspace | Interface that represents the WebMatrix editor workspace.
Public interface | IExtension | Interface that all WebMatrix extensions are required to implement.
Public interface | IHostCommands | Interface for accessing commands exposed by the host.
Public interface | IProtectPathInfo | Interface for specifying information about protected paths.
Public interface | IRibbonButton | Interface for representing a button on the Ribbon.
Public interface | IRibbonContextualTab | Interface for representing a contextual tab on the Ribbon.
Public interface | IRibbonGalleryCategory | Interface that represents a category in a Ribbon gallery.
Public interface | IRibbonGroup | Interface for representing a group on the Ribbon.
Public interface | IRibbonItem | Interface for representing an item on the Ribbon.
Public interface | IRibbonMenuButton | Interface for representing a menu-button on the Ribbon.
Public interface | IRibbonSplitButton | Interface for representing a split-button on the Ribbon.
Public interface | IRibbonSplitButtonGallery | Interface for representing a split-button on the Ribbon that expands to a gallery.
Public interface | IRibbonToggleButton | Interface for representing a toggle button on the Ribbon.
Public interface | ISiteFile | Interface that represents a file in the site.
Public interface | ISiteFileSystemItem | Interface that represents a file or folder in the site.
Public interface | ISiteFolder | Interface that represents a folder (directory) in the site.
Public interface | ISiteItem | Interface that represents an item in the site.
Public interface | IWebMatrixHost | Interface for interacting with the WebMatrix host.
Public interface | IWebSite | Interface for interacting with a web site.
Public interface | IWorkspace | Interface that represents a WebMatrix workspace.

Enumerations

 | Enumeration | Description
Public enumeration | CommonCommandIds..::..Ids | Enumeration values for command IDs; can be passed to ICommandTarget.
Public enumeration | DialogSize | Enumeration of dialog sizes for the IWebMatrixHost.ShowDialog methods.
Public enumeration | VSConstants_Ids..::..VSStd2KCmdID | Set of the standard, shared editor commands in StandardCommandSet2k.


CommonCommandIds Class

[image]

Microsoft WebMatrix 2 Beta
CommonCommandIds Class
Members See Also

Common command IDs: Composed of the GroupId which is a guid separating the group. and the Id enum desribing the individual command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class CommonCommandIds
Visual Basic
Public Class CommonCommandIds

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..CommonCommandIds

See Also

CommonCommandIds Members
Microsoft.WebMatrix.Extensibility Namespace


CommonCommandIds Members

[image] [image]

Microsoft WebMatrix 2 Beta
CommonCommandIds Members
CommonCommandIds Class Constructors Methods Properties See Also

The CommonCommandIds type exposes the following members.

Constructors

 | Name | Description
Public method | CommonCommandIds |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
GroupId | Gets the common command GroupId; can be passed to ICommandTarget.

See Also

CommonCommandIds Class


CommonCommandIds Constructor

[image]

Microsoft WebMatrix 2 Beta
CommonCommandIds Constructor
CommonCommandIds Class See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public CommonCommandIds()
Visual Basic
Public Sub New

See Also

CommonCommandIds Class


CommonCommandIds Methods

[image] [image]

Microsoft WebMatrix 2 Beta
CommonCommandIds Methods
CommonCommandIds Class See Also

The CommonCommandIds type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

CommonCommandIds Class


CommonCommandIds Properties

[image] [image]

Microsoft WebMatrix 2 Beta
CommonCommandIds Properties
CommonCommandIds Class See Also

The CommonCommandIds type exposes the following members.

Properties

Name | Description
GroupId | Gets the common command GroupId; can be passed to ICommandTarget.

See Also

CommonCommandIds Class


GroupId Property

[image]

Microsoft WebMatrix 2 Beta
CommonCommandIds..::..GroupId Property
CommonCommandIds Class See Also

Gets the common command GroupId; can be passed to ICommandTarget.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static Guid GroupId { get; private set; }
Visual Basic
Public Shared Property GroupId As Guid
    Get
    Private Set

See Also

CommonCommandIds Class


CommonCommandIds.Ids Enumeration

[image]

Microsoft WebMatrix 2 Beta
CommonCommandIds..::..Ids Enumeration
CommonCommandIds Class See Also

Enumeration values for command IDs; can be passed to ICommandTarget.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
[GuidAttribute("EAE6F5EA-6E6D-4D44-BEBC-EE5B3B3C70E9")]
public enum Ids
Visual Basic
<GuidAttribute("EAE6F5EA-6E6D-4D44-BEBC-EE5B3B3C70E9")> _
Public Enumeration Ids

Members

Member name | Description
None |
ApplicationExit |
ApplicationOptions |
CloseAll |
Copy |
Cut |
Delete |
DeletePermanent |
LaunchOnlineHelp |
NavigateToDbManager |
NavigateToEditor |
NavigateToSeo |
NavigateToSite |
Paste |
Redo |
Refresh |
Rename |
SaveAll |
SaveAs |
Save |
Undo |
ApplicationAbout |
ToggleFullView |
ExtensionsGallery |

See Also

Microsoft.WebMatrix.Extensibility Namespace


ContextMenuItem Class

[image]

Microsoft WebMatrix 2 Beta
ContextMenuItem Class
Members See Also

Class that represents an item in a context menu.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class ContextMenuItem : IContextMenuItem
Visual Basic
Public Class ContextMenuItem _
    Implements IContextMenuItem

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..ContextMenuItem

See Also

ContextMenuItem Members


ContextMenuItem Members

[image] [image]

Microsoft WebMatrix 2 Beta
ContextMenuItem Members
ContextMenuItem Class Constructors Methods Properties See Also

The ContextMenuItem type exposes the following members.

Constructors

 | Name | Description
Public method | ContextMenuItem | Initializes a new instance of the ContextMenuItem class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is selected.
Public property | CommandParameter | Gets or sets the parameter to pass to the Command.
Public property | Icon | Gets a 16x16 image for the item.
Public property | Label | Gets a label for the item.

See Also

ContextMenuItem Class


ContextMenuItem Constructor

[image]

Microsoft WebMatrix 2 Beta
ContextMenuItem Constructor
ContextMenuItem Class See Also

Initializes a new instance of the ContextMenuItem class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ContextMenuItem(
    string label,
    ImageSource icon,
    ICommand command,
    Object commandParameter
)
Visual Basic
Public Sub New ( _
    label As String, _
    icon As ImageSource, _
    command As ICommand, _
    commandParameter As Object _
)

Parameters

label
Type: System..::..String
Label for the item.
icon
Type: System.Windows.Media..::..ImageSource
16x16 image for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the item is selected.
commandParameter
Type: System..::..Object
Parameter for the command.

See Also

ContextMenuItem Class


ContextMenuItem Methods

[image] [image]

Microsoft WebMatrix 2 Beta
ContextMenuItem Methods
ContextMenuItem Class See Also

The ContextMenuItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ContextMenuItem Class


ContextMenuItem Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ContextMenuItem Properties
ContextMenuItem Class See Also

The ContextMenuItem type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is selected.
Public property | CommandParameter | Gets or sets the parameter to pass to the Command.
Public property | Icon | Gets a 16x16 image for the item.
Public property | Label | Gets a label for the item.

See Also

ContextMenuItem Class


Command Property

[image]

Microsoft WebMatrix 2 Beta
ContextMenuItem..::..Command Property
ContextMenuItem Class See Also

Gets the command to invoke when the button is selected.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ICommand Command { get; private set; }
Visual Basic
Public Property Command As ICommand
    Get
    Private Set

Implements

IContextMenuItem..::..Command

See Also

ContextMenuItem Class


CommandParameter Property

[image]

Microsoft WebMatrix 2 Beta
ContextMenuItem..::..CommandParameter Property
ContextMenuItem Class See Also

Gets or sets the parameter to pass to the Command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Object CommandParameter { get; private set; }
Visual Basic
Public Property CommandParameter As Object
    Get
    Private Set

Implements

IContextMenuItem..::..CommandParameter

See Also

ContextMenuItem Class


Icon Property

[image]

Microsoft WebMatrix 2 Beta
ContextMenuItem..::..Icon Property
ContextMenuItem Class See Also

Gets a 16x16 image for the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ImageSource Icon { get; private set; }
Visual Basic
Public Property Icon As ImageSource
    Get
    Private Set

Implements

IContextMenuItem..::..Icon

See Also

ContextMenuItem Class


Label Property

[image]

Microsoft WebMatrix 2 Beta
ContextMenuItem..::..Label Property
ContextMenuItem Class See Also

Gets a label for the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Label { get; private set; }
Visual Basic
Public Property Label As String
    Get
    Private Set

Implements

IContextMenuItem..::..Label

See Also

ContextMenuItem Class


ContextMenuOpeningEventArgs Class

[image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs Class
Members See Also

Class that represents the event arguments for a context menu opening event.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class ContextMenuOpeningEventArgs : EventArgs
Visual Basic
Public Class ContextMenuOpeningEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Microsoft.WebMatrix.Extensibility..::..ContextMenuOpeningEventArgs

See Also

ContextMenuOpeningEventArgs Members


ContextMenuOpeningEventArgs Members

[image] [image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs Members
ContextMenuOpeningEventArgs Class Constructors Methods Properties See Also

The ContextMenuOpeningEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ContextMenuOpeningEventArgs | Initializes a new instance of the ContextMenuOpeningEventArgs class.

Methods

 | Name | Description
Public method | AddMenuItem | Adds a IContextMenuItem instance to the context menu.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AddedMenuItems | Gets a sequence of IContextMenuItem instances that were added to the context menu.
Public property | Item | Gets the site item for which the context menu is opening.

See Also

ContextMenuOpeningEventArgs Class


ContextMenuOpeningEventArgs Constructor

[image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs Constructor
ContextMenuOpeningEventArgs Class See Also

Initializes a new instance of the ContextMenuOpeningEventArgs class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ContextMenuOpeningEventArgs(
    ISiteItem item
)
Visual Basic
Public Sub New ( _
    item As ISiteItem _
)

Parameters

item
Type: Microsoft.WebMatrix.Extensibility..::..ISiteItem
Site item for which the context menu is opening.

See Also

ContextMenuOpeningEventArgs Class


ContextMenuOpeningEventArgs Methods

[image] [image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs Methods
ContextMenuOpeningEventArgs Class See Also

The ContextMenuOpeningEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | AddMenuItem | Adds a IContextMenuItem instance to the context menu.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ContextMenuOpeningEventArgs Class


AddMenuItem Method

[image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs..::..AddMenuItem Method
ContextMenuOpeningEventArgs Class See Also

Adds a IContextMenuItem instance to the context menu.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public virtual void AddMenuItem(
    IContextMenuItem item
)
Visual Basic
Public Overridable Sub AddMenuItem ( _
    item As IContextMenuItem _
)

Parameters

item
Type: Microsoft.WebMatrix.Extensibility..::..IContextMenuItem
IContextMenuItem instance to add.

See Also

ContextMenuOpeningEventArgs Class


ContextMenuOpeningEventArgs Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs Properties
ContextMenuOpeningEventArgs Class See Also

The ContextMenuOpeningEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AddedMenuItems | Gets a sequence of IContextMenuItem instances that were added to the context menu.
Public property | Item | Gets the site item for which the context menu is opening.

See Also

ContextMenuOpeningEventArgs Class


AddedMenuItems Property

[image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs..::..AddedMenuItems Property
ContextMenuOpeningEventArgs Class See Also

Gets a sequence of IContextMenuItem instances that were added to the context menu.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public virtual IEnumerable<IContextMenuItem> AddedMenuItems { get; }
Visual Basic
Public Overridable ReadOnly Property AddedMenuItems As IEnumerable(Of IContextMenuItem)
    Get

See Also

ContextMenuOpeningEventArgs Class


Item Property

[image]

Microsoft WebMatrix 2 Beta
ContextMenuOpeningEventArgs..::..Item Property
ContextMenuOpeningEventArgs Class See Also

Gets the site item for which the context menu is opening.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ISiteItem Item { get; private set; }
Visual Basic
Public Property Item As ISiteItem
    Get
    Private Set

See Also

ContextMenuOpeningEventArgs Class


DashboardItem Class

[image]

Microsoft WebMatrix 2 Beta
DashboardItem Class
Members See Also

Class that represents a dashboard item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class DashboardItem : IDashboardItem
Visual Basic
Public Class DashboardItem _
    Implements IDashboardItem

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..DashboardItem

See Also

DashboardItem Members


DashboardItem Members

[image] [image]

Microsoft WebMatrix 2 Beta
DashboardItem Members
DashboardItem Class Constructors Methods Properties See Also

The DashboardItem type exposes the following members.

Constructors

 | Name | Description
Public method | DashboardItem(String, String, Uri, Bitmap) | Initializes a new instance of the DashboardItem class.
Public method | DashboardItem(String, String, Uri, ImageSource) | Initializes a new instance of the DashboardItem class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets the item's description.
Public property | Image | Gets a 32x32 image to display next to the item.
Public property | Title | Gets the item's title.
Public property | Uri | Gets the URI to navigate to when the item is clicked.

See Also

DashboardItem Class


DashboardItem Constructor

[image] [image]

Microsoft WebMatrix 2 Beta
DashboardItem Constructor
DashboardItem Class See Also

Overload List

 | Name | Description
Public method | DashboardItem(String, String, Uri, Bitmap) | Initializes a new instance of the DashboardItem class.
Public method | DashboardItem(String, String, Uri, ImageSource) | Initializes a new instance of the DashboardItem class.

See Also

DashboardItem Class
DashboardItem Members


DashboardItem Constructor (String, String, Uri, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
DashboardItem Constructor (String, String, Uri, Bitmap)
DashboardItem Class See Also

Initializes a new instance of the DashboardItem class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public DashboardItem(
    string title,
    string description,
    Uri uri,
    Bitmap image
)
Visual Basic
Public Sub New ( _
    title As String, _
    description As String, _
    uri As Uri, _
    image As Bitmap _
)

Parameters

title
Type: System..::..String
Title of the item.
description
Type: System..::..String
Description for the item.
uri
Type: System..::..Uri
URI for the item.
image
Type: System.Drawing..::..Bitmap
Image for the item.

See Also

DashboardItem Class
DashboardItem Overload


DashboardItem Constructor (String, String, Uri, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
DashboardItem Constructor (String, String, Uri, ImageSource)
DashboardItem Class See Also

Initializes a new instance of the DashboardItem class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public DashboardItem(
    string title,
    string description,
    Uri uri,
    ImageSource image
)
Visual Basic
Public Sub New ( _
    title As String, _
    description As String, _
    uri As Uri, _
    image As ImageSource _
)

Parameters

title
Type: System..::..String
Title of the item.
description
Type: System..::..String
Description for the item.
uri
Type: System..::..Uri
URI for the item.
image
Type: System.Windows.Media..::..ImageSource
Image for the item.

See Also

DashboardItem Class
DashboardItem Overload


DashboardItem Methods

[image] [image]

Microsoft WebMatrix 2 Beta
DashboardItem Methods
DashboardItem Class See Also

The DashboardItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DashboardItem Class


DashboardItem Properties

[image] [image]

Microsoft WebMatrix 2 Beta
DashboardItem Properties
DashboardItem Class See Also

The DashboardItem type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the item's description.
Public property | Image | Gets a 32x32 image to display next to the item.
Public property | Title | Gets the item's title.
Public property | Uri | Gets the URI to navigate to when the item is clicked.

See Also

DashboardItem Class


Description Property

[image]

Microsoft WebMatrix 2 Beta
DashboardItem..::..Description Property
DashboardItem Class See Also

Gets the item's description.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set

Implements

IDashboardItem..::..Description

See Also

DashboardItem Class


Image Property

[image]

Microsoft WebMatrix 2 Beta
DashboardItem..::..Image Property
DashboardItem Class See Also

Gets a 32x32 image to display next to the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ImageSource Image { get; private set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Private Set

Implements

IDashboardItem..::..Image

See Also

DashboardItem Class


Title Property

[image]

Microsoft WebMatrix 2 Beta
DashboardItem..::..Title Property
DashboardItem Class See Also

Gets the item's title.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Title { get; private set; }
Visual Basic
Public Property Title As String
    Get
    Private Set

Implements

IDashboardItem..::..Title

See Also

DashboardItem Class


Uri Property

[image]

Microsoft WebMatrix 2 Beta
DashboardItem..::..Uri Property
DashboardItem Class See Also

Gets the URI to navigate to when the item is clicked.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Uri Uri { get; private set; }
Visual Basic
Public Property Uri As Uri
    Get
    Private Set

Implements

IDashboardItem..::..Uri

See Also

DashboardItem Class


DialogSize Enumeration

[image]

Microsoft WebMatrix 2 Beta
DialogSize Enumeration
See Also

Enumeration of dialog sizes for the IWebMatrixHost.ShowDialog methods.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public enum DialogSize
Visual Basic
Public Enumeration DialogSize

Members

Member name | Description
SizeToContent |
Small |
Medium |
Large |

See Also

Microsoft.WebMatrix.Extensibility Namespace


ExtensionBase Class

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase Class
Members See Also

IExtension implementation that provides a convenient starting-point for creating a WebMatrix extension.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class ExtensionBase : IExtension
Visual Basic
Public Class ExtensionBase _
    Implements IExtension

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..ExtensionBase

See Also

ExtensionBase Members


ExtensionBase Members

[image] [image]

Microsoft WebMatrix 2 Beta
ExtensionBase Members
ExtensionBase Class Constructors Methods Properties See Also

The ExtensionBase type exposes the following members.

Constructors

 | Name | Description
Public method | ExtensionBase | Initializes a new instance of the ExtensionBase class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnWebMatrixHostChanged | Method that is called when the WebMatrixHost property changes
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DashboardItems | Gets a sequence of Dashboard items.
Protected property | DashboardItemsCollection | Gets a collection of IDashboardItem instances.
Public property | Name | Gets the user-friendly name of the extension.
Public property | RibbonItems | Gets a sequence of Ribbon items that are always available.
Protected property | RibbonItemsCollection | Gets a collection of IRibbonItem instances.
Public property | Version | Gets the user-friendly version of the extension.
Protected property | WebMatrixHost | Gets the IWebMatrixHost host instance.

See Also

ExtensionBase Class


ExtensionBase Constructor

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase Constructor
ExtensionBase Class See Also

Initializes a new instance of the ExtensionBase class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ExtensionBase(
    string name,
    string version
)
Visual Basic
Public Sub New ( _
    name As String, _
    version As String _
)

Parameters

name
Type: System..::..String
User-friendly extension name.
version
Type: System..::..String
User-friendly extension version.

See Also

ExtensionBase Class


ExtensionBase Methods

[image] [image]

Microsoft WebMatrix 2 Beta
ExtensionBase Methods
ExtensionBase Class See Also

The ExtensionBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnWebMatrixHostChanged | Method that is called when the WebMatrixHost property changes
Public method | ToString | (Inherited from Object.)

See Also

ExtensionBase Class


OnWebMatrixHostChanged Method

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..OnWebMatrixHostChanged Method
ExtensionBase Class See Also

Method that is called when the WebMatrixHost property changes

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
protected virtual void OnWebMatrixHostChanged(
    IWebMatrixHost oldValue,
    IWebMatrixHost newValue
)
Visual Basic
Protected Overridable Sub OnWebMatrixHostChanged ( _
    oldValue As IWebMatrixHost, _
    newValue As IWebMatrixHost _
)

Parameters

oldValue
Type: Microsoft.WebMatrix.Extensibility..::..IWebMatrixHost
Old value.
newValue
Type: Microsoft.WebMatrix.Extensibility..::..IWebMatrixHost
New value.

See Also

ExtensionBase Class


ExtensionBase Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ExtensionBase Properties
ExtensionBase Class See Also

The ExtensionBase type exposes the following members.

Properties

 | Name | Description
Public property | DashboardItems | Gets a sequence of Dashboard items.
Protected property | DashboardItemsCollection | Gets a collection of IDashboardItem instances.
Public property | Name | Gets the user-friendly name of the extension.
Public property | RibbonItems | Gets a sequence of Ribbon items that are always available.
Protected property | RibbonItemsCollection | Gets a collection of IRibbonItem instances.
Public property | Version | Gets the user-friendly version of the extension.
Protected property | WebMatrixHost | Gets the IWebMatrixHost host instance.

See Also

ExtensionBase Class


DashboardItems Property

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..DashboardItems Property
ExtensionBase Class See Also

Gets a sequence of Dashboard items.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IEnumerable<IDashboardItem> DashboardItems { get; }
Visual Basic
Public ReadOnly Property DashboardItems As IEnumerable(Of IDashboardItem)
    Get

Implements

IExtension..::..DashboardItems

See Also

ExtensionBase Class


DashboardItemsCollection Property

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..DashboardItemsCollection Property
ExtensionBase Class See Also

Gets a collection of IDashboardItem instances.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
protected ObservableCollection<IDashboardItem> DashboardItemsCollection { get; private set; }
Visual Basic
Protected Property DashboardItemsCollection As ObservableCollection(Of IDashboardItem)
    Get
    Private Set

See Also

ExtensionBase Class


Name Property

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..Name Property
ExtensionBase Class Example See Also

Gets the user-friendly name of the extension.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

Implements

IExtension..::..Name

Examples

MyExtension

See Also

ExtensionBase Class


RibbonItems Property

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..RibbonItems Property
ExtensionBase Class See Also

Gets a sequence of Ribbon items that are always available.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IEnumerable<IRibbonItem> RibbonItems { get; }
Visual Basic
Public ReadOnly Property RibbonItems As IEnumerable(Of IRibbonItem)
    Get

Implements

IExtension..::..RibbonItems

See Also

ExtensionBase Class


RibbonItemsCollection Property

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..RibbonItemsCollection Property
ExtensionBase Class See Also

Gets a collection of IRibbonItem instances.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
protected Collection<IRibbonItem> RibbonItemsCollection { get; private set; }
Visual Basic
Protected Property RibbonItemsCollection As Collection(Of IRibbonItem)
    Get
    Private Set

Remarks

Must be set in the constructor and not modified afterward.

See Also

ExtensionBase Class


Version Property

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..Version Property
ExtensionBase Class Example See Also

Gets the user-friendly version of the extension.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Version { get; private set; }
Visual Basic
Public Property Version As String
    Get
    Private Set

Implements

IExtension..::..Version

Examples

1.0

See Also

ExtensionBase Class


WebMatrixHost Property

[image]

Microsoft WebMatrix 2 Beta
ExtensionBase..::..WebMatrixHost Property
ExtensionBase Class See Also

Gets the IWebMatrixHost host instance.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
[ImportAttribute(typeof(IWebMatrixHost))]
protected IWebMatrixHost WebMatrixHost { get; private set; }
Visual Basic
<ImportAttribute(GetType(IWebMatrixHost))> _
Protected Property WebMatrixHost As IWebMatrixHost
    Get
    Private Set

See Also

ExtensionBase Class


HelpInvokedEventArgs Class

[image]

Microsoft WebMatrix 2 Beta
HelpInvokedEventArgs Class
Members See Also

Class that represents the event arguments for a help request.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class HelpInvokedEventArgs : CancelEventArgs
Visual Basic
Public Class HelpInvokedEventArgs _
    Inherits CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Microsoft.WebMatrix.Extensibility..::..HelpInvokedEventArgs

See Also

HelpInvokedEventArgs Members


HelpInvokedEventArgs Members

[image] [image]

Microsoft WebMatrix 2 Beta
HelpInvokedEventArgs Members
HelpInvokedEventArgs Class Constructors Methods Properties See Also

The HelpInvokedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HelpInvokedEventArgs | Initializes a new instance of the HelpInvokedEventArgs class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | (Inherited from CancelEventArgs.)
Public property | Context | Gets a value indicating the context for the help request (such as the focused UI element).

See Also

HelpInvokedEventArgs Class


HelpInvokedEventArgs Constructor

[image]

Microsoft WebMatrix 2 Beta
HelpInvokedEventArgs Constructor
HelpInvokedEventArgs Class See Also

Initializes a new instance of the HelpInvokedEventArgs class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public HelpInvokedEventArgs(
    Object context
)
Visual Basic
Public Sub New ( _
    context As Object _
)

Parameters

context
Type: System..::..Object
Context for the event.

See Also

HelpInvokedEventArgs Class


HelpInvokedEventArgs Methods

[image] [image]

Microsoft WebMatrix 2 Beta
HelpInvokedEventArgs Methods
HelpInvokedEventArgs Class See Also

The HelpInvokedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

HelpInvokedEventArgs Class


HelpInvokedEventArgs Properties

[image] [image]

Microsoft WebMatrix 2 Beta
HelpInvokedEventArgs Properties
HelpInvokedEventArgs Class See Also

The HelpInvokedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | (Inherited from CancelEventArgs.)
Public property | Context | Gets a value indicating the context for the help request (such as the focused UI element).

See Also

HelpInvokedEventArgs Class


Context Property

[image]

Microsoft WebMatrix 2 Beta
HelpInvokedEventArgs..::..Context Property
HelpInvokedEventArgs Class See Also

Gets a value indicating the context for the help request (such as the focused UI element).

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Object Context { get; private set; }
Visual Basic
Public Property Context As Object
    Get
    Private Set

See Also

HelpInvokedEventArgs Class


ICommandId Interface

[image]

Microsoft WebMatrix 2 Beta
ICommandId Interface
Members See Also

Class that defines a command ID.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface ICommandId
Visual Basic
Public Interface ICommandId

See Also

ICommandId Members


ICommandId Members

[image] [image]

Microsoft WebMatrix 2 Beta
ICommandId Members
ICommandId Interface Properties See Also

The ICommandId type exposes the following members.

Properties

 | Name | Description
Public property | CommandName | Gets the name of the command (for diagnostic purposes).
Public property | GroupId | Gets the group ID for the command.
Public property | Id | Gets a unique ID for the command (within its group).

See Also

ICommandId Interface


ICommandId Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ICommandId Properties
ICommandId Interface See Also

The ICommandId type exposes the following members.

Properties

 | Name | Description
Public property | CommandName | Gets the name of the command (for diagnostic purposes).
Public property | GroupId | Gets the group ID for the command.
Public property | Id | Gets a unique ID for the command (within its group).

See Also

ICommandId Interface


CommandName Property

[image]

Microsoft WebMatrix 2 Beta
ICommandId..::..CommandName Property
ICommandId Interface See Also

Gets the name of the command (for diagnostic purposes).

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string CommandName { get; }
Visual Basic
ReadOnly Property CommandName As String
    Get

See Also

ICommandId Interface


GroupId Property

[image]

Microsoft WebMatrix 2 Beta
ICommandId..::..GroupId Property
ICommandId Interface See Also

Gets the group ID for the command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Guid GroupId { get; }
Visual Basic
ReadOnly Property GroupId As Guid
    Get

See Also

ICommandId Interface


Id Property

[image]

Microsoft WebMatrix 2 Beta
ICommandId..::..Id Property
ICommandId Interface See Also

Gets a unique ID for the command (within its group).

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
int Id { get; }
Visual Basic
ReadOnly Property Id As Integer
    Get

See Also

ICommandId Interface


IContextMenuItem Interface

[image]

Microsoft WebMatrix 2 Beta
IContextMenuItem Interface
Members See Also

Interface for representing an item in a context menu.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IContextMenuItem
Visual Basic
Public Interface IContextMenuItem

See Also

IContextMenuItem Members


IContextMenuItem Members

[image] [image]

Microsoft WebMatrix 2 Beta
IContextMenuItem Members
IContextMenuItem Interface Properties See Also

The IContextMenuItem type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is selected.
Public property | CommandParameter | Gets or sets the parameter to pass to the Command.
Public property | Icon | Gets a 16x16 image for the item.
Public property | Label | Gets a label for the item.

See Also

IContextMenuItem Interface


IContextMenuItem Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IContextMenuItem Properties
IContextMenuItem Interface See Also

The IContextMenuItem type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is selected.
Public property | CommandParameter | Gets or sets the parameter to pass to the Command.
Public property | Icon | Gets a 16x16 image for the item.
Public property | Label | Gets a label for the item.

See Also

IContextMenuItem Interface


Command Property

[image]

Microsoft WebMatrix 2 Beta
IContextMenuItem..::..Command Property
IContextMenuItem Interface See Also

Gets the command to invoke when the button is selected.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand Command { get; }
Visual Basic
ReadOnly Property Command As ICommand
    Get

See Also

IContextMenuItem Interface


CommandParameter Property

[image]

Microsoft WebMatrix 2 Beta
IContextMenuItem..::..CommandParameter Property
IContextMenuItem Interface See Also

Gets or sets the parameter to pass to the Command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Object CommandParameter { get; }
Visual Basic
ReadOnly Property CommandParameter As Object
    Get

See Also

IContextMenuItem Interface


Icon Property

[image]

Microsoft WebMatrix 2 Beta
IContextMenuItem..::..Icon Property
IContextMenuItem Interface See Also

Gets a 16x16 image for the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ImageSource Icon { get; }
Visual Basic
ReadOnly Property Icon As ImageSource
    Get

See Also

IContextMenuItem Interface


Label Property

[image]

Microsoft WebMatrix 2 Beta
IContextMenuItem..::..Label Property
IContextMenuItem Interface See Also

Gets a label for the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Label { get; }
Visual Basic
ReadOnly Property Label As String
    Get

See Also

IContextMenuItem Interface


IDashboardItem Interface

[image]

Microsoft WebMatrix 2 Beta
IDashboardItem Interface
Members See Also

Interface for representing an item on the dashboard.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IDashboardItem
Visual Basic
Public Interface IDashboardItem

See Also

IDashboardItem Members


IDashboardItem Members

[image] [image]

Microsoft WebMatrix 2 Beta
IDashboardItem Members
IDashboardItem Interface Properties See Also

The IDashboardItem type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the item's description.
Public property | Image | Gets a 32x32 image to display next to the item.
Public property | Title | Gets the item's title.
Public property | Uri | Gets the URI to navigate to when the item is clicked.

See Also

IDashboardItem Interface


IDashboardItem Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IDashboardItem Properties
IDashboardItem Interface See Also

The IDashboardItem type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the item's description.
Public property | Image | Gets a 32x32 image to display next to the item.
Public property | Title | Gets the item's title.
Public property | Uri | Gets the URI to navigate to when the item is clicked.

See Also

IDashboardItem Interface


Description Property

[image]

Microsoft WebMatrix 2 Beta
IDashboardItem..::..Description Property
IDashboardItem Interface See Also

Gets the item's description.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get

See Also

IDashboardItem Interface


Image Property

[image]

Microsoft WebMatrix 2 Beta
IDashboardItem..::..Image Property
IDashboardItem Interface See Also

Gets a 32x32 image to display next to the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ImageSource Image { get; }
Visual Basic
ReadOnly Property Image As ImageSource
    Get

See Also

IDashboardItem Interface


Title Property

[image]

Microsoft WebMatrix 2 Beta
IDashboardItem..::..Title Property
IDashboardItem Interface See Also

Gets the item's title.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Title { get; }
Visual Basic
ReadOnly Property Title As String
    Get

See Also

IDashboardItem Interface


Uri Property

[image]

Microsoft WebMatrix 2 Beta
IDashboardItem..::..Uri Property
IDashboardItem Interface See Also

Gets the URI to navigate to when the item is clicked.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Uri Uri { get; }
Visual Basic
ReadOnly Property Uri As Uri
    Get

See Also

IDashboardItem Interface


IDialogContent Interface

[image]

Microsoft WebMatrix 2 Beta
IDialogContent Interface
Members See Also

Interface for providing custom content for a dialog and having control over when it closes.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IDialogContent
Visual Basic
Public Interface IDialogContent

See Also

IDialogContent Members


IDialogContent Members

[image] [image]

Microsoft WebMatrix 2 Beta
IDialogContent Members
IDialogContent Interface Events See Also

The IDialogContent type exposes the following members.

Events

 | Name | Description
Public event | CloseDialog | Event to invoke when the dialog should close.

See Also

IDialogContent Interface


IDialogContent Events

[image] [image]

Microsoft WebMatrix 2 Beta
IDialogContent Events
IDialogContent Interface See Also

The IDialogContent type exposes the following members.

Events

 | Name | Description
Public event | CloseDialog | Event to invoke when the dialog should close.

See Also

IDialogContent Interface


CloseDialog Event

[image]

Microsoft WebMatrix 2 Beta
IDialogContent..::..CloseDialog Event
IDialogContent Interface See Also

Event to invoke when the dialog should close.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event EventHandler<EventArgs> CloseDialog
Visual Basic
Event CloseDialog As EventHandler(Of EventArgs)

See Also

IDialogContent Interface


IEditorContainer Interface

[image]

Microsoft WebMatrix 2 Beta
IEditorContainer Interface
Members See Also

Interface to pass into the GetIEditor command

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IEditorContainer
Visual Basic
Public Interface IEditorContainer

See Also

IEditorContainer Members


IEditorContainer Members

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorContainer Members
IEditorContainer Interface Properties See Also

The IEditorContainer type exposes the following members.

Properties

 | Name | Description
Public property | Editor | Fill this container with the data

See Also

IEditorContainer Interface


IEditorContainer Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorContainer Properties
IEditorContainer Interface See Also

The IEditorContainer type exposes the following members.

Properties

 | Name | Description
Public property | Editor | Fill this container with the data

See Also

IEditorContainer Interface


Editor Property

[image]

Microsoft WebMatrix 2 Beta
IEditorContainer..::..Editor Property
IEditorContainer Interface See Also

Fill this container with the data

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEditorExt Editor { get; set; }
Visual Basic
Property Editor As IEditorExt
    Get
    Set

See Also

IEditorContainer Interface


IEditorExt Interface

[image]

Microsoft WebMatrix 2 Beta
IEditorExt Interface
Members See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IEditorExt : IDisposable
Visual Basic
Public Interface IEditorExt _
    Inherits IDisposable

See Also

IEditorExt Members


IEditorExt Members

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorExt Members
IEditorExt Interface Methods Properties Events See Also

The IEditorExt type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)

Properties

 | Name | Description
Public property | Dirty |
Public property | FilePath |
Public property | ReadOnly | When true, the user can't edit the text
Public property | ServiceProvider |
Public property | Text |

Events

 | Name | Description
Public event | DirtyChanged |
Public event | ReadOnlyChanging | Readonly is changing

See Also

IEditorExt Interface


IEditorExt Methods

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorExt Methods
IEditorExt Interface See Also

The IEditorExt type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)

See Also

IEditorExt Interface


IEditorExt Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorExt Properties
IEditorExt Interface See Also

The IEditorExt type exposes the following members.

Properties

 | Name | Description
Public property | Dirty |
Public property | FilePath |
Public property | ReadOnly | When true, the user can't edit the text
Public property | ServiceProvider |
Public property | Text |

See Also

IEditorExt Interface


Dirty Property

[image]

Microsoft WebMatrix 2 Beta
IEditorExt..::..Dirty Property
IEditorExt Interface See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool Dirty { get; set; }
Visual Basic
Property Dirty As Boolean
    Get
    Set

See Also

IEditorExt Interface


FilePath Property

[image]

Microsoft WebMatrix 2 Beta
IEditorExt..::..FilePath Property
IEditorExt Interface See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string FilePath { get; set; }
Visual Basic
Property FilePath As String
    Get
    Set

See Also

IEditorExt Interface


ReadOnly Property

[image]

Microsoft WebMatrix 2 Beta
IEditorExt..::..ReadOnly Property
IEditorExt Interface See Also

When true, the user can't edit the text

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool ReadOnly { get; set; }
Visual Basic
Property ReadOnly As Boolean
    Get
    Set

See Also

IEditorExt Interface


ServiceProvider Property

[image]

Microsoft WebMatrix 2 Beta
IEditorExt..::..ServiceProvider Property
IEditorExt Interface See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IServiceProvider ServiceProvider { get; }
Visual Basic
ReadOnly Property ServiceProvider As IServiceProvider
    Get

See Also

IEditorExt Interface


Text Property

[image]

Microsoft WebMatrix 2 Beta
IEditorExt..::..Text Property
IEditorExt Interface See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Text { get; set; }
Visual Basic
Property Text As String
    Get
    Set

See Also

IEditorExt Interface


IEditorExt Events

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorExt Events
IEditorExt Interface See Also

The IEditorExt type exposes the following members.

Events

 | Name | Description
Public event | DirtyChanged |
Public event | ReadOnlyChanging | Readonly is changing

See Also

IEditorExt Interface


DirtyChanged Event

[image]

Microsoft WebMatrix 2 Beta
IEditorExt..::..DirtyChanged Event
IEditorExt Interface See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event EventHandler DirtyChanged
Visual Basic
Event DirtyChanged As EventHandler

See Also

IEditorExt Interface


ReadOnlyChanging Event

[image]

Microsoft WebMatrix 2 Beta
IEditorExt..::..ReadOnlyChanging Event
IEditorExt Interface See Also

Readonly is changing

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event EventHandler<CancelEventArgs> ReadOnlyChanging
Visual Basic
Event ReadOnlyChanging As EventHandler(Of CancelEventArgs)

See Also

IEditorExt Interface


IEditorWorkspace Interface

[image]

Microsoft WebMatrix 2 Beta
IEditorWorkspace Interface
Members See Also

Interface that represents the WebMatrix editor workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IEditorWorkspace : IWorkspace
Visual Basic
Public Interface IEditorWorkspace _
    Inherits IWorkspace

See Also

IEditorWorkspace Members


IEditorWorkspace Members

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorWorkspace Members
IEditorWorkspace Interface Properties See Also

The IEditorWorkspace type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of the workspace. (Inherited from IWorkspace.)
Public property | Image | Gets a 28x25 image for the workspace. (Inherited from IWorkspace.)
Public property | Title | Gets the title of the workspace. (Inherited from IWorkspace.)

See Also

IEditorWorkspace Interface


IEditorWorkspace Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorWorkspace Properties
IEditorWorkspace Interface See Also

The IEditorWorkspace type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of the workspace. (Inherited from IWorkspace.)
Public property | Image | Gets a 28x25 image for the workspace. (Inherited from IWorkspace.)
Public property | Title | Gets the title of the workspace. (Inherited from IWorkspace.)

See Also

IEditorWorkspace Interface


IExtension Interface

[image]

Microsoft WebMatrix 2 Beta
IExtension Interface
Members See Also

Interface that all WebMatrix extensions are required to implement.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IExtension
Visual Basic
Public Interface IExtension

See Also

IExtension Members


IExtension Members

[image] [image]

Microsoft WebMatrix 2 Beta
IExtension Members
IExtension Interface Properties See Also

The IExtension type exposes the following members.

Properties

 | Name | Description
Public property | DashboardItems | Gets a sequence of Dashboard items.
Public property | Name | Gets the user-friendly name of the extension.
Public property | RibbonItems | Gets a sequence of Ribbon items that are always available.
Public property | Version | Gets the user-friendly version of the extension.

See Also

IExtension Interface


IExtension Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IExtension Properties
IExtension Interface See Also

The IExtension type exposes the following members.

Properties

 | Name | Description
Public property | DashboardItems | Gets a sequence of Dashboard items.
Public property | Name | Gets the user-friendly name of the extension.
Public property | RibbonItems | Gets a sequence of Ribbon items that are always available.
Public property | Version | Gets the user-friendly version of the extension.

See Also

IExtension Interface


DashboardItems Property

[image]

Microsoft WebMatrix 2 Beta
IExtension..::..DashboardItems Property
IExtension Interface See Also

Gets a sequence of Dashboard items.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<IDashboardItem> DashboardItems { get; }
Visual Basic
ReadOnly Property DashboardItems As IEnumerable(Of IDashboardItem)
    Get

See Also

IExtension Interface


Name Property

[image]

Microsoft WebMatrix 2 Beta
IExtension..::..Name Property
IExtension Interface Example See Also

Gets the user-friendly name of the extension.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Examples

MyExtension

See Also

IExtension Interface


RibbonItems Property

[image]

Microsoft WebMatrix 2 Beta
IExtension..::..RibbonItems Property
IExtension Interface See Also

Gets a sequence of Ribbon items that are always available.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<IRibbonItem> RibbonItems { get; }
Visual Basic
ReadOnly Property RibbonItems As IEnumerable(Of IRibbonItem)
    Get

See Also

IExtension Interface


Version Property

[image]

Microsoft WebMatrix 2 Beta
IExtension..::..Version Property
IExtension Interface Example See Also

Gets the user-friendly version of the extension.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Version { get; }
Visual Basic
ReadOnly Property Version As String
    Get

Examples

1.0

See Also

IExtension Interface


IHostCommands Interface

[image]

Microsoft WebMatrix 2 Beta
IHostCommands Interface
Members See Also

Interface for accessing commands exposed by the host.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IHostCommands
Visual Basic
Public Interface IHostCommands

See Also

IHostCommands Members


IHostCommands Members

[image] [image]

Microsoft WebMatrix 2 Beta
IHostCommands Members
IHostCommands Interface Methods Properties See Also

The IHostCommands type exposes the following members.

Methods

 | Name | Description
Public method | GetCommand | Gets (or creates) an arbitrary command identified by group and ID.

Properties

 | Name | Description
Public property | Copy | Gets the "copy" command.
Public property | Cut | Gets the "cut" command.
Public property | Exit | Gets the "exit" command.
Public property | Paste | Gets the "paste" command.

See Also

IHostCommands Interface


IHostCommands Methods

[image] [image]

Microsoft WebMatrix 2 Beta
IHostCommands Methods
IHostCommands Interface See Also

The IHostCommands type exposes the following members.

Methods

 | Name | Description
Public method | GetCommand | Gets (or creates) an arbitrary command identified by group and ID.

See Also

IHostCommands Interface


GetCommand Method

[image]

Microsoft WebMatrix 2 Beta
IHostCommands..::..GetCommand Method
IHostCommands Interface See Also

Gets (or creates) an arbitrary command identified by group and ID.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand GetCommand(
    Guid group,
    int id
)
Visual Basic
Function GetCommand ( _
    group As Guid, _
    id As Integer _
) As ICommand

Parameters

group
Type: System..::..Guid
Command group.
id
Type: System..::..Int32
Command identifier.

Return Value

ICommand reference.

See Also

IHostCommands Interface


IHostCommands Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IHostCommands Properties
IHostCommands Interface See Also

The IHostCommands type exposes the following members.

Properties

 | Name | Description
Public property | Copy | Gets the "copy" command.
Public property | Cut | Gets the "cut" command.
Public property | Exit | Gets the "exit" command.
Public property | Paste | Gets the "paste" command.

See Also

IHostCommands Interface


Copy Property

[image]

Microsoft WebMatrix 2 Beta
IHostCommands..::..Copy Property
IHostCommands Interface See Also

Gets the "copy" command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand Copy { get; }
Visual Basic
ReadOnly Property Copy As ICommand
    Get

See Also

IHostCommands Interface


Cut Property

[image]

Microsoft WebMatrix 2 Beta
IHostCommands..::..Cut Property
IHostCommands Interface See Also

Gets the "cut" command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand Cut { get; }
Visual Basic
ReadOnly Property Cut As ICommand
    Get

See Also

IHostCommands Interface


Exit Property

[image]

Microsoft WebMatrix 2 Beta
IHostCommands..::..Exit Property
IHostCommands Interface See Also

Gets the "exit" command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand Exit { get; }
Visual Basic
ReadOnly Property Exit As ICommand
    Get

See Also

IHostCommands Interface


Paste Property

[image]

Microsoft WebMatrix 2 Beta
IHostCommands..::..Paste Property
IHostCommands Interface See Also

Gets the "paste" command.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand Paste { get; }
Visual Basic
ReadOnly Property Paste As ICommand
    Get

See Also

IHostCommands Interface


IProtectPathInfo Interface

[image]

Microsoft WebMatrix 2 Beta
IProtectPathInfo Interface
Members See Also

Interface for specifying information about protected paths.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IProtectPathInfo
Visual Basic
Public Interface IProtectPathInfo

See Also

IProtectPathInfo Members


IProtectPathInfo Members

[image] [image]

Microsoft WebMatrix 2 Beta
IProtectPathInfo Members
IProtectPathInfo Interface Properties See Also

The IProtectPathInfo type exposes the following members.

Properties

 | Name | Description
Public property | AllowChanges | Value indicating whether the folder or file is protected.
Public property | AllowInNestedFolders | Value indicating whether to allow the relative path to match in nested folders (i.e., sub-directories).
Public property | RelativePath | Relative path of the folder or file.

See Also

IProtectPathInfo Interface


IProtectPathInfo Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IProtectPathInfo Properties
IProtectPathInfo Interface See Also

The IProtectPathInfo type exposes the following members.

Properties

 | Name | Description
Public property | AllowChanges | Value indicating whether the folder or file is protected.
Public property | AllowInNestedFolders | Value indicating whether to allow the relative path to match in nested folders (i.e., sub-directories).
Public property | RelativePath | Relative path of the folder or file.

See Also

IProtectPathInfo Interface


AllowChanges Property

[image]

Microsoft WebMatrix 2 Beta
IProtectPathInfo..::..AllowChanges Property
IProtectPathInfo Interface See Also

Value indicating whether the folder or file is protected.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool AllowChanges { get; }
Visual Basic
ReadOnly Property AllowChanges As Boolean
    Get

See Also

IProtectPathInfo Interface


AllowInNestedFolders Property

[image]

Microsoft WebMatrix 2 Beta
IProtectPathInfo..::..AllowInNestedFolders Property
IProtectPathInfo Interface See Also

Value indicating whether to allow the relative path to match in nested folders (i.e., sub-directories).

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool AllowInNestedFolders { get; }
Visual Basic
ReadOnly Property AllowInNestedFolders As Boolean
    Get

See Also

IProtectPathInfo Interface


RelativePath Property

[image]

Microsoft WebMatrix 2 Beta
IProtectPathInfo..::..RelativePath Property
IProtectPathInfo Interface See Also

Relative path of the folder or file.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string RelativePath { get; }
Visual Basic
ReadOnly Property RelativePath As String
    Get

See Also

IProtectPathInfo Interface


IRibbonButton Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonButton Interface
Members See Also

Interface for representing a button on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonButton : IRibbonItem
Visual Basic
Public Interface IRibbonButton _
    Inherits IRibbonItem

See Also

IRibbonButton Members


IRibbonButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonButton Members
IRibbonButton Interface Properties See Also

The IRibbonButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is pressed.
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed.
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button.
Public property | SmallImage | Gets a 16x16 image for the button.

See Also

IRibbonButton Interface


IRibbonButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonButton Properties
IRibbonButton Interface See Also

The IRibbonButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is pressed.
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed.
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button.
Public property | SmallImage | Gets a 16x16 image for the button.

See Also

IRibbonButton Interface


Command Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonButton..::..Command Property
IRibbonButton Interface See Also

Gets the command to invoke when the button is pressed.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand Command { get; }
Visual Basic
ReadOnly Property Command As ICommand
    Get

See Also

IRibbonButton Interface


CommandId Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonButton..::..CommandId Property
IRibbonButton Interface See Also

Gets or sets the command ID to invoke when the button is pressed.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommandId CommandId { get; }
Visual Basic
ReadOnly Property CommandId As ICommandId
    Get

See Also

IRibbonButton Interface


CommandParameter Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonButton..::..CommandParameter Property
IRibbonButton Interface See Also

Gets or sets the command parameter to pass to the Command or CommandId.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Object CommandParameter { get; }
Visual Basic
ReadOnly Property CommandParameter As Object
    Get

See Also

IRibbonButton Interface


LargeImage Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonButton..::..LargeImage Property
IRibbonButton Interface See Also

Gets a 32x32 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ImageSource LargeImage { get; }
Visual Basic
ReadOnly Property LargeImage As ImageSource
    Get

See Also

IRibbonButton Interface


SmallImage Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonButton..::..SmallImage Property
IRibbonButton Interface See Also

Gets a 16x16 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ImageSource SmallImage { get; }
Visual Basic
ReadOnly Property SmallImage As ImageSource
    Get

See Also

IRibbonButton Interface


IRibbonContextualTab Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonContextualTab Interface
Members See Also

Interface for representing a contextual tab on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonContextualTab : IRibbonItem
Visual Basic
Public Interface IRibbonContextualTab _
    Inherits IRibbonItem

See Also

IRibbonContextualTab Members


IRibbonContextualTab Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonContextualTab Members
IRibbonContextualTab Interface Properties See Also

The IRibbonContextualTab type exposes the following members.

Properties

 | Name | Description
Public property | IsVisible | Gets a value indicating whether the contextual tab is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)

See Also

IRibbonContextualTab Interface


IRibbonContextualTab Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonContextualTab Properties
IRibbonContextualTab Interface See Also

The IRibbonContextualTab type exposes the following members.

Properties

 | Name | Description
Public property | IsVisible | Gets a value indicating whether the contextual tab is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)

See Also

IRibbonContextualTab Interface


IsVisible Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonContextualTab..::..IsVisible Property
IRibbonContextualTab Interface See Also

Gets a value indicating whether the contextual tab is visible.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool IsVisible { get; }
Visual Basic
ReadOnly Property IsVisible As Boolean
    Get

See Also

IRibbonContextualTab Interface


Items Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonContextualTab..::..Items Property
IRibbonContextualTab Interface See Also

Gets a sequence of IRibbonItem instances.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<IRibbonItem> Items { get; }
Visual Basic
ReadOnly Property Items As IEnumerable(Of IRibbonItem)
    Get

See Also

IRibbonContextualTab Interface


IRibbonGalleryCategory Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory Interface
Members See Also

Interface that represents a category in a Ribbon gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonGalleryCategory
Visual Basic
Public Interface IRibbonGalleryCategory

See Also

IRibbonGalleryCategory Members


IRibbonGalleryCategory Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory Members
IRibbonGalleryCategory Interface Properties See Also

The IRibbonGalleryCategory type exposes the following members.

Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns to use for laying out items in the category.
Public property | Header | Gets the header text.
Public property | ItemContainerStyle | Gets a Style used for the containers of items in the category.
Public property | Items | Gets a sequence of items in the category.
Public property | ItemTemplate | Gets a DataTemplate used to display the items in the category.

See Also

IRibbonGalleryCategory Interface


IRibbonGalleryCategory Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory Properties
IRibbonGalleryCategory Interface See Also

The IRibbonGalleryCategory type exposes the following members.

Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns to use for laying out items in the category.
Public property | Header | Gets the header text.
Public property | ItemContainerStyle | Gets a Style used for the containers of items in the category.
Public property | Items | Gets a sequence of items in the category.
Public property | ItemTemplate | Gets a DataTemplate used to display the items in the category.

See Also

IRibbonGalleryCategory Interface


ColumnCount Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory..::..ColumnCount Property
IRibbonGalleryCategory Interface See Also

Gets the number of columns to use for laying out items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
int ColumnCount { get; }
Visual Basic
ReadOnly Property ColumnCount As Integer
    Get

See Also

IRibbonGalleryCategory Interface


Header Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory..::..Header Property
IRibbonGalleryCategory Interface See Also

Gets the header text.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Header { get; }
Visual Basic
ReadOnly Property Header As String
    Get

See Also

IRibbonGalleryCategory Interface


ItemContainerStyle Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory..::..ItemContainerStyle Property
IRibbonGalleryCategory Interface See Also

Gets a Style used for the containers of items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Style ItemContainerStyle { get; }
Visual Basic
ReadOnly Property ItemContainerStyle As Style
    Get

See Also

IRibbonGalleryCategory Interface


Items Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory..::..Items Property
IRibbonGalleryCategory Interface See Also

Gets a sequence of items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<Object> Items { get; }
Visual Basic
ReadOnly Property Items As IEnumerable(Of Object)
    Get

See Also

IRibbonGalleryCategory Interface


ItemTemplate Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonGalleryCategory..::..ItemTemplate Property
IRibbonGalleryCategory Interface See Also

Gets a DataTemplate used to display the items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
DataTemplate ItemTemplate { get; }
Visual Basic
ReadOnly Property ItemTemplate As DataTemplate
    Get

See Also

IRibbonGalleryCategory Interface


IRibbonGroup Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonGroup Interface
Members See Also

Interface for representing a group on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonGroup : IRibbonItem
Visual Basic
Public Interface IRibbonGroup _
    Inherits IRibbonItem

See Also

IRibbonGroup Members


IRibbonGroup Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonGroup Members
IRibbonGroup Interface Properties See Also

The IRibbonGroup type exposes the following members.

Properties

 | Name | Description
Public property | IsVisible | Gets a value indicating whether the group is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)

See Also

IRibbonGroup Interface


IRibbonGroup Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonGroup Properties
IRibbonGroup Interface See Also

The IRibbonGroup type exposes the following members.

Properties

 | Name | Description
Public property | IsVisible | Gets a value indicating whether the group is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)

See Also

IRibbonGroup Interface


IsVisible Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonGroup..::..IsVisible Property
IRibbonGroup Interface See Also

Gets a value indicating whether the group is visible.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool IsVisible { get; set; }
Visual Basic
Property IsVisible As Boolean
    Get
    Set

See Also

IRibbonGroup Interface


Items Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonGroup..::..Items Property
IRibbonGroup Interface See Also

Gets a sequence of IRibbonItem instances.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<IRibbonItem> Items { get; }
Visual Basic
ReadOnly Property Items As IEnumerable(Of IRibbonItem)
    Get

See Also

IRibbonGroup Interface


IRibbonItem Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonItem Interface
Members See Also

Interface for representing an item on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonItem
Visual Basic
Public Interface IRibbonItem

See Also

IRibbonItem Members


IRibbonItem Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonItem Members
IRibbonItem Interface Properties See Also

The IRibbonItem type exposes the following members.

Properties

 | Name | Description
Public property | Label | Gets a label for the item.

See Also

IRibbonItem Interface


IRibbonItem Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonItem Properties
IRibbonItem Interface See Also

The IRibbonItem type exposes the following members.

Properties

 | Name | Description
Public property | Label | Gets a label for the item.

See Also

IRibbonItem Interface


Label Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonItem..::..Label Property
IRibbonItem Interface See Also

Gets a label for the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Label { get; }
Visual Basic
ReadOnly Property Label As String
    Get

See Also

IRibbonItem Interface


IRibbonMenuButton Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonMenuButton Interface
Members See Also

Interface for representing a menu-button on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonMenuButton : IRibbonItem
Visual Basic
Public Interface IRibbonMenuButton _
    Inherits IRibbonItem

See Also

IRibbonMenuButton Members


IRibbonMenuButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonMenuButton Members
IRibbonMenuButton Interface Properties See Also

The IRibbonMenuButton type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets a sequence of IRibbonButtons to show when the menu-button is pressed.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button.
Public property | SmallImage | Gets a 16x16 image for the button.

See Also

IRibbonMenuButton Interface


IRibbonMenuButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonMenuButton Properties
IRibbonMenuButton Interface See Also

The IRibbonMenuButton type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets a sequence of IRibbonButtons to show when the menu-button is pressed.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button.
Public property | SmallImage | Gets a 16x16 image for the button.

See Also

IRibbonMenuButton Interface


Items Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonMenuButton..::..Items Property
IRibbonMenuButton Interface See Also

Gets a sequence of IRibbonButtons to show when the menu-button is pressed.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<IRibbonButton> Items { get; }
Visual Basic
ReadOnly Property Items As IEnumerable(Of IRibbonButton)
    Get

See Also

IRibbonMenuButton Interface


LargeImage Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonMenuButton..::..LargeImage Property
IRibbonMenuButton Interface See Also

Gets a 32x32 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ImageSource LargeImage { get; }
Visual Basic
ReadOnly Property LargeImage As ImageSource
    Get

See Also

IRibbonMenuButton Interface


SmallImage Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonMenuButton..::..SmallImage Property
IRibbonMenuButton Interface See Also

Gets a 16x16 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ImageSource SmallImage { get; }
Visual Basic
ReadOnly Property SmallImage As ImageSource
    Get

See Also

IRibbonMenuButton Interface


IRibbonSplitButton Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButton Interface
Members See Also

Interface for representing a split-button on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonSplitButton : IRibbonButton,
    IRibbonItem
Visual Basic
Public Interface IRibbonSplitButton _
    Inherits IRibbonButton, IRibbonItem

See Also

IRibbonSplitButton Members


IRibbonSplitButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButton Members
IRibbonSplitButton Interface Properties See Also

The IRibbonSplitButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from IRibbonButton.)
Public property | Items | Gets a sequence of IRibbonButtons to show when the split-button is expanded.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button. (Inherited from IRibbonButton.)
Public property | SmallImage | Gets a 16x16 image for the button. (Inherited from IRibbonButton.)

See Also

IRibbonSplitButton Interface


IRibbonSplitButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButton Properties
IRibbonSplitButton Interface See Also

The IRibbonSplitButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from IRibbonButton.)
Public property | Items | Gets a sequence of IRibbonButtons to show when the split-button is expanded.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button. (Inherited from IRibbonButton.)
Public property | SmallImage | Gets a 16x16 image for the button. (Inherited from IRibbonButton.)

See Also

IRibbonSplitButton Interface


Items Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButton..::..Items Property
IRibbonSplitButton Interface See Also

Gets a sequence of IRibbonButtons to show when the split-button is expanded.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<IRibbonButton> Items { get; }
Visual Basic
ReadOnly Property Items As IEnumerable(Of IRibbonButton)
    Get

See Also

IRibbonSplitButton Interface


IRibbonSplitButtonGallery Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery Interface
Members See Also

Interface for representing a split-button on the Ribbon that expands to a gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonSplitButtonGallery : IRibbonButton,
    IRibbonItem
Visual Basic
Public Interface IRibbonSplitButtonGallery _
    Inherits IRibbonButton, IRibbonItem

See Also

IRibbonSplitButtonGallery Members


IRibbonSplitButtonGallery Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery Members
IRibbonSplitButtonGallery Interface Properties See Also

The IRibbonSplitButtonGallery type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Gets a sequence of category instances for the gallery.
Public property | Command | Gets the command to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from IRibbonButton.)
Public property | GalleryClosing | Gets an action to invoke when the gallery is closing.
Public property | GalleryCommand | Gets the command to invoke when an item is chosen from the gallery.
Public property | GalleryCommandId | Gets the command ID to invoke when an item is chosen from the gallery.
Public property | GalleryOpening | Gets an action to invoke when the gallery is opening.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button. (Inherited from IRibbonButton.)
Public property | SmallImage | Gets a 16x16 image for the button. (Inherited from IRibbonButton.)

See Also

IRibbonSplitButtonGallery Interface


IRibbonSplitButtonGallery Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery Properties
IRibbonSplitButtonGallery Interface See Also

The IRibbonSplitButtonGallery type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Gets a sequence of category instances for the gallery.
Public property | Command | Gets the command to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from IRibbonButton.)
Public property | GalleryClosing | Gets an action to invoke when the gallery is closing.
Public property | GalleryCommand | Gets the command to invoke when an item is chosen from the gallery.
Public property | GalleryCommandId | Gets the command ID to invoke when an item is chosen from the gallery.
Public property | GalleryOpening | Gets an action to invoke when the gallery is opening.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button. (Inherited from IRibbonButton.)
Public property | SmallImage | Gets a 16x16 image for the button. (Inherited from IRibbonButton.)

See Also

IRibbonSplitButtonGallery Interface


Categories Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery..::..Categories Property
IRibbonSplitButtonGallery Interface See Also

Gets a sequence of category instances for the gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<IRibbonGalleryCategory> Categories { get; }
Visual Basic
ReadOnly Property Categories As IEnumerable(Of IRibbonGalleryCategory)
    Get

See Also

IRibbonSplitButtonGallery Interface


GalleryClosing Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery..::..GalleryClosing Property
IRibbonSplitButtonGallery Interface See Also

Gets an action to invoke when the gallery is closing.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Action GalleryClosing { get; }
Visual Basic
ReadOnly Property GalleryClosing As Action
    Get

See Also

IRibbonSplitButtonGallery Interface


GalleryCommand Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery..::..GalleryCommand Property
IRibbonSplitButtonGallery Interface See Also

Gets the command to invoke when an item is chosen from the gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommand GalleryCommand { get; }
Visual Basic
ReadOnly Property GalleryCommand As ICommand
    Get

See Also

IRibbonSplitButtonGallery Interface


GalleryCommandId Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery..::..GalleryCommandId Property
IRibbonSplitButtonGallery Interface See Also

Gets the command ID to invoke when an item is chosen from the gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICommandId GalleryCommandId { get; }
Visual Basic
ReadOnly Property GalleryCommandId As ICommandId
    Get

See Also

IRibbonSplitButtonGallery Interface


GalleryOpening Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonSplitButtonGallery..::..GalleryOpening Property
IRibbonSplitButtonGallery Interface See Also

Gets an action to invoke when the gallery is opening.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Action GalleryOpening { get; }
Visual Basic
ReadOnly Property GalleryOpening As Action
    Get

See Also

IRibbonSplitButtonGallery Interface


IRibbonToggleButton Interface

[image]

Microsoft WebMatrix 2 Beta
IRibbonToggleButton Interface
Members See Also

Interface for representing a toggle button on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IRibbonToggleButton : IRibbonButton,
    IRibbonItem
Visual Basic
Public Interface IRibbonToggleButton _
    Inherits IRibbonButton, IRibbonItem

See Also

IRibbonToggleButton Members


IRibbonToggleButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonToggleButton Members
IRibbonToggleButton Interface Properties See Also

The IRibbonToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from IRibbonButton.)
Public property | IsChecked | Gets or sets a value indicating whether the button is checked (toggled) or not.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button. (Inherited from IRibbonButton.)
Public property | SmallImage | Gets a 16x16 image for the button. (Inherited from IRibbonButton.)

See Also

IRibbonToggleButton Interface


IRibbonToggleButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IRibbonToggleButton Properties
IRibbonToggleButton Interface See Also

The IRibbonToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from IRibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from IRibbonButton.)
Public property | IsChecked | Gets or sets a value indicating whether the button is checked (toggled) or not.
Public property | Label | Gets a label for the item. (Inherited from IRibbonItem.)
Public property | LargeImage | Gets a 32x32 image for the button. (Inherited from IRibbonButton.)
Public property | SmallImage | Gets a 16x16 image for the button. (Inherited from IRibbonButton.)

See Also

IRibbonToggleButton Interface


IsChecked Property

[image]

Microsoft WebMatrix 2 Beta
IRibbonToggleButton..::..IsChecked Property
IRibbonToggleButton Interface See Also

Gets or sets a value indicating whether the button is checked (toggled) or not.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Nullable<bool> IsChecked { get; set; }
Visual Basic
Property IsChecked As Nullable(Of Boolean)
    Get
    Set

See Also

IRibbonToggleButton Interface


ISiteFile Interface

[image]

Microsoft WebMatrix 2 Beta
ISiteFile Interface
Members See Also

Interface that represents a file in the site.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface ISiteFile : ISiteFileSystemItem,
    ISiteItem
Visual Basic
Public Interface ISiteFile _
    Inherits ISiteFileSystemItem, ISiteItem

See Also

ISiteFile Members


ISiteFile Members

[image] [image]

Microsoft WebMatrix 2 Beta
ISiteFile Members
ISiteFile Interface Properties See Also

The ISiteFile type exposes the following members.

Properties

 | Name | Description
Public property | Path | Gets the path of the file or folder. (Inherited from ISiteFileSystemItem.)

See Also

ISiteFile Interface


ISiteFile Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ISiteFile Properties
ISiteFile Interface See Also

The ISiteFile type exposes the following members.

Properties

 | Name | Description
Public property | Path | Gets the path of the file or folder. (Inherited from ISiteFileSystemItem.)

See Also

ISiteFile Interface


ISiteFileSystemItem Interface

[image]

Microsoft WebMatrix 2 Beta
ISiteFileSystemItem Interface
Members See Also

Interface that represents a file or folder in the site.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface ISiteFileSystemItem : ISiteItem
Visual Basic
Public Interface ISiteFileSystemItem _
    Inherits ISiteItem

See Also

ISiteFileSystemItem Members


ISiteFileSystemItem Members

[image] [image]

Microsoft WebMatrix 2 Beta
ISiteFileSystemItem Members
ISiteFileSystemItem Interface Properties See Also

The ISiteFileSystemItem type exposes the following members.

Properties

 | Name | Description
Public property | Path | Gets the path of the file or folder.

See Also

ISiteFileSystemItem Interface


ISiteFileSystemItem Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ISiteFileSystemItem Properties
ISiteFileSystemItem Interface See Also

The ISiteFileSystemItem type exposes the following members.

Properties

 | Name | Description
Public property | Path | Gets the path of the file or folder.

See Also

ISiteFileSystemItem Interface


Path Property

[image]

Microsoft WebMatrix 2 Beta
ISiteFileSystemItem..::..Path Property
ISiteFileSystemItem Interface See Also

Gets the path of the file or folder.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Path { get; }
Visual Basic
ReadOnly Property Path As String
    Get

See Also

ISiteFileSystemItem Interface


ISiteFolder Interface

[image]

Microsoft WebMatrix 2 Beta
ISiteFolder Interface
Members See Also

Interface that represents a folder (directory) in the site.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface ISiteFolder : ISiteFileSystemItem,
    ISiteItem
Visual Basic
Public Interface ISiteFolder _
    Inherits ISiteFileSystemItem, ISiteItem

See Also

ISiteFolder Members


ISiteFolder Members

[image] [image]

Microsoft WebMatrix 2 Beta
ISiteFolder Members
ISiteFolder Interface Properties See Also

The ISiteFolder type exposes the following members.

Properties

 | Name | Description
Public property | Path | Gets the path of the file or folder. (Inherited from ISiteFileSystemItem.)

See Also

ISiteFolder Interface


ISiteFolder Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ISiteFolder Properties
ISiteFolder Interface See Also

The ISiteFolder type exposes the following members.

Properties

 | Name | Description
Public property | Path | Gets the path of the file or folder. (Inherited from ISiteFileSystemItem.)

See Also

ISiteFolder Interface


ISiteItem Interface

[image]

Microsoft WebMatrix 2 Beta
ISiteItem Interface
See Also

Interface that represents an item in the site.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface ISiteItem
Visual Basic
Public Interface ISiteItem

See Also

Microsoft.WebMatrix.Extensibility Namespace


IWebMatrixHost Interface

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost Interface
Members See Also

Interface for interacting with the WebMatrix host.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IWebMatrixHost
Visual Basic
Public Interface IWebMatrixHost

See Also

IWebMatrixHost Members


IWebMatrixHost Members

[image] [image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost Members
IWebMatrixHost Interface Methods Properties Events See Also

The IWebMatrixHost type exposes the following members.

Methods

 | Name | Description
Public method | AddDashboardItems | Adds a sequence of dashboard items to the dashboard.
Public method | AddRibbonItems | Adds a sequence of Ribbon items to the Ribbon.
Public method | ApplyPathProtection | Applies a set of IProtectPathInfo rules to the site's files.
Public method | ShowDialog(String, Object) | Shows a modal dialog box with the specified title/content.
Public method | ShowDialog(String, Object, DialogSize) | Shows a modal dialog box with the specified title/content/size.
Public method | ShowDialog(String, Object, MessageBoxButton, MessageBoxResult) | Shows a modal dialog box with the specified title/content/buttons.
Public method | ShowDialog(String, Object, DialogSize, MessageBoxButton, MessageBoxResult) | Shows a modal dialog box with the specified title/content/size/buttons.
Public method | ShowNotification(String) | Shows a notification message for a brief period of time.
Public method | ShowNotification(String, String, Action) | Shows a notification message and an actionable link for a brief period of time.

Properties

 | Name | Description
Public property | HostCommands | Gets an object that exposes commands supported by the host.
Public property | Name | Gets the user-friendly name of the extension.
Public property | Version | Gets the user-friendly version of the extension.
Public property | WebSite | Gets the current web site.
Public property | Workspace | Gets or sets the current workspace.
Public property | Workspaces | Gets a collection of available workspaces.

Events

 | Name | Description
Public event | ContextMenuOpening | Event that is invoked when the user opens a context menu for an item in the tree view.
Public event | HelpInvoked | Event that is invoked when the user initiates a help request.
Public event | WebSiteChanged | Event that is invoked when the current web site changes.
Public event | WorkspaceChanged | Event that is invoked when the current workspace changes.

See Also

IWebMatrixHost Interface


IWebMatrixHost Methods

[image] [image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost Methods
IWebMatrixHost Interface See Also

The IWebMatrixHost type exposes the following members.

Methods

 | Name | Description
Public method | AddDashboardItems | Adds a sequence of dashboard items to the dashboard.
Public method | AddRibbonItems | Adds a sequence of Ribbon items to the Ribbon.
Public method | ApplyPathProtection | Applies a set of IProtectPathInfo rules to the site's files.
Public method | ShowDialog(String, Object) | Shows a modal dialog box with the specified title/content.
Public method | ShowDialog(String, Object, DialogSize) | Shows a modal dialog box with the specified title/content/size.
Public method | ShowDialog(String, Object, MessageBoxButton, MessageBoxResult) | Shows a modal dialog box with the specified title/content/buttons.
Public method | ShowDialog(String, Object, DialogSize, MessageBoxButton, MessageBoxResult) | Shows a modal dialog box with the specified title/content/size/buttons.
Public method | ShowNotification(String) | Shows a notification message for a brief period of time.
Public method | ShowNotification(String, String, Action) | Shows a notification message and an actionable link for a brief period of time.

See Also

IWebMatrixHost Interface


AddDashboardItems Method

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..AddDashboardItems Method
IWebMatrixHost Interface See Also

Adds a sequence of dashboard items to the dashboard.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void AddDashboardItems(
    IEnumerable<IDashboardItem> dashboardItems
)
Visual Basic
Sub AddDashboardItems ( _
    dashboardItems As IEnumerable(Of IDashboardItem) _
)

Parameters

dashboardItems
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IDashboardItem >)>)>
Sequence of IDashboardItems.

See Also

IWebMatrixHost Interface


AddRibbonItems Method

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..AddRibbonItems Method
IWebMatrixHost Interface See Also

Adds a sequence of Ribbon items to the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void AddRibbonItems(
    IEnumerable<IRibbonItem> ribbonItems
)
Visual Basic
Sub AddRibbonItems ( _
    ribbonItems As IEnumerable(Of IRibbonItem) _
)

Parameters

ribbonItems
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonItem >)>)>
Sequence of IRibbonItems.

See Also

IWebMatrixHost Interface


ApplyPathProtection Method

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ApplyPathProtection Method
IWebMatrixHost Interface See Also

Applies a set of IProtectPathInfo rules to the site's files.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void ApplyPathProtection(
    IEnumerable<IProtectPathInfo> protectPathInfos
)
Visual Basic
Sub ApplyPathProtection ( _
    protectPathInfos As IEnumerable(Of IProtectPathInfo) _
)

Parameters

protectPathInfos
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IProtectPathInfo >)>)>
Set of rules to apply.

Remarks

Resets any protection already in place.

See Also

IWebMatrixHost Interface


ShowDialog Method

[image] [image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowDialog Method
IWebMatrixHost Interface See Also

Overload List

 | Name | Description
Public method | ShowDialog(String, Object) | Shows a modal dialog box with the specified title/content.
Public method | ShowDialog(String, Object, DialogSize) | Shows a modal dialog box with the specified title/content/size.
Public method | ShowDialog(String, Object, MessageBoxButton, MessageBoxResult) | Shows a modal dialog box with the specified title/content/buttons.
Public method | ShowDialog(String, Object, DialogSize, MessageBoxButton, MessageBoxResult) | Shows a modal dialog box with the specified title/content/size/buttons.

See Also

IWebMatrixHost Interface
IWebMatrixHost Members


ShowDialog Method (String, Object)

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowDialog Method (String, Object)
IWebMatrixHost Interface See Also

Shows a modal dialog box with the specified title/content.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Nullable<bool> ShowDialog(
    string title,
    Object content
)
Visual Basic
Function ShowDialog ( _
    title As String, _
    content As Object _
) As Nullable(Of Boolean)

Parameters

title
Type: System..::..String
Title for the dialog.
content
Type: System..::..Object
Content for the dialog.

Return Value

True if OK was pressed or CloseDialog invoked, false if Cancel was pressed, null if an error occurred.

Remarks

Buttons for OK/Cancel will be provided unless the content parameter implements IDialogContent (in which case it should invoke the CloseDialog event when complete).

See Also

IWebMatrixHost Interface
ShowDialog Overload


ShowDialog Method (String, Object, DialogSize)

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowDialog Method (String, Object, DialogSize)
IWebMatrixHost Interface See Also

Shows a modal dialog box with the specified title/content/size.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Nullable<bool> ShowDialog(
    string title,
    Object content,
    DialogSize dialogSize
)
Visual Basic
Function ShowDialog ( _
    title As String, _
    content As Object, _
    dialogSize As DialogSize _
) As Nullable(Of Boolean)

Parameters

title
Type: System..::..String
Title for the dialog.
content
Type: System..::..Object
Content for the dialog.
dialogSize
Type: Microsoft.WebMatrix.Extensibility..::..DialogSize
Size for the dialog.

Return Value

True if OK was pressed or CloseDialog invoked, false if Cancel was pressed, null if an error occurred.

Remarks

Buttons for OK/Cancel will be provided unless the content parameter implements IDialogContent (in which case it should invoke the CloseDialog event when complete).

See Also

IWebMatrixHost Interface
ShowDialog Overload


ShowDialog Method (String, Object, MessageBoxButton, MessageBoxResult)

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowDialog Method (String, Object, MessageBoxButton, MessageBoxResult)
IWebMatrixHost Interface See Also

Shows a modal dialog box with the specified title/content/buttons.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Nullable<bool> ShowDialog(
    string title,
    Object content,
    MessageBoxButton buttons,
    MessageBoxResult defaultButton
)
Visual Basic
Function ShowDialog ( _
    title As String, _
    content As Object, _
    buttons As MessageBoxButton, _
    defaultButton As MessageBoxResult _
) As Nullable(Of Boolean)

Parameters

title
Type: System..::..String
Title for the dialog.
content
Type: System..::..Object
Content for the dialog.
buttons
Type: System.Windows..::..MessageBoxButton
Buttons to show.
defaultButton
Type: System.Windows..::..MessageBoxResult
Default button.

Return Value

True if OK was pressed or CloseDialog invoked, false if Cancel was pressed, null if an error occurred.

See Also

IWebMatrixHost Interface
ShowDialog Overload


ShowDialog Method (String, Object, DialogSize, MessageBoxButton, MessageBoxResult)

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowDialog Method (String, Object, DialogSize, MessageBoxButton, MessageBoxResult)
IWebMatrixHost Interface See Also

Shows a modal dialog box with the specified title/content/size/buttons.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Nullable<bool> ShowDialog(
    string title,
    Object content,
    DialogSize dialogSize,
    MessageBoxButton buttons,
    MessageBoxResult defaultButton
)
Visual Basic
Function ShowDialog ( _
    title As String, _
    content As Object, _
    dialogSize As DialogSize, _
    buttons As MessageBoxButton, _
    defaultButton As MessageBoxResult _
) As Nullable(Of Boolean)

Parameters

title
Type: System..::..String
Title for the dialog.
content
Type: System..::..Object
Content for the dialog.
dialogSize
Type: Microsoft.WebMatrix.Extensibility..::..DialogSize
Size for the dialog.
buttons
Type: System.Windows..::..MessageBoxButton
Buttons to show.
defaultButton
Type: System.Windows..::..MessageBoxResult
Default button.

Return Value

True if OK was pressed or CloseDialog invoked, false if Cancel was pressed, null if an error occurred.

See Also

IWebMatrixHost Interface
ShowDialog Overload


ShowNotification Method

[image] [image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowNotification Method
IWebMatrixHost Interface See Also

Overload List

 | Name | Description
Public method | ShowNotification(String) | Shows a notification message for a brief period of time.
Public method | ShowNotification(String, String, Action) | Shows a notification message and an actionable link for a brief period of time.

See Also

IWebMatrixHost Interface
IWebMatrixHost Members


ShowNotification Method (String)

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowNotification Method (String)
IWebMatrixHost Interface See Also

Shows a notification message for a brief period of time.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void ShowNotification(
    string message
)
Visual Basic
Sub ShowNotification ( _
    message As String _
)

Parameters

message
Type: System..::..String
Message to show.

See Also

IWebMatrixHost Interface
ShowNotification Overload


ShowNotification Method (String, String, Action)

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ShowNotification Method (String, String, Action)
IWebMatrixHost Interface See Also

Shows a notification message and an actionable link for a brief period of time.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void ShowNotification(
    string message,
    string actionMessage,
    Action action
)
Visual Basic
Sub ShowNotification ( _
    message As String, _
    actionMessage As String, _
    action As Action _
)

Parameters

message
Type: System..::..String
Message to show.
actionMessage
Type: System..::..String
Message for the actionable link.
action
Type: System..::..Action
Action to execute when the link is invoked.

See Also

IWebMatrixHost Interface
ShowNotification Overload


IWebMatrixHost Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost Properties
IWebMatrixHost Interface See Also

The IWebMatrixHost type exposes the following members.

Properties

 | Name | Description
Public property | HostCommands | Gets an object that exposes commands supported by the host.
Public property | Name | Gets the user-friendly name of the extension.
Public property | Version | Gets the user-friendly version of the extension.
Public property | WebSite | Gets the current web site.
Public property | Workspace | Gets or sets the current workspace.
Public property | Workspaces | Gets a collection of available workspaces.

See Also

IWebMatrixHost Interface


HostCommands Property

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..HostCommands Property
IWebMatrixHost Interface See Also

Gets an object that exposes commands supported by the host.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IHostCommands HostCommands { get; }
Visual Basic
ReadOnly Property HostCommands As IHostCommands
    Get

See Also

IWebMatrixHost Interface


Name Property

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..Name Property
IWebMatrixHost Interface Example See Also

Gets the user-friendly name of the extension.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Examples

MyExtension

See Also

IWebMatrixHost Interface


Version Property

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..Version Property
IWebMatrixHost Interface Example See Also

Gets the user-friendly version of the extension.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Version { get; }
Visual Basic
ReadOnly Property Version As String
    Get

Examples

v1.0

See Also

IWebMatrixHost Interface


WebSite Property

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..WebSite Property
IWebMatrixHost Interface See Also

Gets the current web site.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IWebSite WebSite { get; }
Visual Basic
ReadOnly Property WebSite As IWebSite
    Get

See Also

IWebMatrixHost Interface


Workspace Property

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..Workspace Property
IWebMatrixHost Interface See Also

Gets or sets the current workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IWorkspace Workspace { get; set; }
Visual Basic
Property Workspace As IWorkspace
    Get
    Set

See Also

IWebMatrixHost Interface


Workspaces Property

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..Workspaces Property
IWebMatrixHost Interface See Also

Gets a collection of available workspaces.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ICollection<IWorkspace> Workspaces { get; }
Visual Basic
ReadOnly Property Workspaces As ICollection(Of IWorkspace)
    Get

See Also

IWebMatrixHost Interface


IWebMatrixHost Events

[image] [image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost Events
IWebMatrixHost Interface See Also

The IWebMatrixHost type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuOpening | Event that is invoked when the user opens a context menu for an item in the tree view.
Public event | HelpInvoked | Event that is invoked when the user initiates a help request.
Public event | WebSiteChanged | Event that is invoked when the current web site changes.
Public event | WorkspaceChanged | Event that is invoked when the current workspace changes.

See Also

IWebMatrixHost Interface


ContextMenuOpening Event

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..ContextMenuOpening Event
IWebMatrixHost Interface See Also

Event that is invoked when the user opens a context menu for an item in the tree view.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event EventHandler<ContextMenuOpeningEventArgs> ContextMenuOpening
Visual Basic
Event ContextMenuOpening As EventHandler(Of ContextMenuOpeningEventArgs)

See Also

IWebMatrixHost Interface


HelpInvoked Event

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..HelpInvoked Event
IWebMatrixHost Interface See Also

Event that is invoked when the user initiates a help request.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event EventHandler<HelpInvokedEventArgs> HelpInvoked
Visual Basic
Event HelpInvoked As EventHandler(Of HelpInvokedEventArgs)

See Also

IWebMatrixHost Interface


WebSiteChanged Event

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..WebSiteChanged Event
IWebMatrixHost Interface See Also

Event that is invoked when the current web site changes.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event EventHandler<EventArgs> WebSiteChanged
Visual Basic
Event WebSiteChanged As EventHandler(Of EventArgs)

See Also

IWebMatrixHost Interface


WorkspaceChanged Event

[image]

Microsoft WebMatrix 2 Beta
IWebMatrixHost..::..WorkspaceChanged Event
IWebMatrixHost Interface See Also

Event that is invoked when the current workspace changes.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event EventHandler<WorkspaceChangedEventArgs> WorkspaceChanged
Visual Basic
Event WorkspaceChanged As EventHandler(Of WorkspaceChangedEventArgs)

See Also

IWebMatrixHost Interface


IWebSite Interface

[image]

Microsoft WebMatrix 2 Beta
IWebSite Interface
Members See Also

Interface for interacting with a web site.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IWebSite
Visual Basic
Public Interface IWebSite

See Also

IWebSite Members


IWebSite Members

[image] [image]

Microsoft WebMatrix 2 Beta
IWebSite Members
IWebSite Interface Properties See Also

The IWebSite type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationIdentifier | Gets the Web Platform Installer application identifier for the site's application.
Public property | Path | Gets the physical path for the site on the local machine.
Public property | Uri | Gets the URI for the site on the local machine.

See Also

IWebSite Interface


IWebSite Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IWebSite Properties
IWebSite Interface See Also

The IWebSite type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationIdentifier | Gets the Web Platform Installer application identifier for the site's application.
Public property | Path | Gets the physical path for the site on the local machine.
Public property | Uri | Gets the URI for the site on the local machine.

See Also

IWebSite Interface


ApplicationIdentifier Property

[image]

Microsoft WebMatrix 2 Beta
IWebSite..::..ApplicationIdentifier Property
IWebSite Interface See Also

Gets the Web Platform Installer application identifier for the site's application.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string ApplicationIdentifier { get; }
Visual Basic
ReadOnly Property ApplicationIdentifier As String
    Get

Remarks

Returns null if the site is not a recognized application.

See Also

IWebSite Interface


Path Property

[image]

Microsoft WebMatrix 2 Beta
IWebSite..::..Path Property
IWebSite Interface See Also

Gets the physical path for the site on the local machine.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Path { get; }
Visual Basic
ReadOnly Property Path As String
    Get

See Also

IWebSite Interface


Uri Property

[image]

Microsoft WebMatrix 2 Beta
IWebSite..::..Uri Property
IWebSite Interface See Also

Gets the URI for the site on the local machine.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
Uri Uri { get; }
Visual Basic
ReadOnly Property Uri As Uri
    Get

See Also

IWebSite Interface


IWorkspace Interface

[image]

Microsoft WebMatrix 2 Beta
IWorkspace Interface
Members See Also

Interface that represents a WebMatrix workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IWorkspace
Visual Basic
Public Interface IWorkspace

See Also

IWorkspace Members


IWorkspace Members

[image] [image]

Microsoft WebMatrix 2 Beta
IWorkspace Members
IWorkspace Interface Properties See Also

The IWorkspace type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of the workspace.
Public property | Image | Gets a 28x25 image for the workspace.
Public property | Title | Gets the title of the workspace.

See Also

IWorkspace Interface


IWorkspace Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IWorkspace Properties
IWorkspace Interface See Also

The IWorkspace type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of the workspace.
Public property | Image | Gets a 28x25 image for the workspace.
Public property | Title | Gets the title of the workspace.

See Also

IWorkspace Interface


Description Property

[image]

Microsoft WebMatrix 2 Beta
IWorkspace..::..Description Property
IWorkspace Interface See Also

Gets the description of the workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get

See Also

IWorkspace Interface


Image Property

[image]

Microsoft WebMatrix 2 Beta
IWorkspace..::..Image Property
IWorkspace Interface See Also

Gets a 28x25 image for the workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ImageSource Image { get; }
Visual Basic
ReadOnly Property Image As ImageSource
    Get

See Also

IWorkspace Interface


Title Property

[image]

Microsoft WebMatrix 2 Beta
IWorkspace..::..Title Property
IWorkspace Interface See Also

Gets the title of the workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Title { get; }
Visual Basic
ReadOnly Property Title As String
    Get

See Also

IWorkspace Interface


ProtectPathInfo Class

[image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo Class
Members See Also

Class that specifies information about protected paths.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class ProtectPathInfo : IProtectPathInfo
Visual Basic
Public Class ProtectPathInfo _
    Implements IProtectPathInfo

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..ProtectPathInfo

See Also

ProtectPathInfo Members


ProtectPathInfo Members

[image] [image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo Members
ProtectPathInfo Class Constructors Methods Properties See Also

The ProtectPathInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ProtectPathInfo | Initializes a new instance of the ProtectPathInfo class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowChanges | Value indicating whether changes to the folder or file are allowed.
Public property | AllowInNestedFolders | Value indicating whether to allow the relative path to match in nested folders (i.e., sub-directories).
Public property | RelativePath | Relative path of the folder or file.

See Also

ProtectPathInfo Class


ProtectPathInfo Constructor

[image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo Constructor
ProtectPathInfo Class See Also

Initializes a new instance of the ProtectPathInfo class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ProtectPathInfo(
    string relativePath,
    bool allowChanges,
    bool allowInNestedFolders
)
Visual Basic
Public Sub New ( _
    relativePath As String, _
    allowChanges As Boolean, _
    allowInNestedFolders As Boolean _
)

Parameters

relativePath
Type: System..::..String
Relative path of the folder or file.
allowChanges
Type: System..::..Boolean
Value indicating whether changes to the folder or file are allowed.
allowInNestedFolders
Type: System..::..Boolean
Value indicating whether to allow the relative path to match in nested folders (i.e., sub-directories).

See Also

ProtectPathInfo Class


ProtectPathInfo Methods

[image] [image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo Methods
ProtectPathInfo Class See Also

The ProtectPathInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ProtectPathInfo Class


ProtectPathInfo Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo Properties
ProtectPathInfo Class See Also

The ProtectPathInfo type exposes the following members.

Properties

 | Name | Description
Public property | AllowChanges | Value indicating whether changes to the folder or file are allowed.
Public property | AllowInNestedFolders | Value indicating whether to allow the relative path to match in nested folders (i.e., sub-directories).
Public property | RelativePath | Relative path of the folder or file.

See Also

ProtectPathInfo Class


AllowChanges Property

[image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo..::..AllowChanges Property
ProtectPathInfo Class See Also

Value indicating whether changes to the folder or file are allowed.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public bool AllowChanges { get; private set; }
Visual Basic
Public Property AllowChanges As Boolean
    Get
    Private Set

Implements

IProtectPathInfo..::..AllowChanges

See Also

ProtectPathInfo Class


AllowInNestedFolders Property

[image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo..::..AllowInNestedFolders Property
ProtectPathInfo Class See Also

Value indicating whether to allow the relative path to match in nested folders (i.e., sub-directories).

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public bool AllowInNestedFolders { get; private set; }
Visual Basic
Public Property AllowInNestedFolders As Boolean
    Get
    Private Set

Implements

IProtectPathInfo..::..AllowInNestedFolders

See Also

ProtectPathInfo Class


RelativePath Property

[image]

Microsoft WebMatrix 2 Beta
ProtectPathInfo..::..RelativePath Property
ProtectPathInfo Class See Also

Relative path of the folder or file.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string RelativePath { get; private set; }
Visual Basic
Public Property RelativePath As String
    Get
    Private Set

Implements

IProtectPathInfo..::..RelativePath

See Also

ProtectPathInfo Class


RibbonButton Class

[image]

Microsoft WebMatrix 2 Beta
RibbonButton Class
Members See Also

Class that represents a Ribbon button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonButton : IRibbonButton,
    IRibbonItem
Visual Basic
Public Class RibbonButton _
    Implements IRibbonButton, IRibbonItem

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonButton
Microsoft.WebMatrix.Extensibility..::..RibbonSplitButton
Microsoft.WebMatrix.Extensibility..::..RibbonSplitButtonGallery
Microsoft.WebMatrix.Extensibility..::..RibbonToggleButton

See Also

RibbonButton Members


RibbonButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonButton Members
RibbonButton Class Constructors Methods Properties See Also

The RibbonButton type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonButton(String, ICommandId, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonButton class.
Public method | RibbonButton(String, ICommandId, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonButton class.
Public method | RibbonButton(String, ICommand, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonButton class.
Public method | RibbonButton(String, ICommand, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonButton class.
Protected method | RibbonButton(String, ICommand, ICommandId, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonButton class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | Gets or sets the command to invoke when the button is pressed.
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed.
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId.
Public property | Label | Gets or sets a label for the item.
Public property | LargeImage | Gets or sets a 32x32 image for the button.
Public property | SmallImage | Gets or sets a 16x16 image for the button.

See Also

RibbonButton Class


RibbonButton Constructor

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonButton Constructor
RibbonButton Class See Also

Overload List

 | Name | Description
Public method | RibbonButton(String, ICommandId, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonButton class.
Public method | RibbonButton(String, ICommandId, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonButton class.
Public method | RibbonButton(String, ICommand, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonButton class.
Public method | RibbonButton(String, ICommand, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonButton class.
Protected method | RibbonButton(String, ICommand, ICommandId, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonButton class.

See Also

RibbonButton Class
RibbonButton Members


RibbonButton Constructor (String, ICommandId, Object, Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonButton Constructor (String, ICommandId, Object, Bitmap, Bitmap)
RibbonButton Class See Also

Initializes a new instance of the RibbonButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonButton(
    string label,
    ICommandId commandId,
    Object commandParameter,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed
commandParameter
Type: System..::..Object
Command parameter for commandId.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonButton Class
RibbonButton Overload


RibbonButton Constructor (String, ICommandId, Object, ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonButton Constructor (String, ICommandId, Object, ImageSource, ImageSource)
RibbonButton Class See Also

Initializes a new instance of the RibbonButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonButton(
    string label,
    ICommandId commandId,
    Object commandParameter,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed
commandParameter
Type: System..::..Object
Command parameter for commandId.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonButton Class
RibbonButton Overload


RibbonButton Constructor (String, ICommand, Object, Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonButton Constructor (String, ICommand, Object, Bitmap, Bitmap)
RibbonButton Class See Also

Initializes a new instance of the RibbonButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonButton(
    string label,
    ICommand command,
    Object commandParameter,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for commandId.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonButton Class
RibbonButton Overload


RibbonButton Constructor (String, ICommand, Object, ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonButton Constructor (String, ICommand, Object, ImageSource, ImageSource)
RibbonButton Class See Also

Initializes a new instance of the RibbonButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonButton(
    string label,
    ICommand command,
    Object commandParameter,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonButton Class
RibbonButton Overload


RibbonButton Constructor (String, ICommand, ICommandId, Object, ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonButton Constructor (String, ICommand, ICommandId, Object, ImageSource, ImageSource)
RibbonButton Class See Also

Initializes a new instance of the RibbonButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
protected RibbonButton(
    string label,
    ICommand command,
    ICommandId commandId,
    Object commandParameter,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Protected Sub New ( _
    label As String, _
    command As ICommand, _
    commandId As ICommandId, _
    commandParameter As Object, _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed
commandParameter
Type: System..::..Object
Command parameter for command or commandId.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonButton Class
RibbonButton Overload


RibbonButton Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonButton Methods
RibbonButton Class See Also

The RibbonButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonButton Class


RibbonButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonButton Properties
RibbonButton Class See Also

The RibbonButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets or sets the command to invoke when the button is pressed.
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed.
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId.
Public property | Label | Gets or sets a label for the item.
Public property | LargeImage | Gets or sets a 32x32 image for the button.
Public property | SmallImage | Gets or sets a 16x16 image for the button.

See Also

RibbonButton Class


Command Property

[image]

Microsoft WebMatrix 2 Beta
RibbonButton..::..Command Property
RibbonButton Class See Also

Gets or sets the command to invoke when the button is pressed.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ICommand Command { get; private set; }
Visual Basic
Public Property Command As ICommand
    Get
    Private Set

Implements

IRibbonButton..::..Command

See Also

RibbonButton Class


CommandId Property

[image]

Microsoft WebMatrix 2 Beta
RibbonButton..::..CommandId Property
RibbonButton Class See Also

Gets or sets the command ID to invoke when the button is pressed.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ICommandId CommandId { get; private set; }
Visual Basic
Public Property CommandId As ICommandId
    Get
    Private Set

Implements

IRibbonButton..::..CommandId

See Also

RibbonButton Class


CommandParameter Property

[image]

Microsoft WebMatrix 2 Beta
RibbonButton..::..CommandParameter Property
RibbonButton Class See Also

Gets or sets the command parameter to pass to the Command or CommandId.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Object CommandParameter { get; private set; }
Visual Basic
Public Property CommandParameter As Object
    Get
    Private Set

Implements

IRibbonButton..::..CommandParameter

See Also

RibbonButton Class


Label Property

[image]

Microsoft WebMatrix 2 Beta
RibbonButton..::..Label Property
RibbonButton Class See Also

Gets or sets a label for the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Label { get; protected set; }
Visual Basic
Public Property Label As String
    Get
    Protected Set

Implements

IRibbonItem..::..Label

See Also

RibbonButton Class


LargeImage Property

[image]

Microsoft WebMatrix 2 Beta
RibbonButton..::..LargeImage Property
RibbonButton Class See Also

Gets or sets a 32x32 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ImageSource LargeImage { get; private set; }
Visual Basic
Public Property LargeImage As ImageSource
    Get
    Private Set

Implements

IRibbonButton..::..LargeImage

See Also

RibbonButton Class


SmallImage Property

[image]

Microsoft WebMatrix 2 Beta
RibbonButton..::..SmallImage Property
RibbonButton Class See Also

Gets or sets a 16x16 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ImageSource SmallImage { get; private set; }
Visual Basic
Public Property SmallImage As ImageSource
    Get
    Private Set

Implements

IRibbonButton..::..SmallImage

See Also

RibbonButton Class


RibbonContextualTab Class

[image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab Class
Members See Also

Class that represents a contextual tab on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonContextualTab : IRibbonContextualTab,
    IRibbonItem, INotifyPropertyChanged
Visual Basic
Public Class RibbonContextualTab _
    Implements IRibbonContextualTab, IRibbonItem, INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonContextualTab

See Also

RibbonContextualTab Members


RibbonContextualTab Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab Members
RibbonContextualTab Class Constructors Methods Properties Events See Also

The RibbonContextualTab type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonContextualTab | Initializes a new instance of the RibbonContextualTab class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsVisible | Gets or sets a value indicating whether the contextual tab is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets or sets a label for the tab.

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

See Also

RibbonContextualTab Class


RibbonContextualTab Constructor

[image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab Constructor
RibbonContextualTab Class See Also

Initializes a new instance of the RibbonContextualTab class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonContextualTab(
    string label,
    IEnumerable<IRibbonItem> items
)
Visual Basic
Public Sub New ( _
    label As String, _
    items As IEnumerable(Of IRibbonItem) _
)

Parameters

label
Type: System..::..String
Label for the tab.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonItem >)>)>
Items in the tab.

See Also

RibbonContextualTab Class


RibbonContextualTab Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab Methods
RibbonContextualTab Class See Also

The RibbonContextualTab type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonContextualTab Class


RibbonContextualTab Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab Properties
RibbonContextualTab Class See Also

The RibbonContextualTab type exposes the following members.

Properties

 | Name | Description
Public property | IsVisible | Gets or sets a value indicating whether the contextual tab is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets or sets a label for the tab.

See Also

RibbonContextualTab Class


IsVisible Property

[image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab..::..IsVisible Property
RibbonContextualTab Class See Also

Gets or sets a value indicating whether the contextual tab is visible.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set

Implements

IRibbonContextualTab..::..IsVisible

See Also

RibbonContextualTab Class


Items Property

[image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab..::..Items Property
RibbonContextualTab Class See Also

Gets a sequence of IRibbonItem instances.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IEnumerable<IRibbonItem> Items { get; private set; }
Visual Basic
Public Property Items As IEnumerable(Of IRibbonItem)
    Get
    Private Set

Implements

IRibbonContextualTab..::..Items

See Also

RibbonContextualTab Class


Label Property

[image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab..::..Label Property
RibbonContextualTab Class See Also

Gets or sets a label for the tab.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Label { get; private set; }
Visual Basic
Public Property Label As String
    Get
    Private Set

Implements

IRibbonItem..::..Label

See Also

RibbonContextualTab Class


RibbonContextualTab Events

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab Events
RibbonContextualTab Class See Also

The RibbonContextualTab type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

See Also

RibbonContextualTab Class


PropertyChanged Event

[image]

Microsoft WebMatrix 2 Beta
RibbonContextualTab..::..PropertyChanged Event
RibbonContextualTab Class See Also

Event invoked when a property change value.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

RibbonContextualTab Class


RibbonGalleryCategory Class

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory Class
Members See Also

Class that represents a category in a Ribbon gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonGalleryCategory : IRibbonGalleryCategory,
    INotifyPropertyChanged
Visual Basic
Public Class RibbonGalleryCategory _
    Implements IRibbonGalleryCategory, INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonGalleryCategory

See Also

RibbonGalleryCategory Members


RibbonGalleryCategory Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory Members
RibbonGalleryCategory Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The RibbonGalleryCategory type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonGalleryCategory | Initializes a new instance of the RibbonGalleryCategory class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnCount | Gets or sets the number of columns to use for laying out items in the category.
Public property | Header | Gets the header text.
Public property | ItemContainerStyle | Gets or sets a Style used for the containers of items in the category.
Public property | Items | Gets a sequence of items in the category.
Public property | ItemTemplate | Gets a DataTemplate used to display the items in the category.

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IRibbonGalleryCategory..::..Items | Gets a sequence of items in the category.

See Also

RibbonGalleryCategory Class


RibbonGalleryCategory Constructor

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory Constructor
RibbonGalleryCategory Class See Also

Initializes a new instance of the RibbonGalleryCategory class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonGalleryCategory(
    string header
)
Visual Basic
Public Sub New ( _
    header As String _
)

Parameters

header
Type: System..::..String
Header text for the category.

See Also

RibbonGalleryCategory Class


RibbonGalleryCategory Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory Methods
RibbonGalleryCategory Class See Also

The RibbonGalleryCategory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonGalleryCategory Class


RibbonGalleryCategory Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory Properties
RibbonGalleryCategory Class See Also

The RibbonGalleryCategory type exposes the following members.

Properties

 | Name | Description
Public property | ColumnCount | Gets or sets the number of columns to use for laying out items in the category.
Public property | Header | Gets the header text.
Public property | ItemContainerStyle | Gets or sets a Style used for the containers of items in the category.
Public property | Items | Gets a sequence of items in the category.
Public property | ItemTemplate | Gets a DataTemplate used to display the items in the category.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IRibbonGalleryCategory..::..Items | Gets a sequence of items in the category.

See Also

RibbonGalleryCategory Class


ColumnCount Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory..::..ColumnCount Property
RibbonGalleryCategory Class See Also

Gets or sets the number of columns to use for laying out items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public int ColumnCount { get; set; }
Visual Basic
Public Property ColumnCount As Integer
    Get
    Set

Implements

IRibbonGalleryCategory..::..ColumnCount

See Also

RibbonGalleryCategory Class


Header Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory..::..Header Property
RibbonGalleryCategory Class See Also

Gets the header text.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Header { get; private set; }
Visual Basic
Public Property Header As String
    Get
    Private Set

Implements

IRibbonGalleryCategory..::..Header

See Also

RibbonGalleryCategory Class


IRibbonGalleryCategory.Items Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory..::..IRibbonGalleryCategory..::..Items Property
RibbonGalleryCategory Class See Also

Gets a sequence of items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IEnumerable<Object> IRibbonGalleryCategory.Items { get; }
Visual Basic
Private ReadOnly Property Items As IEnumerable(Of Object)
    Implements IRibbonGalleryCategory.Items
    Get

Implements

IRibbonGalleryCategory..::..Items

Remarks

Interface definition.

See Also

RibbonGalleryCategory Class


ItemContainerStyle Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory..::..ItemContainerStyle Property
RibbonGalleryCategory Class See Also

Gets or sets a Style used for the containers of items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Style ItemContainerStyle { get; set; }
Visual Basic
Public Property ItemContainerStyle As Style
    Get
    Set

Implements

IRibbonGalleryCategory..::..ItemContainerStyle

See Also

RibbonGalleryCategory Class


Items Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory..::..Items Property
RibbonGalleryCategory Class See Also

Gets a sequence of items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ObservableCollection<Object> Items { get; private set; }
Visual Basic
Public Property Items As ObservableCollection(Of Object)
    Get
    Private Set

Remarks

Convenience implementation.

See Also

RibbonGalleryCategory Class


ItemTemplate Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory..::..ItemTemplate Property
RibbonGalleryCategory Class See Also

Gets a DataTemplate used to display the items in the category.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public DataTemplate ItemTemplate { get; set; }
Visual Basic
Public Property ItemTemplate As DataTemplate
    Get
    Set

Implements

IRibbonGalleryCategory..::..ItemTemplate

See Also

RibbonGalleryCategory Class


RibbonGalleryCategory Events

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory Events
RibbonGalleryCategory Class See Also

The RibbonGalleryCategory type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

See Also

RibbonGalleryCategory Class


PropertyChanged Event

[image]

Microsoft WebMatrix 2 Beta
RibbonGalleryCategory..::..PropertyChanged Event
RibbonGalleryCategory Class See Also

Event invoked when a property change value.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

RibbonGalleryCategory Class


RibbonGroup Class

[image]

Microsoft WebMatrix 2 Beta
RibbonGroup Class
Members See Also

Class that represents a group on the Ribbon.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonGroup : IRibbonGroup,
    IRibbonItem, INotifyPropertyChanged
Visual Basic
Public Class RibbonGroup _
    Implements IRibbonGroup, IRibbonItem, INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonGroup

See Also

RibbonGroup Members


RibbonGroup Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGroup Members
RibbonGroup Class Constructors Methods Properties Events See Also

The RibbonGroup type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonGroup | Initializes a new instance of the RibbonGroup class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsVisible | Gets or sets a value indicating whether the group is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets or sets a label for the group.

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

See Also

RibbonGroup Class


RibbonGroup Constructor

[image]

Microsoft WebMatrix 2 Beta
RibbonGroup Constructor
RibbonGroup Class See Also

Initializes a new instance of the RibbonGroup class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonGroup(
    string label,
    IEnumerable<IRibbonItem> items
)
Visual Basic
Public Sub New ( _
    label As String, _
    items As IEnumerable(Of IRibbonItem) _
)

Parameters

label
Type: System..::..String
Label for the group.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonItem >)>)>
Items in the group.

See Also

RibbonGroup Class


RibbonGroup Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGroup Methods
RibbonGroup Class See Also

The RibbonGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonGroup Class


RibbonGroup Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGroup Properties
RibbonGroup Class See Also

The RibbonGroup type exposes the following members.

Properties

 | Name | Description
Public property | IsVisible | Gets or sets a value indicating whether the group is visible.
Public property | Items | Gets a sequence of IRibbonItem instances.
Public property | Label | Gets or sets a label for the group.

See Also

RibbonGroup Class


IsVisible Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGroup..::..IsVisible Property
RibbonGroup Class See Also

Gets or sets a value indicating whether the group is visible.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set

Implements

IRibbonGroup..::..IsVisible

See Also

RibbonGroup Class


Items Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGroup..::..Items Property
RibbonGroup Class See Also

Gets a sequence of IRibbonItem instances.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IEnumerable<IRibbonItem> Items { get; private set; }
Visual Basic
Public Property Items As IEnumerable(Of IRibbonItem)
    Get
    Private Set

Implements

IRibbonGroup..::..Items

See Also

RibbonGroup Class


Label Property

[image]

Microsoft WebMatrix 2 Beta
RibbonGroup..::..Label Property
RibbonGroup Class See Also

Gets or sets a label for the group.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Label { get; private set; }
Visual Basic
Public Property Label As String
    Get
    Private Set

Implements

IRibbonItem..::..Label

See Also

RibbonGroup Class


RibbonGroup Events

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonGroup Events
RibbonGroup Class See Also

The RibbonGroup type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

See Also

RibbonGroup Class


PropertyChanged Event

[image]

Microsoft WebMatrix 2 Beta
RibbonGroup..::..PropertyChanged Event
RibbonGroup Class See Also

Event invoked when a property change value.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

RibbonGroup Class


RibbonMenuButton Class

[image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton Class
Members See Also

Class that represents a Ribbon menu-button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonMenuButton : IRibbonMenuButton,
    IRibbonItem
Visual Basic
Public Class RibbonMenuButton _
    Implements IRibbonMenuButton, IRibbonItem

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonMenuButton

See Also

RibbonMenuButton Members


RibbonMenuButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton Members
RibbonMenuButton Class Constructors Methods Properties See Also

The RibbonMenuButton type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonMenuButton(String, IEnumerable<(Of <<'(IRibbonButton>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonMenuButton class.
Public method | RibbonMenuButton(String, IEnumerable<(Of <<'(IRibbonButton>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonMenuButton class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | Gets a sequence of IRibbonButtons to show when the menu-button is pressed.
Public property | Label | Gets or sets a label for the item.
Public property | LargeImage | Gets or sets a 32x32 image for the button.
Public property | SmallImage | Gets or sets a 16x16 image for the button.

See Also

RibbonMenuButton Class


RibbonMenuButton Constructor

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton Constructor
RibbonMenuButton Class See Also

Overload List

 | Name | Description
Public method | RibbonMenuButton(String, IEnumerable<(Of <<'(IRibbonButton>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonMenuButton class.
Public method | RibbonMenuButton(String, IEnumerable<(Of <<'(IRibbonButton>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonMenuButton class.

See Also

RibbonMenuButton Class
RibbonMenuButton Members


RibbonMenuButton Constructor (String, IEnumerable(IRibbonButton), Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton Constructor (String, IEnumerable<(Of <(<'IRibbonButton>)>)>, Bitmap, Bitmap)
RibbonMenuButton Class See Also

Initializes a new instance of the RibbonMenuButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonMenuButton(
    string label,
    IEnumerable<IRibbonButton> items,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    items As IEnumerable(Of IRibbonButton), _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonButton >)>)>
Sequence of IRibbonButtons to show when the menu-button is pressed.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonMenuButton Class
RibbonMenuButton Overload


RibbonMenuButton Constructor (String, IEnumerable(IRibbonButton), ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton Constructor (String, IEnumerable<(Of <(<'IRibbonButton>)>)>, ImageSource, ImageSource)
RibbonMenuButton Class See Also

Initializes a new instance of the RibbonMenuButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonMenuButton(
    string label,
    IEnumerable<IRibbonButton> items,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    items As IEnumerable(Of IRibbonButton), _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonButton >)>)>
Sequence of IRibbonButtons to show when the menu-button is pressed.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonMenuButton Class
RibbonMenuButton Overload


RibbonMenuButton Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton Methods
RibbonMenuButton Class See Also

The RibbonMenuButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonMenuButton Class


RibbonMenuButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton Properties
RibbonMenuButton Class See Also

The RibbonMenuButton type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets a sequence of IRibbonButtons to show when the menu-button is pressed.
Public property | Label | Gets or sets a label for the item.
Public property | LargeImage | Gets or sets a 32x32 image for the button.
Public property | SmallImage | Gets or sets a 16x16 image for the button.

See Also

RibbonMenuButton Class


Items Property

[image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton..::..Items Property
RibbonMenuButton Class See Also

Gets a sequence of IRibbonButtons to show when the menu-button is pressed.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IEnumerable<IRibbonButton> Items { get; private set; }
Visual Basic
Public Property Items As IEnumerable(Of IRibbonButton)
    Get
    Private Set

Implements

IRibbonMenuButton..::..Items

See Also

RibbonMenuButton Class


Label Property

[image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton..::..Label Property
RibbonMenuButton Class See Also

Gets or sets a label for the item.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Label { get; protected set; }
Visual Basic
Public Property Label As String
    Get
    Protected Set

Implements

IRibbonItem..::..Label

See Also

RibbonMenuButton Class


LargeImage Property

[image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton..::..LargeImage Property
RibbonMenuButton Class See Also

Gets or sets a 32x32 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ImageSource LargeImage { get; private set; }
Visual Basic
Public Property LargeImage As ImageSource
    Get
    Private Set

Implements

IRibbonMenuButton..::..LargeImage

See Also

RibbonMenuButton Class


SmallImage Property

[image]

Microsoft WebMatrix 2 Beta
RibbonMenuButton..::..SmallImage Property
RibbonMenuButton Class See Also

Gets or sets a 16x16 image for the button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ImageSource SmallImage { get; private set; }
Visual Basic
Public Property SmallImage As ImageSource
    Get
    Private Set

Implements

IRibbonMenuButton..::..SmallImage

See Also

RibbonMenuButton Class


RibbonSplitButton Class

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Class
Members See Also

Class that represents a Ribbon split-button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonSplitButton : RibbonButton,
    IRibbonSplitButton, IRibbonButton, IRibbonItem
Visual Basic
Public Class RibbonSplitButton _
    Inherits RibbonButton _
    Implements IRibbonSplitButton, IRibbonButton, IRibbonItem

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonButton
Microsoft.WebMatrix.Extensibility..::..RibbonSplitButton

See Also

RibbonSplitButton Members


RibbonSplitButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Members
RibbonSplitButton Class Constructors Methods Properties See Also

The RibbonSplitButton type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonSplitButton(String, ICommandId, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButton class.
Public method | RibbonSplitButton(String, ICommandId, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButton class.
Public method | RibbonSplitButton(String, ICommand, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButton class.
Public method | RibbonSplitButton(String, ICommand, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButton class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | Gets or sets the command to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from RibbonButton.)
Public property | Items | Gets a sequence of IRibbonButtons to show when the split-button is expanded.
Public property | Label | Gets or sets a label for the item. (Inherited from RibbonButton.)
Public property | LargeImage | Gets or sets a 32x32 image for the button. (Inherited from RibbonButton.)
Public property | SmallImage | Gets or sets a 16x16 image for the button. (Inherited from RibbonButton.)

See Also

RibbonSplitButton Class


RibbonSplitButton Constructor

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Constructor
RibbonSplitButton Class See Also

Overload List

 | Name | Description
Public method | RibbonSplitButton(String, ICommandId, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButton class.
Public method | RibbonSplitButton(String, ICommandId, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButton class.
Public method | RibbonSplitButton(String, ICommand, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButton class.
Public method | RibbonSplitButton(String, ICommand, Object, IEnumerable<(Of <<'(IRibbonButton>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButton class.

See Also

RibbonSplitButton Class
RibbonSplitButton Members


RibbonSplitButton Constructor (String, ICommandId, Object, IEnumerable(IRibbonButton), Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Constructor (String, ICommandId, Object, IEnumerable<(Of <(<'IRibbonButton>)>)>, Bitmap, Bitmap)
RibbonSplitButton Class See Also

Initializes a new instance of the RibbonSplitButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButton(
    string label,
    ICommandId commandId,
    Object commandParameter,
    IEnumerable<IRibbonButton> items,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    items As IEnumerable(Of IRibbonButton), _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed
commandParameter
Type: System..::..Object
Command parameter for commandId.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonButton >)>)>
Sequence of IRibbonButtons to show when the split-button is expanded.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonSplitButton Class
RibbonSplitButton Overload


RibbonSplitButton Constructor (String, ICommandId, Object, IEnumerable(IRibbonButton), ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Constructor (String, ICommandId, Object, IEnumerable<(Of <(<'IRibbonButton>)>)>, ImageSource, ImageSource)
RibbonSplitButton Class See Also

Initializes a new instance of the RibbonSplitButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButton(
    string label,
    ICommandId commandId,
    Object commandParameter,
    IEnumerable<IRibbonButton> items,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    items As IEnumerable(Of IRibbonButton), _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed
commandParameter
Type: System..::..Object
Command parameter for commandId.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonButton >)>)>
Sequence of IRibbonButtons to show when the split-button is expanded.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonSplitButton Class
RibbonSplitButton Overload


RibbonSplitButton Constructor (String, ICommand, Object, IEnumerable(IRibbonButton), Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Constructor (String, ICommand, Object, IEnumerable<(Of <(<'IRibbonButton>)>)>, Bitmap, Bitmap)
RibbonSplitButton Class See Also

Initializes a new instance of the RibbonSplitButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButton(
    string label,
    ICommand command,
    Object commandParameter,
    IEnumerable<IRibbonButton> items,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    items As IEnumerable(Of IRibbonButton), _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for commandId.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonButton >)>)>
Sequence of IRibbonButtons to show when the split-button is expanded.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonSplitButton Class
RibbonSplitButton Overload


RibbonSplitButton Constructor (String, ICommand, Object, IEnumerable(IRibbonButton), ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Constructor (String, ICommand, Object, IEnumerable<(Of <(<'IRibbonButton>)>)>, ImageSource, ImageSource)
RibbonSplitButton Class See Also

Initializes a new instance of the RibbonSplitButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButton(
    string label,
    ICommand command,
    Object commandParameter,
    IEnumerable<IRibbonButton> items,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    items As IEnumerable(Of IRibbonButton), _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonButton >)>)>
Sequence of IRibbonButtons to show when the split-button is expanded.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonSplitButton Class
RibbonSplitButton Overload


RibbonSplitButton Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Methods
RibbonSplitButton Class See Also

The RibbonSplitButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonSplitButton Class


RibbonSplitButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton Properties
RibbonSplitButton Class See Also

The RibbonSplitButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets or sets the command to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from RibbonButton.)
Public property | Items | Gets a sequence of IRibbonButtons to show when the split-button is expanded.
Public property | Label | Gets or sets a label for the item. (Inherited from RibbonButton.)
Public property | LargeImage | Gets or sets a 32x32 image for the button. (Inherited from RibbonButton.)
Public property | SmallImage | Gets or sets a 16x16 image for the button. (Inherited from RibbonButton.)

See Also

RibbonSplitButton Class


Items Property

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButton..::..Items Property
RibbonSplitButton Class See Also

Gets a sequence of IRibbonButtons to show when the split-button is expanded.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IEnumerable<IRibbonButton> Items { get; private set; }
Visual Basic
Public Property Items As IEnumerable(Of IRibbonButton)
    Get
    Private Set

Implements

IRibbonSplitButton..::..Items

See Also

RibbonSplitButton Class


RibbonSplitButtonGallery Class

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Class
Members See Also

Class that represents a Ribbon split-button that expands to a gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonSplitButtonGallery : RibbonButton,
    IRibbonSplitButtonGallery, IRibbonButton, IRibbonItem
Visual Basic
Public Class RibbonSplitButtonGallery _
    Inherits RibbonButton _
    Implements IRibbonSplitButtonGallery, IRibbonButton, IRibbonItem

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonButton
Microsoft.WebMatrix.Extensibility..::..RibbonSplitButtonGallery

See Also

RibbonSplitButtonGallery Members


RibbonSplitButtonGallery Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Members
RibbonSplitButtonGallery Class Constructors Methods Properties See Also

The RibbonSplitButtonGallery type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonSplitButtonGallery(String, ICommandId, Object, ICommandId, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButtonGallery class.
Public method | RibbonSplitButtonGallery(String, ICommandId, Object, ICommandId, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButtonGallery class.
Public method | RibbonSplitButtonGallery(String, ICommand, Object, ICommand, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButtonGallery class.
Public method | RibbonSplitButtonGallery(String, ICommand, Object, ICommand, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButtonGallery class.
Protected method | RibbonSplitButtonGallery(String, ICommand, ICommandId, Object, ICommand, ICommandId, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButtonGallery class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Gets a sequence of category instances for the gallery.
Public property | Command | Gets or sets the command to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from RibbonButton.)
Public property | GalleryClosing | Gets or sets an action to invoke when the gallery is closing.
Public property | GalleryCommand | Gets the command to invoke when an item is chosen from the gallery.
Public property | GalleryCommandId | Gets or sets the command ID to invoke when an item is chosen from the gallery.
Public property | GalleryOpening | Gets or sets an action to invoke when the gallery is opening.
Public property | Label | Gets or sets a label for the item. (Inherited from RibbonButton.)
Public property | LargeImage | Gets or sets a 32x32 image for the button. (Inherited from RibbonButton.)
Public property | SmallImage | Gets or sets a 16x16 image for the button. (Inherited from RibbonButton.)

See Also

RibbonSplitButtonGallery Class


RibbonSplitButtonGallery Constructor

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Constructor
RibbonSplitButtonGallery Class See Also

Overload List

 | Name | Description
Public method | RibbonSplitButtonGallery(String, ICommandId, Object, ICommandId, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButtonGallery class.
Public method | RibbonSplitButtonGallery(String, ICommandId, Object, ICommandId, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButtonGallery class.
Public method | RibbonSplitButtonGallery(String, ICommand, Object, ICommand, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), Bitmap, Bitmap) | Initializes a new instance of the RibbonSplitButtonGallery class.
Public method | RibbonSplitButtonGallery(String, ICommand, Object, ICommand, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButtonGallery class.
Protected method | RibbonSplitButtonGallery(String, ICommand, ICommandId, Object, ICommand, ICommandId, IEnumerable<(Of <<'(IRibbonGalleryCategory>)>>), ImageSource, ImageSource) | Initializes a new instance of the RibbonSplitButtonGallery class.

See Also

RibbonSplitButtonGallery Class
RibbonSplitButtonGallery Members


RibbonSplitButtonGallery Constructor (String, ICommandId, Object, ICommandId, IEnumerable(IRibbonGalleryCategory), Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Constructor (String, ICommandId, Object, ICommandId, IEnumerable<(Of <(<'IRibbonGalleryCategory>)>)>, Bitmap, Bitmap)
RibbonSplitButtonGallery Class See Also

Initializes a new instance of the RibbonSplitButtonGallery class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButtonGallery(
    string label,
    ICommandId commandId,
    Object commandParameter,
    ICommandId galleryCommandId,
    IEnumerable<IRibbonGalleryCategory> categories,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    galleryCommandId As ICommandId, _
    categories As IEnumerable(Of IRibbonGalleryCategory), _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
galleryCommandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when a gallery item is selected.
categories
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonGalleryCategory >)>)>
Sequence of categories to show in the gallery.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonSplitButtonGallery Class
RibbonSplitButtonGallery Overload


RibbonSplitButtonGallery Constructor (String, ICommandId, Object, ICommandId, IEnumerable(IRibbonGalleryCategory), ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Constructor (String, ICommandId, Object, ICommandId, IEnumerable<(Of <(<'IRibbonGalleryCategory>)>)>, ImageSource, ImageSource)
RibbonSplitButtonGallery Class See Also

Initializes a new instance of the RibbonSplitButtonGallery class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButtonGallery(
    string label,
    ICommandId commandId,
    Object commandParameter,
    ICommandId galleryCommandId,
    IEnumerable<IRibbonGalleryCategory> categories,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    galleryCommandId As ICommandId, _
    categories As IEnumerable(Of IRibbonGalleryCategory), _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
galleryCommandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when a gallery item is selected.
categories
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonGalleryCategory >)>)>
Sequence of categories to show in the gallery.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonSplitButtonGallery Class
RibbonSplitButtonGallery Overload


RibbonSplitButtonGallery Constructor (String, ICommand, Object, ICommand, IEnumerable(IRibbonGalleryCategory), Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Constructor (String, ICommand, Object, ICommand, IEnumerable<(Of <(<'IRibbonGalleryCategory>)>)>, Bitmap, Bitmap)
RibbonSplitButtonGallery Class See Also

Initializes a new instance of the RibbonSplitButtonGallery class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButtonGallery(
    string label,
    ICommand command,
    Object commandParameter,
    ICommand galleryCommand,
    IEnumerable<IRibbonGalleryCategory> categories,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    galleryCommand As ICommand, _
    categories As IEnumerable(Of IRibbonGalleryCategory), _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
galleryCommand
Type: System.Windows.Input..::..ICommand
Command to invoke when a gallery item is selected.
categories
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonGalleryCategory >)>)>
Sequence of categories to show in the gallery.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonSplitButtonGallery Class
RibbonSplitButtonGallery Overload


RibbonSplitButtonGallery Constructor (String, ICommand, Object, ICommand, IEnumerable(IRibbonGalleryCategory), ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Constructor (String, ICommand, Object, ICommand, IEnumerable<(Of <(<'IRibbonGalleryCategory>)>)>, ImageSource, ImageSource)
RibbonSplitButtonGallery Class See Also

Initializes a new instance of the RibbonSplitButtonGallery class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonSplitButtonGallery(
    string label,
    ICommand command,
    Object commandParameter,
    ICommand galleryCommand,
    IEnumerable<IRibbonGalleryCategory> categories,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    galleryCommand As ICommand, _
    categories As IEnumerable(Of IRibbonGalleryCategory), _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
galleryCommand
Type: System.Windows.Input..::..ICommand
Command to invoke when a gallery item is selected.
categories
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonGalleryCategory >)>)>
Sequence of categories to show in the gallery.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonSplitButtonGallery Class
RibbonSplitButtonGallery Overload


RibbonSplitButtonGallery Constructor (String, ICommand, ICommandId, Object, ICommand, ICommandId, IEnumerable(IRibbonGalleryCategory), ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Constructor (String, ICommand, ICommandId, Object, ICommand, ICommandId, IEnumerable<(Of <(<'IRibbonGalleryCategory>)>)>, ImageSource, ImageSource)
RibbonSplitButtonGallery Class See Also

Initializes a new instance of the RibbonSplitButtonGallery class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
protected RibbonSplitButtonGallery(
    string label,
    ICommand command,
    ICommandId commandId,
    Object commandParameter,
    ICommand galleryCommand,
    ICommandId galleryCommandId,
    IEnumerable<IRibbonGalleryCategory> categories,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Protected Sub New ( _
    label As String, _
    command As ICommand, _
    commandId As ICommandId, _
    commandParameter As Object, _
    galleryCommand As ICommand, _
    galleryCommandId As ICommandId, _
    categories As IEnumerable(Of IRibbonGalleryCategory), _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
galleryCommand
Type: System.Windows.Input..::..ICommand
Command to invoke when a gallery item is selected.
galleryCommandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when a gallery item is selected.
categories
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IRibbonGalleryCategory >)>)>
Sequence of categories to show in the gallery.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonSplitButtonGallery Class
RibbonSplitButtonGallery Overload


RibbonSplitButtonGallery Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Methods
RibbonSplitButtonGallery Class See Also

The RibbonSplitButtonGallery type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonSplitButtonGallery Class


RibbonSplitButtonGallery Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery Properties
RibbonSplitButtonGallery Class See Also

The RibbonSplitButtonGallery type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Gets a sequence of category instances for the gallery.
Public property | Command | Gets or sets the command to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from RibbonButton.)
Public property | GalleryClosing | Gets or sets an action to invoke when the gallery is closing.
Public property | GalleryCommand | Gets the command to invoke when an item is chosen from the gallery.
Public property | GalleryCommandId | Gets or sets the command ID to invoke when an item is chosen from the gallery.
Public property | GalleryOpening | Gets or sets an action to invoke when the gallery is opening.
Public property | Label | Gets or sets a label for the item. (Inherited from RibbonButton.)
Public property | LargeImage | Gets or sets a 32x32 image for the button. (Inherited from RibbonButton.)
Public property | SmallImage | Gets or sets a 16x16 image for the button. (Inherited from RibbonButton.)

See Also

RibbonSplitButtonGallery Class


Categories Property

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery..::..Categories Property
RibbonSplitButtonGallery Class See Also

Gets a sequence of category instances for the gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IEnumerable<IRibbonGalleryCategory> Categories { get; private set; }
Visual Basic
Public Property Categories As IEnumerable(Of IRibbonGalleryCategory)
    Get
    Private Set

Implements

IRibbonSplitButtonGallery..::..Categories

See Also

RibbonSplitButtonGallery Class


GalleryClosing Property

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery..::..GalleryClosing Property
RibbonSplitButtonGallery Class See Also

Gets or sets an action to invoke when the gallery is closing.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Action GalleryClosing { get; set; }
Visual Basic
Public Property GalleryClosing As Action
    Get
    Set

Implements

IRibbonSplitButtonGallery..::..GalleryClosing

See Also

RibbonSplitButtonGallery Class


GalleryCommand Property

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery..::..GalleryCommand Property
RibbonSplitButtonGallery Class See Also

Gets the command to invoke when an item is chosen from the gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ICommand GalleryCommand { get; private set; }
Visual Basic
Public Property GalleryCommand As ICommand
    Get
    Private Set

Implements

IRibbonSplitButtonGallery..::..GalleryCommand

See Also

RibbonSplitButtonGallery Class


GalleryCommandId Property

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery..::..GalleryCommandId Property
RibbonSplitButtonGallery Class See Also

Gets or sets the command ID to invoke when an item is chosen from the gallery.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public ICommandId GalleryCommandId { get; private set; }
Visual Basic
Public Property GalleryCommandId As ICommandId
    Get
    Private Set

Implements

IRibbonSplitButtonGallery..::..GalleryCommandId

See Also

RibbonSplitButtonGallery Class


GalleryOpening Property

[image]

Microsoft WebMatrix 2 Beta
RibbonSplitButtonGallery..::..GalleryOpening Property
RibbonSplitButtonGallery Class See Also

Gets or sets an action to invoke when the gallery is opening.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Action GalleryOpening { get; set; }
Visual Basic
Public Property GalleryOpening As Action
    Get
    Set

Implements

IRibbonSplitButtonGallery..::..GalleryOpening

See Also

RibbonSplitButtonGallery Class


RibbonToggleButton Class

[image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Class
Members See Also

Class that represents a Ribbon toggle button.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class RibbonToggleButton : RibbonButton,
    IRibbonToggleButton, IRibbonButton, IRibbonItem, INotifyPropertyChanged
Visual Basic
Public Class RibbonToggleButton _
    Inherits RibbonButton _
    Implements IRibbonToggleButton, IRibbonButton, IRibbonItem, INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..RibbonButton
Microsoft.WebMatrix.Extensibility..::..RibbonToggleButton

See Also

RibbonToggleButton Members


RibbonToggleButton Members

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Members
RibbonToggleButton Class Constructors Methods Properties Events See Also

The RibbonToggleButton type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonToggleButton(String, ICommandId, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonToggleButton class.
Public method | RibbonToggleButton(String, ICommandId, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonToggleButton class.
Public method | RibbonToggleButton(String, ICommand, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonToggleButton class.
Public method | RibbonToggleButton(String, ICommand, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonToggleButton class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | Gets or sets the command to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from RibbonButton.)
Public property | IsChecked | Gets or sets a value indicating whether the button is checked (toggled) or not.
Public property | Label | Gets or sets a label for the item. (Inherited from RibbonButton.)
Public property | LargeImage | Gets or sets a 32x32 image for the button. (Inherited from RibbonButton.)
Public property | SmallImage | Gets or sets a 16x16 image for the button. (Inherited from RibbonButton.)

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

See Also

RibbonToggleButton Class


RibbonToggleButton Constructor

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Constructor
RibbonToggleButton Class See Also

Overload List

 | Name | Description
Public method | RibbonToggleButton(String, ICommandId, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonToggleButton class.
Public method | RibbonToggleButton(String, ICommandId, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonToggleButton class.
Public method | RibbonToggleButton(String, ICommand, Object, Bitmap, Bitmap) | Initializes a new instance of the RibbonToggleButton class.
Public method | RibbonToggleButton(String, ICommand, Object, ImageSource, ImageSource) | Initializes a new instance of the RibbonToggleButton class.

See Also

RibbonToggleButton Class
RibbonToggleButton Members


RibbonToggleButton Constructor (String, ICommandId, Object, Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Constructor (String, ICommandId, Object, Bitmap, Bitmap)
RibbonToggleButton Class See Also

Initializes a new instance of the RibbonToggleButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonToggleButton(
    string label,
    ICommandId commandId,
    Object commandParameter,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed
commandParameter
Type: System..::..Object
Command parameter for commandId.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonToggleButton Class
RibbonToggleButton Overload


RibbonToggleButton Constructor (String, ICommandId, Object, ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Constructor (String, ICommandId, Object, ImageSource, ImageSource)
RibbonToggleButton Class See Also

Initializes a new instance of the RibbonToggleButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonToggleButton(
    string label,
    ICommandId commandId,
    Object commandParameter,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    commandId As ICommandId, _
    commandParameter As Object, _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
commandId
Type: Microsoft.WebMatrix.Extensibility..::..ICommandId
Command ID to invoke when the button is pressed
commandParameter
Type: System..::..Object
Command parameter for commandId.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonToggleButton Class
RibbonToggleButton Overload


RibbonToggleButton Constructor (String, ICommand, Object, Bitmap, Bitmap)

[image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Constructor (String, ICommand, Object, Bitmap, Bitmap)
RibbonToggleButton Class See Also

Initializes a new instance of the RibbonToggleButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonToggleButton(
    string label,
    ICommand command,
    Object commandParameter,
    Bitmap smallImage,
    Bitmap largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    smallImage As Bitmap, _
    largeImage As Bitmap _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for commandId.
smallImage
Type: System.Drawing..::..Bitmap
16x16 image for the button.
largeImage
Type: System.Drawing..::..Bitmap
32x32 image for the button.

See Also

RibbonToggleButton Class
RibbonToggleButton Overload


RibbonToggleButton Constructor (String, ICommand, Object, ImageSource, ImageSource)

[image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Constructor (String, ICommand, Object, ImageSource, ImageSource)
RibbonToggleButton Class See Also

Initializes a new instance of the RibbonToggleButton class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public RibbonToggleButton(
    string label,
    ICommand command,
    Object commandParameter,
    ImageSource smallImage,
    ImageSource largeImage
)
Visual Basic
Public Sub New ( _
    label As String, _
    command As ICommand, _
    commandParameter As Object, _
    smallImage As ImageSource, _
    largeImage As ImageSource _
)

Parameters

label
Type: System..::..String
Label for the item.
command
Type: System.Windows.Input..::..ICommand
Command to invoke when the button is pressed.
commandParameter
Type: System..::..Object
Command parameter for command.
smallImage
Type: System.Windows.Media..::..ImageSource
16x16 image for the button.
largeImage
Type: System.Windows.Media..::..ImageSource
32x32 image for the button.

See Also

RibbonToggleButton Class
RibbonToggleButton Overload


RibbonToggleButton Methods

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Methods
RibbonToggleButton Class See Also

The RibbonToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RibbonToggleButton Class


RibbonToggleButton Properties

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Properties
RibbonToggleButton Class See Also

The RibbonToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets or sets the command to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandId | Gets or sets the command ID to invoke when the button is pressed. (Inherited from RibbonButton.)
Public property | CommandParameter | Gets or sets the command parameter to pass to the Command or CommandId. (Inherited from RibbonButton.)
Public property | IsChecked | Gets or sets a value indicating whether the button is checked (toggled) or not.
Public property | Label | Gets or sets a label for the item. (Inherited from RibbonButton.)
Public property | LargeImage | Gets or sets a 32x32 image for the button. (Inherited from RibbonButton.)
Public property | SmallImage | Gets or sets a 16x16 image for the button. (Inherited from RibbonButton.)

See Also

RibbonToggleButton Class


IsChecked Property

[image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton..::..IsChecked Property
RibbonToggleButton Class See Also

Gets or sets a value indicating whether the button is checked (toggled) or not.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Nullable<bool> IsChecked { get; set; }
Visual Basic
Public Property IsChecked As Nullable(Of Boolean)
    Get
    Set

Implements

IRibbonToggleButton..::..IsChecked

See Also

RibbonToggleButton Class


RibbonToggleButton Events

[image] [image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton Events
RibbonToggleButton Class See Also

The RibbonToggleButton type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Event invoked when a property change value.

See Also

RibbonToggleButton Class


PropertyChanged Event

[image]

Microsoft WebMatrix 2 Beta
RibbonToggleButton..::..PropertyChanged Event
RibbonToggleButton Class See Also

Event invoked when a property change value.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

RibbonToggleButton Class


Utility Class

[image]

Microsoft WebMatrix 2 Beta
Utility Class
Members See Also

Class that exposes a variety of helpful utility methods.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static class Utility
Visual Basic
Public NotInheritable Class Utility

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..Utility

See Also

Utility Members


Utility Members

[image] [image]

Microsoft WebMatrix 2 Beta
Utility Members
Utility Class Methods See Also

The Utility type exposes the following members.

Methods

Name | Description
ConvertBitmapToImageSource | Converts a Bitmap instance into an ImageSource.

See Also

Utility Class


Utility Methods

[image] [image]

Microsoft WebMatrix 2 Beta
Utility Methods
Utility Class See Also

The Utility type exposes the following members.

Methods

Name | Description
ConvertBitmapToImageSource | Converts a Bitmap instance into an ImageSource.

See Also

Utility Class


ConvertBitmapToImageSource Method

[image]

Microsoft WebMatrix 2 Beta
Utility..::..ConvertBitmapToImageSource Method
Utility Class See Also

Converts a Bitmap instance into an ImageSource.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static ImageSource ConvertBitmapToImageSource(
    Bitmap bitmap
)
Visual Basic
Public Shared Function ConvertBitmapToImageSource ( _
    bitmap As Bitmap _
) As ImageSource

Parameters

bitmap
Type: System.Drawing..::..Bitmap
Bitmap instance to convert.

Return Value

Converted ImageSource.

See Also

Utility Class


VSConstants_Ids Class

[image]

Microsoft WebMatrix 2 Beta
VSConstants_Ids Class
Members See Also

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static class VSConstants_Ids
Visual Basic
Public NotInheritable Class VSConstants_Ids

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility..::..VSConstants_Ids

See Also

VSConstants_Ids Members


VSConstants_Ids Members

[image] [image]

Microsoft WebMatrix 2 Beta
VSConstants_Ids Members
VSConstants_Ids Class Fields See Also

The VSConstants_Ids type exposes the following members.

Fields

Name | Description
VSStd2K | GUID for the 2K command set. This is a set of standard editor commands.

See Also

VSConstants_Ids Class


VSConstants_Ids Fields

[image] [image]

Microsoft WebMatrix 2 Beta
VSConstants_Ids Fields
VSConstants_Ids Class See Also

The VSConstants_Ids type exposes the following members.

Fields

Name | Description
VSStd2K | GUID for the 2K command set. This is a set of standard editor commands.

See Also

VSConstants_Ids Class


VSStd2K Field

[image]

Microsoft WebMatrix 2 Beta
VSConstants_Ids..::..VSStd2K Field
VSConstants_Ids Class See Also

GUID for the 2K command set. This is a set of standard editor commands.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static readonly Guid VSStd2K
Visual Basic
Public Shared ReadOnly VSStd2K As Guid

See Also

VSConstants_Ids Class


VSConstants_Ids.VSStd2KCmdID Enumeration

[image]

Microsoft WebMatrix 2 Beta
VSConstants_Ids..::..VSStd2KCmdID Enumeration
VSConstants_Ids Class See Also

Set of the standard, shared editor commands in StandardCommandSet2k.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public enum VSStd2KCmdID
Visual Basic
Public Enumeration VSStd2KCmdID

Members

Member name | Description
TYPECHAR |
BACKSPACE |
RETURN |
TAB |
ECMD_TAB |
BACKTAB |
DELETE |
LEFT |
LEFT_EXT |
RIGHT |
RIGHT_EXT |
UP |
UP_EXT |
DOWN |
DOWN_EXT |
HOME |
HOME_EXT |
END |
END_EXT |
BOL |
BOL_EXT |
FIRSTCHAR |
FIRSTCHAR_EXT |
EOL |
EOL_EXT |
LASTCHAR |
LASTCHAR_EXT |
PAGEUP |
PAGEUP_EXT |
PAGEDN |
PAGEDN_EXT |
TOPLINE |
TOPLINE_EXT |
BOTTOMLINE |
BOTTOMLINE_EXT |
SCROLLUP |
SCROLLDN |
SCROLLPAGEUP |
SCROLLPAGEDN |
SCROLLLEFT |
SCROLLRIGHT |
SCROLLBOTTOM |
SCROLLCENTER |
SCROLLTOP |
SELECTALL |
SELTABIFY |
SELUNTABIFY |
SELLOWCASE |
SELUPCASE |
SELTOGGLECASE |
SELTITLECASE |
SELSWAPANCHOR |
GOTOLINE |
GOTOBRACE |
GOTOBRACE_EXT |
GOBACK |
SELECTMODE |
TOGGLE_OVERTYPE_MODE |
CUT |
COPY |
PASTE |
CUTLINE |
DELETELINE |
DELETEBLANKLINES |
DELETEWHITESPACE |
DELETETOEOL |
DELETETOBOL |
OPENLINEABOVE |
OPENLINEBELOW |
INDENT |
UNINDENT |
UNDO |
UNDONOMOVE |
REDO |
REDONOMOVE |
DELETEALLTEMPBOOKMARKS |
TOGGLETEMPBOOKMARK |
GOTONEXTBOOKMARK |
GOTOPREVBOOKMARK |
FIND |
REPLACE |
REPLACE_ALL |
FINDNEXT |
FINDNEXTWORD |
FINDPREV |
FINDPREVWORD |
FINDAGAIN |
TRANSPOSECHAR |
TRANSPOSEWORD |
TRANSPOSELINE |
SELECTCURRENTWORD |
DELETEWORDRIGHT |
DELETEWORDLEFT |
WORDPREV |
WORDPREV_EXT |
WORDNEXT |
WORDNEXT_EXT |
COMMENTBLOCK |
UNCOMMENTBLOCK |
SETREPEATCOUNT |
WIDGETMARGIN_LBTNDOWN |
SHOWCONTEXTMENU |
CANCEL |
PARAMINFO |
TOGGLEVISSPACE |
TOGGLECARETPASTEPOS |
COMPLETEWORD |
SHOWMEMBERLIST |
FIRSTNONWHITEPREV |
FIRSTNONWHITENEXT |
HELPKEYWORD |
FORMATSELECTION |
OPENURL |
INSERTFILE |
TOGGLESHORTCUT |
QUICKINFO |
LEFT_EXT_COL |
RIGHT_EXT_COL |
UP_EXT_COL |
DOWN_EXT_COL |
TOGGLEWORDWRAP |
ISEARCH |
ISEARCHBACK |
BOL_EXT_COL |
EOL_EXT_COL |
WORDPREV_EXT_COL |
WORDNEXT_EXT_COL |
OUTLN_HIDE_SELECTION |
OUTLN_TOGGLE_CURRENT |
OUTLN_TOGGLE_ALL |
OUTLN_STOP_HIDING_ALL |
OUTLN_STOP_HIDING_CURRENT |
OUTLN_COLLAPSE_TO_DEF |
DOUBLECLICK |
EXTERNALLY_HANDLED_WIDGET_CLICK |
COMMENT_BLOCK |
UNCOMMENT_BLOCK |
OPENFILE |
NAVIGATETOURL |
HANDLEIMEMESSAGE |
SELTOGOBACK |
COMPLETION_HIDE_ADVANCED |
FORMATDOCUMENT |
OUTLN_START_AUTOHIDING |
FINAL |
ECMD_DECREASEFILTER |
ECMD_COPYTIP |
ECMD_PASTETIP |
ECMD_LEFTCLICK |
ECMD_GOTONEXTBOOKMARKINDOC |
ECMD_GOTOPREVBOOKMARKINDOC |
ECMD_INVOKESNIPPETFROMSHORTCUT |
AUTOCOMPLETE |
ECMD_INVOKESNIPPETPICKER2 |
ECMD_DELETEALLBOOKMARKSINDOC |
ECMD_CONVERTTABSTOSPACES |
ECMD_CONVERTSPACESTOTABS |
ECMD_FINAL |
STOP |
REVERSECANCEL |
SLNREFRESH |
SAVECOPYOFITEMAS |
NEWELEMENT |
NEWATTRIBUTE |
NEWCOMPLEXTYPE |
NEWSIMPLETYPE |
NEWGROUP |
NEWATTRIBUTEGROUP |
NEWKEY |
NEWRELATION |
EDITKEY |
EDITRELATION |
MAKETYPEGLOBAL |
PREVIEWDATASET |
GENERATEDATASET |
CREATESCHEMA |
LAYOUTINDENT |
LAYOUTUNINDENT |
REMOVEHANDLER |
EDITHANDLER |
ADDHANDLER |
STYLE |
STYLEGETLIST |
FONTSTYLE |
FONTSTYLEGETLIST |
PASTEASHTML |
VIEWBORDERS |
VIEWDETAILS |
EXPANDCONTROLS |
COLLAPSECONTROLS |
SHOWSCRIPTONLY |
INSERTTABLE |
INSERTCOLLEFT |
INSERTCOLRIGHT |
INSERTROWABOVE |
INSERTROWBELOW |
DELETETABLE |
DELETECOLS |
DELETEROWS |
SELECTTABLE |
SELECTTABLECOL |
SELECTTABLEROW |
SELECTTABLECELL |
MERGECELLS |
SPLITCELL |
INSERTCELL |
DELETECELLS |
SEAMLESSFRAME |
VIEWFRAME |
DELETEFRAME |
SETFRAMESOURCE |
NEWLEFTFRAME |
NEWRIGHTFRAME |
NEWTOPFRAME |
NEWBOTTOMFRAME |
SHOWGRID |
SNAPTOGRID |
BOOKMARK |
HYPERLINK |
IMAGE |
INSERTFORM |
INSERTSPAN |
DIV |
HTMLCLIENTSCRIPTBLOCK |
HTMLSERVERSCRIPTBLOCK |
BULLETEDLIST |
NUMBEREDLIST |
EDITSCRIPT |
EDITCODEBEHIND |
DOCOUTLINEHTML |
DOCOUTLINESCRIPT |
RUNATSERVER |
WEBFORMSVERBS |
WEBFORMSTEMPLATES |
ENDTEMPLATE |
EDITDEFAULTEVENT |
SUPERSCRIPT |
SUBSCRIPT |
EDITSTYLE |
ADDIMAGEHEIGHTWIDTH |
REMOVEIMAGEHEIGHTWIDTH |
LOCKELEMENT |
VIEWSTYLEORGANIZER |
ECMD_AUTOCLOSEOVERRIDE |
NEWANY |
NEWANYATTRIBUTE |
DELETEKEY |
AUTOARRANGE |
VALIDATESCHEMA |
NEWFACET |
VALIDATEXMLDATA |
DOCOUTLINETOGGLE |
VALIDATEHTMLDATA |
VIEWXMLSCHEMAOVERVIEW |
SHOWDEFAULTVIEW |
EXPAND_CHILDREN |
COLLAPSE_CHILDREN |
TOPDOWNLAYOUT |
LEFTRIGHTLAYOUT |
INSERTCELLRIGHT |
EDITMASTER |
INSERTSNIPPET |
FORMATANDVALIDATION |
COLLAPSETAG |
SELECT_TAG |
SELECT_TAG_CONTENT |
CHECK_ACCESSIBILITY |
UNCOLLAPSETAG |
GENERATEPAGERESOURCE |
SHOWNONVISUALCONTROLS |
RESIZECOLUMN |
RESIZEROW |
MAKEABSOLUTE |
MAKERELATIVE |
MAKESTATIC |
INSERTLAYER |
UPDATEDESIGNVIEW |
UPDATESOURCEVIEW |
INSERTCAPTION |
DELETECAPTION |
MAKEPOSITIONNOTSET |
AUTOPOSITIONOPTIONS |
EDITIMAGE |
COMPILE |
PROJSETTINGS |
LINKONLY |
REMOVE |
PROJSTARTDEBUG |
PROJSTEPINTO |
ECMD_UPDATEMGDRES |
UPDATEWEBREF |
ADDRESOURCE |
WEBDEPLOY |
ECMD_PROJTOOLORDER |
ECMD_PROJECTTOOLFILES |
ECMD_OTB_PGO_INSTRUMENT |
ECMD_OTB_PGO_OPT |
ECMD_OTB_PGO_UPDATE |
ECMD_OTB_PGO_RUNSCENARIO |
ADDHTMLPAGE |
ADDHTMLPAGECTX |
ADDMODULE |
ADDMODULECTX |
ADDWFCFORM |
ADDWEBFORM |
ECMD_ADDMASTERPAGE |
ADDUSERCONTROL |
ECMD_ADDCONTENTPAGE |
ADDDHTMLPAGE |
ADDIMAGEGENERATOR |
ADDINHERWFCFORM |
ADDINHERCONTROL |
ADDWEBUSERCONTROL |
BUILDANDBROWSE |
ADDTBXCOMPONENT |
ADDWEBSERVICE |
ECMD_ADDSTYLESHEET |
ECMD_SETBROWSELOCATION |
ECMD_REFRESHFOLDER |
ECMD_SETBROWSELOCATIONCTX |
ECMD_VIEWMARKUP |
ECMD_NEXTMETHOD |
ECMD_PREVMETHOD |
ECMD_RENAMESYMBOL |
ECMD_SHOWREFERENCES |
ECMD_CREATESNIPPET |
ECMD_CREATEREPLACEMENT |
ECMD_INSERTCOMMENT |
VIEWCOMPONENTDESIGNER |
GOTOTYPEDEF |
SHOWSNIPPETHIGHLIGHTING |
HIDESNIPPETHIGHLIGHTING |
ADDVFPPAGE |
SETBREAKPOINT |
SHOWALLFILES |
ADDTOPROJECT |
ADDBLANKNODE |
ADDNODEFROMFILE |
CHANGEURLFROMFILE |
EDITTOPIC |
EDITTITLE |
MOVENODEUP |
MOVENODEDOWN |
MOVENODELEFT |
MOVENODERIGHT |
ADDOUTPUT |
ADDFILE |
MERGEMODULE |
ADDCOMPONENTS |
LAUNCHINSTALLER |
LAUNCHUNINSTALL |
LAUNCHORCA |
FILESYSTEMEDITOR |
REGISTRYEDITOR |
FILETYPESEDITOR |
USERINTERFACEEDITOR |
CUSTOMACTIONSEDITOR |
LAUNCHCONDITIONSEDITOR |
EDITOR |
EXCLUDE |
REFRESHDEPENDENCIES |
VIEWOUTPUTS |
VIEWDEPENDENCIES |
VIEWFILTER |
KEY |
STRING |
BINARY |
DWORD |
KEYSOLO |
IMPORT |
FOLDER |
PROJECTOUTPUT |
FILE |
ADDMERGEMODULES |
CREATESHORTCUT |
LARGEICONS |
SMALLICONS |
LIST |
DETAILS |
ADDFILETYPE |
ADDACTION |
SETASDEFAULT |
MOVEUP |
MOVEDOWN |
ADDDIALOG |
IMPORTDIALOG |
ADDFILESEARCH |
ADDREGISTRYSEARCH |
ADDCOMPONENTSEARCH |
ADDLAUNCHCONDITION |
ADDCUSTOMACTION |
OUTPUTS |
DEPENDENCIES |
FILTER |
COMPONENTS |
ENVSTRING |
CREATEEMPTYSHORTCUT |
ADDFILECONDITION |
ADDREGISTRYCONDITION |
ADDCOMPONENTCONDITION |
ADDURTCONDITION |
ADDIISCONDITION |
SPECIALFOLDERBASE |
USERSAPPLICATIONDATAFOLDER |
COMMONFILES64FOLDER |
COMMONFILESFOLDER |
CUSTOMFOLDER |
USERSDESKTOP |
USERSFAVORITESFOLDER |
FONTSFOLDER |
GLOBALASSEMBLYCACHEFOLDER |
MODULERETARGETABLEFOLDER |
USERSPERSONALDATAFOLDER |
PROGRAMFILES64FOLDER |
PROGRAMFILESFOLDER |
USERSPROGRAMSMENU |
USERSSENDTOMENU |
SHAREDCOMPONENTSFOLDER |
USERSSTARTMENU |
USERSSTARTUPFOLDER |
SYSTEM64FOLDER |
SYSTEMFOLDER |
APPLICATIONFOLDER |
USERSTEMPLATEFOLDER |
WEBCUSTOMFOLDER |
WINDOWSFOLDER |
SPECIALFOLDERLAST |
EXPORTEVENTS |
IMPORTEVENTS |
VIEWEVENT |
VIEWEVENTLIST |
VIEWCHART |
VIEWMACHINEDIAGRAM |
VIEWPROCESSDIAGRAM |
VIEWSOURCEDIAGRAM |
VIEWSTRUCTUREDIAGRAM |
VIEWTIMELINE |
VIEWSUMMARY |
APPLYFILTER |
CLEARFILTER |
STARTRECORDING |
STOPRECORDING |
PAUSERECORDING |
ACTIVATEFILTER |
SHOWFIRSTEVENT |
SHOWPREVIOUSEVENT |
SHOWNEXTEVENT |
SHOWLASTEVENT |
REPLAYEVENTS |
STOPREPLAY |
INCREASEPLAYBACKSPEED |
DECREASEPLAYBACKSPEED |
ADDMACHINE |
ADDREMOVECOLUMNS |
SORTCOLUMNS |
SAVECOLUMNSETTINGS |
RESETCOLUMNSETTINGS |
SIZECOLUMNSTOFIT |
AUTOSELECT |
AUTOFILTER |
AUTOPLAYTRACK |
GOTOEVENT |
ZOOMTOFIT |
ADDGRAPH |
REMOVEGRAPH |
CONNECTMACHINE |
DISCONNECTMACHINE |
EXPANDSELECTION |
COLLAPSESELECTION |
ADDFILTER |
ADDPREDEFINED0 |
ADDPREDEFINED1 |
ADDPREDEFINED2 |
ADDPREDEFINED3 |
ADDPREDEFINED4 |
ADDPREDEFINED5 |
ADDPREDEFINED6 |
ADDPREDEFINED7 |
ADDPREDEFINED8 |
TIMELINESIZETOFIT |
FIELDVIEW |
SELECTEXPERT |
TOPNEXPERT |
SORTORDER |
PROPPAGE |
HELP |
SAVEREPORT |
INSERTSUMMARY |
INSERTGROUP |
INSERTSUBREPORT |
INSERTCHART |
INSERTPICTURE |
SETASSTARTPAGE |
RECALCULATELINKS |
WEBPERMISSIONS |
COMPARETOMASTER |
WORKOFFLINE |
SYNCHRONIZEFOLDER |
SYNCHRONIZEALLFOLDERS |
COPYPROJECT |
IMPORTFILEFROMWEB |
INCLUDEINPROJECT |
EXCLUDEFROMPROJECT |
BROKENLINKSREPORT |
ADDPROJECTOUTPUTS |
ADDREFERENCE |
ADDWEBREFERENCE |
ADDWEBREFERENCECTX |
UPDATEWEBREFERENCE |
RUNCUSTOMTOOL |
SETRUNTIMEVERSION |
VIEWREFINOBJECTBROWSER |
PUBLISH |
PUBLISHCTX |
STARTOPTIONS |
ADDREFERENCECTX |
STARTOPTIONSCTX |
DETACHLOCALDATAFILECTX |
ADDSERVICEREFERENCE |
ADDSERVICEREFERENCECTX |
UPDATESERVICEREFERENCE |
CONFIGURESERVICEREFERENCE |
DRAG_MOVE |
DRAG_COPY |
DRAG_CANCEL |
TESTDIALOG |
SPACEACROSS |
SPACEDOWN |
TOGGLEGRID |
TOGGLEGUIDES |
SIZETOTEXT |
CENTERVERT |
CENTERHORZ |
FLIPDIALOG |
SETTABORDER |
BUTTONRIGHT |
BUTTONBOTTOM |
AUTOLAYOUTGROW |
AUTOLAYOUTNORESIZE |
AUTOLAYOUTOPTIMIZE |
GUIDESETTINGS |
RESOURCEINCLUDES |
RESOURCESYMBOLS |
OPENBINARY |
RESOURCEOPEN |
RESOURCENEW |
RESOURCENEWCOPY |
INSERT |
EXPORT |
CTLMOVELEFT |
CTLMOVEDOWN |
CTLMOVERIGHT |
CTLMOVEUP |
CTLSIZEDOWN |
CTLSIZEUP |
CTLSIZELEFT |
CTLSIZERIGHT |
NEWACCELERATOR |
CAPTUREKEYSTROKE |
INSERTACTIVEXCTL |
INVERTCOLORS |
FLIPHORIZONTAL |
FLIPVERTICAL |
ROTATE90 |
SHOWCOLORSWINDOW |
NEWSTRING |
NEWINFOBLOCK |
DELETEINFOBLOCK |
ADJUSTCOLORS |
LOADPALETTE |
SAVEPALETTE |
CHECKMNEMONICS |
DRAWOPAQUE |
TOOLBAREDITOR |
GRIDSETTINGS |
NEWDEVICEIMAGE |
OPENDEVICEIMAGE |
DELETEDEVICEIMAGE |
VIEWASPOPUP |
CHECKMENUMNEMONICS |
SHOWIMAGEGRID |
SHOWTILEGRID |
MAGNIFY |
ResProps |
IMPORTICONIMAGE |
EXPORTICONIMAGE |
OPENEXTERNALEDITOR |
PICKRECTANGLE |
PICKREGION |
PICKCOLOR |
ERASERTOOL |
FILLTOOL |
PENCILTOOL |
BRUSHTOOL |
AIRBRUSHTOOL |
LINETOOL |
CURVETOOL |
TEXTTOOL |
RECTTOOL |
OUTLINERECTTOOL |
FILLEDRECTTOOL |
ROUNDRECTTOOL |
OUTLINEROUNDRECTTOOL |
FILLEDROUNDRECTTOOL |
ELLIPSETOOL |
OUTLINEELLIPSETOOL |
FILLEDELLIPSETOOL |
SETHOTSPOT |
ZOOMTOOL |
ZOOM1X |
ZOOM2X |
ZOOM6X |
ZOOM8X |
TRANSPARENTBCKGRND |
OPAQUEBCKGRND |
ERASERSMALL |
ERASERMEDIUM |
ERASERLARGE |
ERASERLARGER |
CIRCLELARGE |
CIRCLEMEDIUM |
CIRCLESMALL |
SQUARELARGE |
SQUAREMEDIUM |
SQUARESMALL |
LEFTDIAGLARGE |
LEFTDIAGMEDIUM |
LEFTDIAGSMALL |
RIGHTDIAGLARGE |
RIGHTDIAGMEDIUM |
RIGHTDIAGSMALL |
SPLASHSMALL |
SPLASHMEDIUM |
SPLASHLARGE |
LINESMALLER |
LINESMALL |
LINEMEDIUM |
LINELARGE |
LINELARGER |
LARGERBRUSH |
LARGEBRUSH |
STDBRUSH |
SMALLBRUSH |
SMALLERBRUSH |
ZOOMIN |
ZOOMOUT |
PREVCOLOR |
PREVECOLOR |
NEXTCOLOR |
NEXTECOLOR |
IMG_OPTIONS |
STARTWEBADMINTOOL |
NESTRELATEDFILES |
CANCELDRAG |
DEFAULTACTION |
CTLMOVEUPGRID |
CTLMOVEDOWNGRID |
CTLMOVELEFTGRID |
CTLMOVERIGHTGRID |
CTLSIZERIGHTGRID |
CTLSIZEUPGRID |
CTLSIZELEFTGRID |
CTLSIZEDOWNGRID |
NEXTCTL |
PREVCTL |
RENAME |
EXTRACTMETHOD |
ENCAPSULATEFIELD |
EXTRACTINTERFACE |
PROMOTELOCAL |
REMOVEPARAMETERS |
REORDERPARAMETERS |
GENERATEMETHODSTUB |
IMPLEMENTINTERFACEIMPLICIT |
IMPLEMENTINTERFACEEXPLICIT |
IMPLEMENTABSTRACTCLASS |
SURROUNDWITH |
QUICKOBJECTSEARCH |
ToggleWordWrapOW |
GotoNextLocationOW |
GotoPrevLocationOW |
BuildOnlyProject |
RebuildOnlyProject |
CleanOnlyProject |
SetBuildStartupsOnlyOnRun |
UnhideAll |
HideFolder |
UnhideFolders |
CopyFullPathName |
SaveFolderAsSolution |
ManageUserSettings |
NewSolutionFolder |
ClearPaneOW |
GotoErrorTagOW |
GotoNextErrorTagOW |
GotoPrevErrorTagOW |
ClearPaneFR1 |
GotoErrorTagFR1 |
GotoNextErrorTagFR1 |
GotoPrevErrorTagFR1 |
ClearPaneFR2 |
GotoErrorTagFR2 |
GotoNextErrorTagFR2 |
GotoPrevErrorTagFR2 |
OutputPaneCombo |
OutputPaneComboList |
DisableDockingChanges |
ToggleFloat |
ResetLayout |
NewSolutionFolderBar |
DataShortcut |
NextToolWindow |
PrevToolWindow |
BrowseToFileInExplorer |
ShowEzMDIFileMenu |
PrevToolWindowNav |
StaticAnalysisOnlyProject |
ECMD_RUNFXCOPSEL |
CloseAllButThis |
CVShowInheritedMembers |
CVShowBaseTypes |
CVShowDerivedTypes |
CVShowHidden |
CVBack |
CVForward |
CVSearchCombo |
CVSearch |
CVSortObjectsAlpha |
CVSortObjectsType |
CVSortObjectsAccess |
CVGroupObjectsType |
CVSortMembersAlpha |
CVSortMembersType |
CVSortMembersAccess |
CVTypeBrowserSettings |
CVViewMembersAsImplementor |
CVViewMembersAsSubclass |
CVViewMembersAsUser |
CVReserved1 |
CVReserved2 |
CVShowProjectReferences |
CVGroupMembersType |
CVClearSearch |
CVFilterToType |
CVSortByBestMatch |
CVSearchMRUList |
CVViewOtherMembers |
CVSearchCmd |
CVGoToSearchCmd |
ControlGallery |
OBShowInheritedMembers |
OBShowBaseTypes |
OBShowDerivedTypes |
OBShowHidden |
OBBack |
OBForward |
OBSearchCombo |
OBSearch |
OBSortObjectsAlpha |
OBSortObjectsType |
OBSortObjectsAccess |
OBGroupObjectsType |
OBSortMembersAlpha |
OBSortMembersType |
OBSortMembersAccess |
OBTypeBrowserSettings |
OBViewMembersAsImplementor |
OBViewMembersAsSubclass |
OBViewMembersAsUser |
OBNamespacesView |
OBContainersView |
OBReserved1 |
OBGroupMembersType |
OBClearSearch |
OBFilterToType |
OBSortByBestMatch |
OBSearchMRUList |
OBViewOtherMembers |
OBSearchCmd |
OBGoToSearchCmd |
OBShowExtensionMembers |
FullScreen2 |
FSRSortObjectsAlpha |
FSRSortByBestMatch |
NavigateBack |
NavigateForward |
ECMD_CORRECTION_1 |
ECMD_CORRECTION_2 |
ECMD_CORRECTION_3 |
ECMD_CORRECTION_4 |
ECMD_CORRECTION_5 |
ECMD_CORRECTION_6 |
ECMD_CORRECTION_7 |
ECMD_CORRECTION_8 |
ECMD_CORRECTION_9 |
ECMD_CORRECTION_10 |
OBAddReference |
FindReferences | Obsolete.
CodeDefView |
CodeDefViewGoToPrev |
CodeDefViewGoToNext |
CodeDefViewEditDefinition |
CodeDefViewChooseEncoding |
ViewInClassDiagram |
ECMD_ADDDBTABLE |
ECMD_ADDDATATABLE |
ECMD_ADDFUNCTION |
ECMD_ADDRELATION |
ECMD_ADDKEY |
ECMD_ADDCOLUMN |
ECMD_CONVERT_DBTABLE |
ECMD_CONVERT_DATATABLE |
ECMD_GENERATE_DATABASE |
ECMD_CONFIGURE_CONNECTIONS |
ECMD_IMPORT_XMLSCHEMA |
ECMD_SYNC_WITH_DATABASE |
ECMD_CONFIGURE |
ECMD_CREATE_DATAFORM |
ECMD_CREATE_ENUM |
ECMD_INSERT_FUNCTION |
ECMD_EDIT_FUNCTION |
ECMD_SET_PRIMARY_KEY |
ECMD_INSERT_COLUMN |
ECMD_AUTO_SIZE |
ECMD_SHOW_RELATION_LABELS |
VSDGenerateDataSet |
VSDPreview |
VSDConfigureAdapter |
VSDViewDatasetSchema |
VSDDatasetProperties |
VSDParameterizeForm |
VSDAddChildForm |
ECMD_EDITCONSTRAINT |
ECMD_DELETECONSTRAINT |
ECMD_EDITDATARELATION |
CloseProject |
ReloadCommandBars |
SolutionPlatform |
SolutionPlatformGetList |
ECMD_DATAACCESSOR |
ECMD_ADD_DATAACCESSOR |
ECMD_QUERY |
ECMD_ADD_QUERY |
ECMD_PUBLISHSELECTION |
ECMD_PUBLISHSLNCTX |
CallBrowserShowCallsTo |
CallBrowserShowCallsFrom |
CallBrowserShowNewCallsTo |
CallBrowserShowNewCallsFrom |
CallBrowser1ShowCallsTo |
CallBrowser2ShowCallsTo |
CallBrowser3ShowCallsTo |
CallBrowser4ShowCallsTo |
CallBrowser5ShowCallsTo |
CallBrowser6ShowCallsTo |
CallBrowser7ShowCallsTo |
CallBrowser8ShowCallsTo |
CallBrowser9ShowCallsTo |
CallBrowser10ShowCallsTo |
CallBrowser11ShowCallsTo |
CallBrowser12ShowCallsTo |
CallBrowser13ShowCallsTo |
CallBrowser14ShowCallsTo |
CallBrowser15ShowCallsTo |
CallBrowser16ShowCallsTo |
CallBrowser1ShowCallsFrom |
CallBrowser2ShowCallsFrom |
CallBrowser3ShowCallsFrom |
CallBrowser4ShowCallsFrom |
CallBrowser5ShowCallsFrom |
CallBrowser6ShowCallsFrom |
CallBrowser7ShowCallsFrom |
CallBrowser8ShowCallsFrom |
CallBrowser9ShowCallsFrom |
CallBrowser10ShowCallsFrom |
CallBrowser11ShowCallsFrom |
CallBrowser12ShowCallsFrom |
CallBrowser13ShowCallsFrom |
CallBrowser14ShowCallsFrom |
CallBrowser15ShowCallsFrom |
CallBrowser16ShowCallsFrom |
CallBrowser1ShowFullNames |
CallBrowser2ShowFullNames |
CallBrowser3ShowFullNames |
CallBrowser4ShowFullNames |
CallBrowser5ShowFullNames |
CallBrowser6ShowFullNames |
CallBrowser7ShowFullNames |
CallBrowser8ShowFullNames |
CallBrowser9ShowFullNames |
CallBrowser10ShowFullNames |
CallBrowser11ShowFullNames |
CallBrowser12ShowFullNames |
CallBrowser13ShowFullNames |
CallBrowser14ShowFullNames |
CallBrowser15ShowFullNames |
CallBrowser16ShowFullNames |
CallBrowser1Settings |
CallBrowser2Settings |
CallBrowser3Settings |
CallBrowser4Settings |
CallBrowser5Settings |
CallBrowser6Settings |
CallBrowser7Settings |
CallBrowser8Settings |
CallBrowser9Settings |
CallBrowser10Settings |
CallBrowser11Settings |
CallBrowser12Settings |
CallBrowser13Settings |
CallBrowser14Settings |
CallBrowser15Settings |
CallBrowser16Settings |
CallBrowser1SortAlpha |
CallBrowser2SortAlpha |
CallBrowser3SortAlpha |
CallBrowser4SortAlpha |
CallBrowser5SortAlpha |
CallBrowser6SortAlpha |
CallBrowser7SortAlpha |
CallBrowser8SortAlpha |
CallBrowser9SortAlpha |
CallBrowser10SortAlpha |
CallBrowser11SortAlpha |
CallBrowser12SortAlpha |
CallBrowser13SortAlpha |
CallBrowser14SortAlpha |
CallBrowser15SortAlpha |
CallBrowser16SortAlpha |
CallBrowser1SortAccess |
CallBrowser2SortAccess |
CallBrowser3SortAccess |
CallBrowser4SortAccess |
CallBrowser5SortAccess |
CallBrowser6SortAccess |
CallBrowser7SortAccess |
CallBrowser8SortAccess |
CallBrowser9SortAccess |
CallBrowser10SortAccess |
CallBrowser11SortAccess |
CallBrowser12SortAccess |
CallBrowser13SortAccess |
CallBrowser14SortAccess |
CallBrowser15SortAccess |
CallBrowser16SortAccess |
ShowCallBrowser |
CallBrowser1 |
CallBrowser2 |
CallBrowser3 |
CallBrowser4 |
CallBrowser5 |
CallBrowser6 |
CallBrowser7 |
CallBrowser8 |
CallBrowser9 |
CallBrowser10 |
CallBrowser11 |
CallBrowser12 |
CallBrowser13 |
CallBrowser14 |
CallBrowser15 |
CallBrowser16 |
CallBrowser17 |
GlobalUndo |
GlobalRedo |
CallBrowserShowCallsToCmd |
CallBrowserShowCallsFromCmd |
CallBrowserShowNewCallsToCmd |
CallBrowserShowNewCallsFromCmd |
CallBrowser1Search |
CallBrowser2Search |
CallBrowser3Search |
CallBrowser4Search |
CallBrowser5Search |
CallBrowser6Search |
CallBrowser7Search |
CallBrowser8Search |
CallBrowser9Search |
CallBrowser10Search |
CallBrowser11Search |
CallBrowser12Search |
CallBrowser13Search |
CallBrowser14Search |
CallBrowser15Search |
CallBrowser16Search |
CallBrowser1Refresh |
CallBrowser2Refresh |
CallBrowser3Refresh |
CallBrowser4Refresh |
CallBrowser5Refresh |
CallBrowser6Refresh |
CallBrowser7Refresh |
CallBrowser8Refresh |
CallBrowser9Refresh |
CallBrowser10Refresh |
CallBrowser11Refresh |
CallBrowser12Refresh |
CallBrowser13Refresh |
CallBrowser14Refresh |
CallBrowser15Refresh |
CallBrowser16Refresh |
CallBrowser1SearchCombo |
CallBrowser2SearchCombo |
CallBrowser3SearchCombo |
CallBrowser4SearchCombo |
CallBrowser5SearchCombo |
CallBrowser6SearchCombo |
CallBrowser7SearchCombo |
CallBrowser8SearchCombo |
CallBrowser9SearchCombo |
CallBrowser10SearchCombo |
CallBrowser11SearchCombo |
CallBrowser12SearchCombo |
CallBrowser13SearchCombo |
CallBrowser14SearchCombo |
CallBrowser15SearchCombo |
CallBrowser16SearchCombo |
TaskListProviderCombo |
TaskListProviderComboList |
CreateUserTask |
ErrorListShowErrors |
ErrorListShowWarnings |
ErrorListShowMessages |
Registration |
CallBrowser1SearchComboList |
CallBrowser2SearchComboList |
CallBrowser3SearchComboList |
CallBrowser4SearchComboList |
CallBrowser5SearchComboList |
CallBrowser6SearchComboList |
CallBrowser7SearchComboList |
CallBrowser8SearchComboList |
CallBrowser9SearchComboList |
CallBrowser10SearchComboList |
CallBrowser11SearchComboList |
CallBrowser12SearchComboList |
CallBrowser13SearchComboList |
CallBrowser14SearchComboList |
CallBrowser15SearchComboList |
CallBrowser16SearchComboList |
SnippetProp |
SnippetRef |
SnippetRepl |
StartPage |
EditorLineFirstColumn |
EditorLineFirstColumnExtend |
SEServerExplorer |
SEDataExplorer |
ECMD_VALIDATION_TARGET |
ECMD_VALIDATION_TARGET_GET_LIST |
ECMD_CSS_TARGET |
ECMD_CSS_TARGET_GET_LIST |
Design |
DesignOn |
SEDesign |
NewDiagram |
NewTable |
NewDBItem |
NewTrigger |
Debug |
NewProcedure |
NewQuery |
RefreshLocal |
DbAddDataConnection |
DBDefDBRef |
RunCmd |
RunOn |
NewDBRef |
SetAsDef |
CreateCmdFile |
NewDatabase |
NewUser |
NewRole |
ChangeLogin |
NewView |
ModifyConnection |
Disconnect |
CopyScript |
AddSCC |
RemoveSCC |
GetLatest |
CheckOut |
CheckIn |
UndoCheckOut |
AddItemSCC |
NewPackageSpec |
NewPackageBody |
InsertSQL |
RunSelection |
UpdateScript |
NewScript |
NewFunction |
NewTableFunction |
NewInlineFunction |
AddDiagram |
AddTable |
AddSynonym |
AddView |
AddProcedure |
AddFunction |
AddTableFunction |
AddInlineFunction |
AddPkgSpec |
AddPkgBody |
AddTrigger |
ExportData |
DbnsVcsAdd |
DbnsVcsRemove |
DbnsVcsCheckout |
DbnsVcsUndoCheckout |
DbnsVcsCheckin |
SERetrieveData |
SEEditTextObject |
DesignSQLBlock |
RegisterSQLInstance |
UnregisterSQLInstance |
CommandWindowSaveScript |
CommandWindowRunScript |
CommandWindowCursorUp |
CommandWindowCursorDown |
CommandWindowCursorLeft |
CommandWindowCursorRight |
CommandWindowHistoryUp |
CommandWindowHistoryDown |

See Also

Microsoft.WebMatrix.Extensibility Namespace


WorkspaceChangedEventArgs Class

[image]

Microsoft WebMatrix 2 Beta
WorkspaceChangedEventArgs Class
Members See Also

Class that represents the event arguments for a WorkspaceChanged event.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class WorkspaceChangedEventArgs : EventArgs
Visual Basic
Public Class WorkspaceChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Microsoft.WebMatrix.Extensibility..::..WorkspaceChangedEventArgs

See Also

WorkspaceChangedEventArgs Members


WorkspaceChangedEventArgs Members

[image] [image]

Microsoft WebMatrix 2 Beta
WorkspaceChangedEventArgs Members
WorkspaceChangedEventArgs Class Constructors Methods Properties See Also

The WorkspaceChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | WorkspaceChangedEventArgs | Initializes a new instance of the WorkspaceChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | NewWorkspace | Gets a value indicating the new (current) workspace.
Public property | OldWorkspace | Gets a value indicating the old (previous) workspace.

See Also

WorkspaceChangedEventArgs Class


WorkspaceChangedEventArgs Constructor

[image]

Microsoft WebMatrix 2 Beta
WorkspaceChangedEventArgs Constructor
WorkspaceChangedEventArgs Class See Also

Initializes a new instance of the WorkspaceChangedEventArgs class.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public WorkspaceChangedEventArgs(
    IWorkspace oldWorkspace,
    IWorkspace newWorkspace
)
Visual Basic
Public Sub New ( _
    oldWorkspace As IWorkspace, _
    newWorkspace As IWorkspace _
)

Parameters

oldWorkspace
Type: Microsoft.WebMatrix.Extensibility..::..IWorkspace
Old workspace.
newWorkspace
Type: Microsoft.WebMatrix.Extensibility..::..IWorkspace
New workspace.

See Also

WorkspaceChangedEventArgs Class


WorkspaceChangedEventArgs Methods

[image] [image]

Microsoft WebMatrix 2 Beta
WorkspaceChangedEventArgs Methods
WorkspaceChangedEventArgs Class See Also

The WorkspaceChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

WorkspaceChangedEventArgs Class


WorkspaceChangedEventArgs Properties

[image] [image]

Microsoft WebMatrix 2 Beta
WorkspaceChangedEventArgs Properties
WorkspaceChangedEventArgs Class See Also

The WorkspaceChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewWorkspace | Gets a value indicating the new (current) workspace.
Public property | OldWorkspace | Gets a value indicating the old (previous) workspace.

See Also

WorkspaceChangedEventArgs Class


NewWorkspace Property

[image]

Microsoft WebMatrix 2 Beta
WorkspaceChangedEventArgs..::..NewWorkspace Property
WorkspaceChangedEventArgs Class See Also

Gets a value indicating the new (current) workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IWorkspace NewWorkspace { get; private set; }
Visual Basic
Public Property NewWorkspace As IWorkspace
    Get
    Private Set

See Also

WorkspaceChangedEventArgs Class


OldWorkspace Property

[image]

Microsoft WebMatrix 2 Beta
WorkspaceChangedEventArgs..::..OldWorkspace Property
WorkspaceChangedEventArgs Class See Also

Gets a value indicating the old (previous) workspace.

Namespace: Microsoft.WebMatrix.Extensibility
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public IWorkspace OldWorkspace { get; private set; }
Visual Basic
Public Property OldWorkspace As IWorkspace
    Get
    Private Set

See Also

WorkspaceChangedEventArgs Class


Microsoft.WebMatrix.Extensibility.Editor Namespace

[image]

Microsoft WebMatrix 2 Beta
Microsoft.WebMatrix.Extensibility.Editor Namespace

Classes

 | Class | Description
Public class | FormatData | Class that stores format data.
Public class | SettingChangedEventArgs | Used in the SettingChanged event
Public class | Theme | Class that represents an editor theme.
Public class | ThemeKeys | Class that exposes theme keys.
Public class | XmlDocExtensions | Class that contains extensions for XmlDocument.

Interfaces

 | Interface | Description
Public interface | IEditorSettings | Interface that represents editor settings.
Public interface | IEditorSettingsProvider | Interface that represents an editor settings provider.
Public interface | IFileTypeManagementService | Interface for a file type management service.
Public interface | IFileTypeManagementServiceProvider | Interface for a file type management service provider.
Public interface | ITheme | Interface for an editor theme.
Public interface | IThemeManager | Interface for managing editor themes.
Public interface | IThemeManagerServiceProvider | Interface for a theme manager service provider.

Delegates

 | Delegate | Description
Public delegate | SettingChangedEventHandler | For handling the SettingChanged event


FormatData Class

[image]

Microsoft WebMatrix 2 Beta
FormatData Class
Members See Also

Class that stores format data.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class FormatData
Visual Basic
Public Class FormatData

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility.Editor..::..FormatData

See Also

FormatData Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


FormatData Members

[image] [image]

Microsoft WebMatrix 2 Beta
FormatData Members
FormatData Class Constructors Methods Properties See Also

The FormatData type exposes the following members.

Constructors

 | Name | Description
Public method | FormatData |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | Gets or sets the back color.
Public property | ForeColor | Gets or sets the fore color.
Public property | IsBold | Gets or sets the bold setting.

See Also

FormatData Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


FormatData Constructor

[image]

Microsoft WebMatrix 2 Beta
FormatData Constructor
FormatData Class See Also

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public FormatData()
Visual Basic
Public Sub New

See Also

FormatData Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


FormatData Methods

[image] [image]

Microsoft WebMatrix 2 Beta
FormatData Methods
FormatData Class See Also

The FormatData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FormatData Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


FormatData Properties

[image] [image]

Microsoft WebMatrix 2 Beta
FormatData Properties
FormatData Class See Also

The FormatData type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Gets or sets the back color.
Public property | ForeColor | Gets or sets the fore color.
Public property | IsBold | Gets or sets the bold setting.

See Also

FormatData Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


BackColor Property

[image]

Microsoft WebMatrix 2 Beta
FormatData..::..BackColor Property
FormatData Class See Also

Gets or sets the back color.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public SolidColorBrush BackColor { get; set; }
Visual Basic
Public Property BackColor As SolidColorBrush
    Get
    Set

See Also

FormatData Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ForeColor Property

[image]

Microsoft WebMatrix 2 Beta
FormatData..::..ForeColor Property
FormatData Class See Also

Gets or sets the fore color.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public SolidColorBrush ForeColor { get; set; }
Visual Basic
Public Property ForeColor As SolidColorBrush
    Get
    Set

See Also

FormatData Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


IsBold Property

[image]

Microsoft WebMatrix 2 Beta
FormatData..::..IsBold Property
FormatData Class See Also

Gets or sets the bold setting.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public bool IsBold { get; set; }
Visual Basic
Public Property IsBold As Boolean
    Get
    Set

See Also

FormatData Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


IEditorSettings Interface

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings Interface
Members See Also

Interface that represents editor settings.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IEditorSettings
Visual Basic
Public Interface IEditorSettings

See Also

IEditorSettings Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


IEditorSettings Members

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorSettings Members
IEditorSettings Interface Properties See Also

The IEditorSettings type exposes the following members.

Properties

 | Name | Description
Public property | FontFamily | Gets or sets the font family.
Public property | FontSizeInPoints | Gets or sets the font size in points.
Public property | InsertSpacesForTabs | Gets or sets whether spaces are inserted for tabs.
Public property | LineNumbersEnabled | Gets or sets whether line numbers are enabled.
Public property | ShowWhiteSpaces | Gets or sets whether whitespace is shown.
Public property | SurfaceBackgroundBrush | Gets or sets the surface background brush.
Public property | TabSize | Gets or sets the tab size.
Public property | WordWrapEnabled | Gets or sets whether word wrap is enabled.

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IEditorSettings Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorSettings Properties
IEditorSettings Interface See Also

The IEditorSettings type exposes the following members.

Properties

 | Name | Description
Public property | FontFamily | Gets or sets the font family.
Public property | FontSizeInPoints | Gets or sets the font size in points.
Public property | InsertSpacesForTabs | Gets or sets whether spaces are inserted for tabs.
Public property | LineNumbersEnabled | Gets or sets whether line numbers are enabled.
Public property | ShowWhiteSpaces | Gets or sets whether whitespace is shown.
Public property | SurfaceBackgroundBrush | Gets or sets the surface background brush.
Public property | TabSize | Gets or sets the tab size.
Public property | WordWrapEnabled | Gets or sets whether word wrap is enabled.

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


FontFamily Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..FontFamily Property
IEditorSettings Interface See Also

Gets or sets the font family.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string FontFamily { get; set; }
Visual Basic
Property FontFamily As String
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


FontSizeInPoints Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..FontSizeInPoints Property
IEditorSettings Interface See Also

Gets or sets the font size in points.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
float FontSizeInPoints { get; set; }
Visual Basic
Property FontSizeInPoints As Single
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


InsertSpacesForTabs Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..InsertSpacesForTabs Property
IEditorSettings Interface See Also

Gets or sets whether spaces are inserted for tabs.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool InsertSpacesForTabs { get; set; }
Visual Basic
Property InsertSpacesForTabs As Boolean
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


LineNumbersEnabled Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..LineNumbersEnabled Property
IEditorSettings Interface See Also

Gets or sets whether line numbers are enabled.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool LineNumbersEnabled { get; set; }
Visual Basic
Property LineNumbersEnabled As Boolean
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


ShowWhiteSpaces Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..ShowWhiteSpaces Property
IEditorSettings Interface See Also

Gets or sets whether whitespace is shown.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool ShowWhiteSpaces { get; set; }
Visual Basic
Property ShowWhiteSpaces As Boolean
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


SurfaceBackgroundBrush Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..SurfaceBackgroundBrush Property
IEditorSettings Interface See Also

Gets or sets the surface background brush.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
SolidColorBrush SurfaceBackgroundBrush { get; set; }
Visual Basic
Property SurfaceBackgroundBrush As SolidColorBrush
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


TabSize Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..TabSize Property
IEditorSettings Interface See Also

Gets or sets the tab size.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
int TabSize { get; set; }
Visual Basic
Property TabSize As Integer
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


WordWrapEnabled Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettings..::..WordWrapEnabled Property
IEditorSettings Interface See Also

Gets or sets whether word wrap is enabled.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool WordWrapEnabled { get; set; }
Visual Basic
Property WordWrapEnabled As Boolean
    Get
    Set

See Also

IEditorSettings Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IEditorSettingsProvider Interface

[image]

Microsoft WebMatrix 2 Beta
IEditorSettingsProvider Interface
Members See Also

Interface that represents an editor settings provider.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IEditorSettingsProvider : IEditorSettings
Visual Basic
Public Interface IEditorSettingsProvider _
    Inherits IEditorSettings

See Also

IEditorSettingsProvider Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


IEditorSettingsProvider Members

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorSettingsProvider Members
IEditorSettingsProvider Interface Properties Events See Also

The IEditorSettingsProvider type exposes the following members.

Properties

 | Name | Description
Public property | FontFamily | Gets or sets the font family. (Inherited from IEditorSettings.)
Public property | FontSizeInPoints | Gets or sets the font size in points. (Inherited from IEditorSettings.)
Public property | InsertSpacesForTabs | Gets or sets whether spaces are inserted for tabs. (Inherited from IEditorSettings.)
Public property | LineNumbersEnabled | Gets or sets whether line numbers are enabled. (Inherited from IEditorSettings.)
Public property | ShowWhiteSpaces | Gets or sets whether whitespace is shown. (Inherited from IEditorSettings.)
Public property | SurfaceBackgroundBrush | Gets or sets the surface background brush. (Inherited from IEditorSettings.)
Public property | TabSize | Gets or sets the tab size. (Inherited from IEditorSettings.)
Public property | ThemeFileLocation | Gets or sets the theme file location.
Public property | WordWrapEnabled | Gets or sets whether word wrap is enabled. (Inherited from IEditorSettings.)

Events

 | Name | Description
Public event | SettingChanged | Event that is invoked when a setting has changed.

See Also

IEditorSettingsProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IEditorSettingsProvider Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorSettingsProvider Properties
IEditorSettingsProvider Interface See Also

The IEditorSettingsProvider type exposes the following members.

Properties

 | Name | Description
Public property | FontFamily | Gets or sets the font family. (Inherited from IEditorSettings.)
Public property | FontSizeInPoints | Gets or sets the font size in points. (Inherited from IEditorSettings.)
Public property | InsertSpacesForTabs | Gets or sets whether spaces are inserted for tabs. (Inherited from IEditorSettings.)
Public property | LineNumbersEnabled | Gets or sets whether line numbers are enabled. (Inherited from IEditorSettings.)
Public property | ShowWhiteSpaces | Gets or sets whether whitespace is shown. (Inherited from IEditorSettings.)
Public property | SurfaceBackgroundBrush | Gets or sets the surface background brush. (Inherited from IEditorSettings.)
Public property | TabSize | Gets or sets the tab size. (Inherited from IEditorSettings.)
Public property | ThemeFileLocation | Gets or sets the theme file location.
Public property | WordWrapEnabled | Gets or sets whether word wrap is enabled. (Inherited from IEditorSettings.)

See Also

IEditorSettingsProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


ThemeFileLocation Property

[image]

Microsoft WebMatrix 2 Beta
IEditorSettingsProvider..::..ThemeFileLocation Property
IEditorSettingsProvider Interface See Also

Gets or sets the theme file location.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string ThemeFileLocation { get; set; }
Visual Basic
Property ThemeFileLocation As String
    Get
    Set

See Also

IEditorSettingsProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IEditorSettingsProvider Events

[image] [image]

Microsoft WebMatrix 2 Beta
IEditorSettingsProvider Events
IEditorSettingsProvider Interface See Also

The IEditorSettingsProvider type exposes the following members.

Events

 | Name | Description
Public event | SettingChanged | Event that is invoked when a setting has changed.

See Also

IEditorSettingsProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChanged Event

[image]

Microsoft WebMatrix 2 Beta
IEditorSettingsProvider..::..SettingChanged Event
IEditorSettingsProvider Interface See Also

Event that is invoked when a setting has changed.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
event SettingChangedEventHandler SettingChanged
Visual Basic
Event SettingChanged As SettingChangedEventHandler

See Also

IEditorSettingsProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IFileTypeManagementService Interface

[image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementService Interface
Members See Also

Interface for a file type management service.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IFileTypeManagementService
Visual Basic
Public Interface IFileTypeManagementService

See Also

IFileTypeManagementService Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


IFileTypeManagementService Members

[image] [image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementService Members
IFileTypeManagementService Interface Methods See Also

The IFileTypeManagementService type exposes the following members.

Methods

 | Name | Description
Public method | IsRegisteredExtension | Indicates whether an extension is registered.
Public method | IsRegisteredType | Indicates whether a content type is registered.
Public method | RegisterExtensionToContentType | Registers an extension to a content type.
Public method | RegisterType | Registers a content type.

See Also

IFileTypeManagementService Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IFileTypeManagementService Methods

[image] [image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementService Methods
IFileTypeManagementService Interface See Also

The IFileTypeManagementService type exposes the following members.

Methods

 | Name | Description
Public method | IsRegisteredExtension | Indicates whether an extension is registered.
Public method | IsRegisteredType | Indicates whether a content type is registered.
Public method | RegisterExtensionToContentType | Registers an extension to a content type.
Public method | RegisterType | Registers a content type.

See Also

IFileTypeManagementService Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IsRegisteredExtension Method

[image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementService..::..IsRegisteredExtension Method
IFileTypeManagementService Interface See Also

Indicates whether an extension is registered.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool IsRegisteredExtension(
    string filePath,
    out string contentTypeName
)
Visual Basic
Function IsRegisteredExtension ( _
    filePath As String, _
    <OutAttribute> ByRef contentTypeName As String _
) As Boolean

Parameters

filePath
Type: System..::..String
File path.
contentTypeName
Type: System..::..String %
Content type.

Return Value

True if registered.

See Also

IFileTypeManagementService Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IsRegisteredType Method

[image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementService..::..IsRegisteredType Method
IFileTypeManagementService Interface See Also

Indicates whether a content type is registered.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool IsRegisteredType(
    string contentTypeName
)
Visual Basic
Function IsRegisteredType ( _
    contentTypeName As String _
) As Boolean

Parameters

contentTypeName
Type: System..::..String
Content type.

Return Value

True if registered.

See Also

IFileTypeManagementService Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


RegisterExtensionToContentType Method

[image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementService..::..RegisterExtensionToContentType Method
IFileTypeManagementService Interface See Also

Registers an extension to a content type.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
bool RegisterExtensionToContentType(
    string filePath,
    string contentTypeName
)
Visual Basic
Function RegisterExtensionToContentType ( _
    filePath As String, _
    contentTypeName As String _
) As Boolean

Parameters

filePath
Type: System..::..String
File path.
contentTypeName
Type: System..::..String
Content type.

Return Value

True if registered.

See Also

IFileTypeManagementService Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


RegisterType Method

[image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementService..::..RegisterType Method
IFileTypeManagementService Interface See Also

Registers a content type.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void RegisterType(
    string contentTypeName,
    string[] baseTypes
)
Visual Basic
Sub RegisterType ( _
    contentTypeName As String, _
    baseTypes As String() _
)

Parameters

contentTypeName
Type: System..::..String
Content type.
baseTypes
Type: array< System..::..String >[]()[][]
Base types.

See Also

IFileTypeManagementService Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IFileTypeManagementServiceProvider Interface

[image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementServiceProvider Interface
Members See Also

Interface for a file type management service provider.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IFileTypeManagementServiceProvider
Visual Basic
Public Interface IFileTypeManagementServiceProvider

See Also

IFileTypeManagementServiceProvider Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


IFileTypeManagementServiceProvider Members

[image] [image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementServiceProvider Members
IFileTypeManagementServiceProvider Interface Methods See Also

The IFileTypeManagementServiceProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetFileManagementService | Gets an instance of the IFileTypeManagementService interface.

See Also

IFileTypeManagementServiceProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IFileTypeManagementServiceProvider Methods

[image] [image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementServiceProvider Methods
IFileTypeManagementServiceProvider Interface See Also

The IFileTypeManagementServiceProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetFileManagementService | Gets an instance of the IFileTypeManagementService interface.

See Also

IFileTypeManagementServiceProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


GetFileManagementService Method

[image]

Microsoft WebMatrix 2 Beta
IFileTypeManagementServiceProvider..::..GetFileManagementService Method
IFileTypeManagementServiceProvider Interface See Also

Gets an instance of the IFileTypeManagementService interface.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IFileTypeManagementService GetFileManagementService()
Visual Basic
Function GetFileManagementService As IFileTypeManagementService

Return Value

IFileTypeManagementService instance.

See Also

IFileTypeManagementServiceProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


ITheme Interface

[image]

Microsoft WebMatrix 2 Beta
ITheme Interface
Members See Also

Interface for an editor theme.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface ITheme
Visual Basic
Public Interface ITheme

See Also

ITheme Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


ITheme Members

[image] [image]

Microsoft WebMatrix 2 Beta
ITheme Members
ITheme Interface Methods Properties See Also

The ITheme type exposes the following members.

Methods

 | Name | Description
Public method | GetFormatData | Gets the format data for a classification.
Public method | LoadFromFile | Loads the theme from a file.
Public method | SaveToFile | Saves the theme to a file.
Public method | ToXml | Converts the theme to XML.

Properties

 | Name | Description
Public property | DefaultFormat | Gets or sets the default format.
Public property | Formats | Gets a dictionary of formats.
Public property | Name | Gets the theme name.
Public property | SurfaceBackgroundBrush | Gets the surface background brush.

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


ITheme Methods

[image] [image]

Microsoft WebMatrix 2 Beta
ITheme Methods
ITheme Interface See Also

The ITheme type exposes the following members.

Methods

 | Name | Description
Public method | GetFormatData | Gets the format data for a classification.
Public method | LoadFromFile | Loads the theme from a file.
Public method | SaveToFile | Saves the theme to a file.
Public method | ToXml | Converts the theme to XML.

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


GetFormatData Method

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..GetFormatData Method
ITheme Interface See Also

Gets the format data for a classification.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
FormatData GetFormatData(
    string classificationName
)
Visual Basic
Function GetFormatData ( _
    classificationName As String _
) As FormatData

Parameters

classificationName
Type: System..::..String
Classification name.

Return Value

FormatData instance.

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


LoadFromFile Method

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..LoadFromFile Method
ITheme Interface See Also

Loads the theme from a file.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void LoadFromFile(
    string fileName
)
Visual Basic
Sub LoadFromFile ( _
    fileName As String _
)

Parameters

fileName
Type: System..::..String
File name.

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


SaveToFile Method

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..SaveToFile Method
ITheme Interface See Also

Saves the theme to a file.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void SaveToFile(
    string fileName
)
Visual Basic
Sub SaveToFile ( _
    fileName As String _
)

Parameters

fileName
Type: System..::..String
File name.

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


ToXml Method

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..ToXml Method
ITheme Interface See Also

Converts the theme to XML.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string ToXml()
Visual Basic
Function ToXml As String

Return Value

XML string.

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


ITheme Properties

[image] [image]

Microsoft WebMatrix 2 Beta
ITheme Properties
ITheme Interface See Also

The ITheme type exposes the following members.

Properties

 | Name | Description
Public property | DefaultFormat | Gets or sets the default format.
Public property | Formats | Gets a dictionary of formats.
Public property | Name | Gets the theme name.
Public property | SurfaceBackgroundBrush | Gets the surface background brush.

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


DefaultFormat Property

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..DefaultFormat Property
ITheme Interface See Also

Gets or sets the default format.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
FormatData DefaultFormat { get; set; }
Visual Basic
Property DefaultFormat As FormatData
    Get
    Set

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


Formats Property

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..Formats Property
ITheme Interface See Also

Gets a dictionary of formats.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IDictionary<string, FormatData> Formats { get; }
Visual Basic
ReadOnly Property Formats As IDictionary(Of String, FormatData)
    Get

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


Name Property

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..Name Property
ITheme Interface See Also

Gets the theme name.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


SurfaceBackgroundBrush Property

[image]

Microsoft WebMatrix 2 Beta
ITheme..::..SurfaceBackgroundBrush Property
ITheme Interface See Also

Gets the surface background brush.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
SolidColorBrush SurfaceBackgroundBrush { get; set; }
Visual Basic
Property SurfaceBackgroundBrush As SolidColorBrush
    Get
    Set

See Also

ITheme Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IThemeManager Interface

[image]

Microsoft WebMatrix 2 Beta
IThemeManager Interface
Members See Also

Interface for managing editor themes.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IThemeManager
Visual Basic
Public Interface IThemeManager

See Also

IThemeManager Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


IThemeManager Members

[image] [image]

Microsoft WebMatrix 2 Beta
IThemeManager Members
IThemeManager Interface Methods Properties See Also

The IThemeManager type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Applies the theme to the current live editor.
Public method | SaveAsDefault | Saves the theme to the users folder, and sets it as the default theme for next startup.

Properties

 | Name | Description
Public property | CurrentEditorTheme | Gets the theme currently applied at the editor.
Public property | CurrentTheme | Current theme loaded from a theme file.

See Also

IThemeManager Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IThemeManager Methods

[image] [image]

Microsoft WebMatrix 2 Beta
IThemeManager Methods
IThemeManager Interface See Also

The IThemeManager type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Applies the theme to the current live editor.
Public method | SaveAsDefault | Saves the theme to the users folder, and sets it as the default theme for next startup.

See Also

IThemeManager Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


Apply Method

[image]

Microsoft WebMatrix 2 Beta
IThemeManager..::..Apply Method
IThemeManager Interface See Also

Applies the theme to the current live editor.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void Apply(
    ITheme theme
)
Visual Basic
Sub Apply ( _
    theme As ITheme _
)

Parameters

theme
Type: Microsoft.WebMatrix.Extensibility.Editor..::..ITheme
Theme to apply, null for default theme.

See Also

IThemeManager Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


SaveAsDefault Method

[image]

Microsoft WebMatrix 2 Beta
IThemeManager..::..SaveAsDefault Method
IThemeManager Interface See Also

Saves the theme to the users folder, and sets it as the default theme for next startup.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
void SaveAsDefault(
    ITheme theme
)
Visual Basic
Sub SaveAsDefault ( _
    theme As ITheme _
)

Parameters

theme
Type: Microsoft.WebMatrix.Extensibility.Editor..::..ITheme
Theme to save, pass null to restore default.

See Also

IThemeManager Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IThemeManager Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IThemeManager Properties
IThemeManager Interface See Also

The IThemeManager type exposes the following members.

Properties

 | Name | Description
Public property | CurrentEditorTheme | Gets the theme currently applied at the editor.
Public property | CurrentTheme | Current theme loaded from a theme file.

See Also

IThemeManager Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


CurrentEditorTheme Property

[image]

Microsoft WebMatrix 2 Beta
IThemeManager..::..CurrentEditorTheme Property
IThemeManager Interface See Also

Gets the theme currently applied at the editor.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ITheme CurrentEditorTheme { get; }
Visual Basic
ReadOnly Property CurrentEditorTheme As ITheme
    Get

See Also

IThemeManager Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


CurrentTheme Property

[image]

Microsoft WebMatrix 2 Beta
IThemeManager..::..CurrentTheme Property
IThemeManager Interface See Also

Current theme loaded from a theme file.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
ITheme CurrentTheme { get; }
Visual Basic
ReadOnly Property CurrentTheme As ITheme
    Get

Remarks

This can be a subset of the current editor theme. For example, just C# related theme changes.

See Also

IThemeManager Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IThemeManagerServiceProvider Interface

[image]

Microsoft WebMatrix 2 Beta
IThemeManagerServiceProvider Interface
Members See Also

Interface for a theme manager service provider.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public interface IThemeManagerServiceProvider
Visual Basic
Public Interface IThemeManagerServiceProvider

See Also

IThemeManagerServiceProvider Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


IThemeManagerServiceProvider Members

[image] [image]

Microsoft WebMatrix 2 Beta
IThemeManagerServiceProvider Members
IThemeManagerServiceProvider Interface Properties See Also

The IThemeManagerServiceProvider type exposes the following members.

Properties

 | Name | Description
Public property | ThemeManager | Gets an IThemeManager instance.

See Also

IThemeManagerServiceProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


IThemeManagerServiceProvider Properties

[image] [image]

Microsoft WebMatrix 2 Beta
IThemeManagerServiceProvider Properties
IThemeManagerServiceProvider Interface See Also

The IThemeManagerServiceProvider type exposes the following members.

Properties

 | Name | Description
Public property | ThemeManager | Gets an IThemeManager instance.

See Also

IThemeManagerServiceProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


ThemeManager Property

[image]

Microsoft WebMatrix 2 Beta
IThemeManagerServiceProvider..::..ThemeManager Property
IThemeManagerServiceProvider Interface See Also

Gets an IThemeManager instance.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IThemeManager ThemeManager { get; }
Visual Basic
ReadOnly Property ThemeManager As IThemeManager
    Get

See Also

IThemeManagerServiceProvider Interface
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChangedEventArgs Class

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs Class
Members See Also

Used in the SettingChanged event

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class SettingChangedEventArgs : EventArgs
Visual Basic
Public Class SettingChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Microsoft.WebMatrix.Extensibility.Editor..::..SettingChangedEventArgs

See Also

SettingChangedEventArgs Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChangedEventArgs Members

[image] [image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs Members
SettingChangedEventArgs Class Constructors Methods Fields Properties See Also

The SettingChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SettingChangedEventArgs | Initializes a new instance of the SettingChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
DebugNoTabColorsKey | Debug no tab colors key.
FontFamilyKey | Font family key.
FontSizeKey | Font size key.
InsertSpacesForTabsKey | Insert spaces fro tabs key.
LastAccessedDirectoryKey | Last accessed directory key.
LastSelectedCategoryKey | Last selected category key.
LastSelectedTemplateKey | Last selected template key.
LineNumbersEnabledKey | Line numbers enabled key.
ShowWhiteSpacesKey | Show white spaces key.
SurfaceBackgroundBrushKey | Surface background brush key.
SyncTreeSelectionKey | Sync tree selection key.
TabSizeKey | Tab size key.
ThemeFileLocationKey | Theme file location key.
WordWrapEnabledKey | Word wrap enabled key.

Properties

 | Name | Description
Public property | SettingKey | Gets or sets the setting key.

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChangedEventArgs Constructor

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs Constructor
SettingChangedEventArgs Class See Also

Initializes a new instance of the SettingChangedEventArgs class.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public SettingChangedEventArgs(
    string settingKey
)
Visual Basic
Public Sub New ( _
    settingKey As String _
)

Parameters

settingKey
Type: System..::..String
Setting key.

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChangedEventArgs Fields

[image] [image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs Fields
SettingChangedEventArgs Class See Also

The SettingChangedEventArgs type exposes the following members.

Fields

Name | Description
DebugNoTabColorsKey | Debug no tab colors key.
FontFamilyKey | Font family key.
FontSizeKey | Font size key.
InsertSpacesForTabsKey | Insert spaces fro tabs key.
LastAccessedDirectoryKey | Last accessed directory key.
LastSelectedCategoryKey | Last selected category key.
LastSelectedTemplateKey | Last selected template key.
LineNumbersEnabledKey | Line numbers enabled key.
ShowWhiteSpacesKey | Show white spaces key.
SurfaceBackgroundBrushKey | Surface background brush key.
SyncTreeSelectionKey | Sync tree selection key.
TabSizeKey | Tab size key.
ThemeFileLocationKey | Theme file location key.
WordWrapEnabledKey | Word wrap enabled key.

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


DebugNoTabColorsKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..DebugNoTabColorsKey Field
SettingChangedEventArgs Class See Also

Debug no tab colors key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string DebugNoTabColorsKey
Visual Basic
Public Const DebugNoTabColorsKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


FontFamilyKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..FontFamilyKey Field
SettingChangedEventArgs Class See Also

Font family key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string FontFamilyKey
Visual Basic
Public Const FontFamilyKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


FontSizeKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..FontSizeKey Field
SettingChangedEventArgs Class See Also

Font size key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string FontSizeKey
Visual Basic
Public Const FontSizeKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


InsertSpacesForTabsKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..InsertSpacesForTabsKey Field
SettingChangedEventArgs Class See Also

Insert spaces fro tabs key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string InsertSpacesForTabsKey
Visual Basic
Public Const InsertSpacesForTabsKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


LastAccessedDirectoryKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..LastAccessedDirectoryKey Field
SettingChangedEventArgs Class See Also

Last accessed directory key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string LastAccessedDirectoryKey
Visual Basic
Public Const LastAccessedDirectoryKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


LastSelectedCategoryKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..LastSelectedCategoryKey Field
SettingChangedEventArgs Class See Also

Last selected category key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string LastSelectedCategoryKey
Visual Basic
Public Const LastSelectedCategoryKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


LastSelectedTemplateKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..LastSelectedTemplateKey Field
SettingChangedEventArgs Class See Also

Last selected template key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string LastSelectedTemplateKey
Visual Basic
Public Const LastSelectedTemplateKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


LineNumbersEnabledKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..LineNumbersEnabledKey Field
SettingChangedEventArgs Class See Also

Line numbers enabled key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string LineNumbersEnabledKey
Visual Basic
Public Const LineNumbersEnabledKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ShowWhiteSpacesKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..ShowWhiteSpacesKey Field
SettingChangedEventArgs Class See Also

Show white spaces key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string ShowWhiteSpacesKey
Visual Basic
Public Const ShowWhiteSpacesKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SurfaceBackgroundBrushKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..SurfaceBackgroundBrushKey Field
SettingChangedEventArgs Class See Also

Surface background brush key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string SurfaceBackgroundBrushKey
Visual Basic
Public Const SurfaceBackgroundBrushKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SyncTreeSelectionKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..SyncTreeSelectionKey Field
SettingChangedEventArgs Class See Also

Sync tree selection key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string SyncTreeSelectionKey
Visual Basic
Public Const SyncTreeSelectionKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


TabSizeKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..TabSizeKey Field
SettingChangedEventArgs Class See Also

Tab size key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string TabSizeKey
Visual Basic
Public Const TabSizeKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ThemeFileLocationKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..ThemeFileLocationKey Field
SettingChangedEventArgs Class See Also

Theme file location key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string ThemeFileLocationKey
Visual Basic
Public Const ThemeFileLocationKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


WordWrapEnabledKey Field

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..WordWrapEnabledKey Field
SettingChangedEventArgs Class See Also

Word wrap enabled key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string WordWrapEnabledKey
Visual Basic
Public Const WordWrapEnabledKey As String

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChangedEventArgs Methods

[image] [image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs Methods
SettingChangedEventArgs Class See Also

The SettingChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChangedEventArgs Properties

[image] [image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs Properties
SettingChangedEventArgs Class See Also

The SettingChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | SettingKey | Gets or sets the setting key.

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingKey Property

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventArgs..::..SettingKey Property
SettingChangedEventArgs Class See Also

Gets or sets the setting key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string SettingKey { get; private set; }
Visual Basic
Public Property SettingKey As String
    Get
    Private Set

See Also

SettingChangedEventArgs Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SettingChangedEventHandler Delegate

[image]

Microsoft WebMatrix 2 Beta
SettingChangedEventHandler Delegate
See Also

For handling the SettingChanged event

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public delegate void SettingChangedEventHandler(
    Object sender,
    SettingChangedEventArgs e
)
Visual Basic
Public Delegate Sub SettingChangedEventHandler ( _
    sender As Object, _
    e As SettingChangedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Microsoft.WebMatrix.Extensibility.Editor..::..SettingChangedEventArgs

See Also

Microsoft.WebMatrix.Extensibility.Editor Namespace


Theme Class

[image]

Microsoft WebMatrix 2 Beta
Theme Class
Members See Also

Class that represents an editor theme.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public class Theme : ITheme
Visual Basic
Public Class Theme _
    Implements ITheme

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility.Editor..::..Theme

See Also

Theme Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


Theme Members

[image] [image]

Microsoft WebMatrix 2 Beta
Theme Members
Theme Class Constructors Methods Properties Explicit Interface Implementations See Also

The Theme type exposes the following members.

Constructors

 | Name | Description
Public method | Theme | Initializes a new instance of the Theme class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetFormatData | Gets the format data for a classification.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Load | Loads the theme from an XML string.
Public method | LoadFromFile | Loads the theme from a file.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SaveToFile | Saves the theme to a file.
Public method | ToString | (Inherited from Object.)
Public method | ToXml | Converts the theme to XML.

Properties

 | Name | Description
Public property | DefaultFormat | Gets or sets the default format.
Public property | Formats | Gets a dictionary of formats.
Public property | Name | Gets the theme name.
Public property | SurfaceBackgroundBrush | Gets the surface background brush.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ITheme..::..Formats |

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


Theme Constructor

[image]

Microsoft WebMatrix 2 Beta
Theme Constructor
Theme Class See Also

Initializes a new instance of the Theme class.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Theme(
    string themeName
)
Visual Basic
Public Sub New ( _
    themeName As String _
)

Parameters

themeName
Type: System..::..String
Theme name.

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


Theme Methods

[image] [image]

Microsoft WebMatrix 2 Beta
Theme Methods
Theme Class See Also

The Theme type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetFormatData | Gets the format data for a classification.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Load | Loads the theme from an XML string.
Public method | LoadFromFile | Loads the theme from a file.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SaveToFile | Saves the theme to a file.
Public method | ToString | (Inherited from Object.)
Public method | ToXml | Converts the theme to XML.

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


GetFormatData Method

[image]

Microsoft WebMatrix 2 Beta
Theme..::..GetFormatData Method
Theme Class See Also

Gets the format data for a classification.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public virtual FormatData GetFormatData(
    string classificationName
)
Visual Basic
Public Overridable Function GetFormatData ( _
    classificationName As String _
) As FormatData

Parameters

classificationName
Type: System..::..String
Classification name.

Return Value

FormatData instance.

Implements

ITheme..::..GetFormatData(String)

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


Load Method

[image]

Microsoft WebMatrix 2 Beta
Theme..::..Load Method
Theme Class See Also

Loads the theme from an XML string.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public void Load(
    string xmlString
)
Visual Basic
Public Sub Load ( _
    xmlString As String _
)

Parameters

xmlString
Type: System..::..String
XML string.

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


LoadFromFile Method

[image]

Microsoft WebMatrix 2 Beta
Theme..::..LoadFromFile Method
Theme Class See Also

Loads the theme from a file.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public void LoadFromFile(
    string fileName
)
Visual Basic
Public Sub LoadFromFile ( _
    fileName As String _
)

Parameters

fileName
Type: System..::..String
File name.

Implements

ITheme..::..LoadFromFile(String)

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SaveToFile Method

[image]

Microsoft WebMatrix 2 Beta
Theme..::..SaveToFile Method
Theme Class See Also

Saves the theme to a file.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public void SaveToFile(
    string fileName
)
Visual Basic
Public Sub SaveToFile ( _
    fileName As String _
)

Parameters

fileName
Type: System..::..String
File name.

Implements

ITheme..::..SaveToFile(String)

Remarks

This method is not protected and will throw exception.

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ToXml Method

[image]

Microsoft WebMatrix 2 Beta
Theme..::..ToXml Method
Theme Class See Also

Converts the theme to XML.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string ToXml()
Visual Basic
Public Function ToXml As String

Return Value

XML string.

Implements

ITheme..::..ToXml()()()()

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


Theme Properties

[image] [image]

Microsoft WebMatrix 2 Beta
Theme Properties
Theme Class See Also

The Theme type exposes the following members.

Properties

 | Name | Description
Public property | DefaultFormat | Gets or sets the default format.
Public property | Formats | Gets a dictionary of formats.
Public property | Name | Gets the theme name.
Public property | SurfaceBackgroundBrush | Gets the surface background brush.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ITheme..::..Formats |

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


DefaultFormat Property

[image]

Microsoft WebMatrix 2 Beta
Theme..::..DefaultFormat Property
Theme Class See Also

Gets or sets the default format.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public virtual FormatData DefaultFormat { get; set; }
Visual Basic
Public Overridable Property DefaultFormat As FormatData
    Get
    Set

Implements

ITheme..::..DefaultFormat

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


Formats Property

[image]

Microsoft WebMatrix 2 Beta
Theme..::..Formats Property
Theme Class See Also

Gets a dictionary of formats.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public Dictionary<string, FormatData> Formats { get; private set; }
Visual Basic
Public Property Formats As Dictionary(Of String, FormatData)
    Get
    Private Set

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ITheme.Formats Property

[image]

Microsoft WebMatrix 2 Beta
Theme..::..ITheme..::..Formats Property
Theme Class See Also

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
IDictionary<string, FormatData> ITheme.Formats { get; }
Visual Basic
Private ReadOnly Property Formats As IDictionary(Of String, FormatData)
    Implements ITheme.Formats
    Get

Implements

ITheme..::..Formats

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


Name Property

[image]

Microsoft WebMatrix 2 Beta
Theme..::..Name Property
Theme Class See Also

Gets the theme name.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

Implements

ITheme..::..Name

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SurfaceBackgroundBrush Property

[image]

Microsoft WebMatrix 2 Beta
Theme..::..SurfaceBackgroundBrush Property
Theme Class See Also

Gets the surface background brush.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public virtual SolidColorBrush SurfaceBackgroundBrush { get; set; }
Visual Basic
Public Overridable Property SurfaceBackgroundBrush As SolidColorBrush
    Get
    Set

Implements

ITheme..::..SurfaceBackgroundBrush

See Also

Theme Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ThemeKeys Class

[image]

Microsoft WebMatrix 2 Beta
ThemeKeys Class
Members See Also

Class that exposes theme keys.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static class ThemeKeys
Visual Basic
Public NotInheritable Class ThemeKeys

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility.Editor..::..ThemeKeys

See Also

ThemeKeys Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


ThemeKeys Members

[image] [image]

Microsoft WebMatrix 2 Beta
ThemeKeys Members
ThemeKeys Class Fields See Also

The ThemeKeys type exposes the following members.

Fields

Name | Description
DefaultHighContrastTheme | Default high contrast theme.
DefaultTheme | Default theme.
ThemeKey | Theme key.

See Also

ThemeKeys Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ThemeKeys Fields

[image] [image]

Microsoft WebMatrix 2 Beta
ThemeKeys Fields
ThemeKeys Class See Also

The ThemeKeys type exposes the following members.

Fields

Name | Description
DefaultHighContrastTheme | Default high contrast theme.
DefaultTheme | Default theme.
ThemeKey | Theme key.

See Also

ThemeKeys Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


DefaultHighContrastTheme Field

[image]

Microsoft WebMatrix 2 Beta
ThemeKeys..::..DefaultHighContrastTheme Field
ThemeKeys Class See Also

Default high contrast theme.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string DefaultHighContrastTheme
Visual Basic
Public Const DefaultHighContrastTheme As String

See Also

ThemeKeys Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


DefaultTheme Field

[image]

Microsoft WebMatrix 2 Beta
ThemeKeys..::..DefaultTheme Field
ThemeKeys Class See Also

Default theme.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string DefaultTheme
Visual Basic
Public Const DefaultTheme As String

See Also

ThemeKeys Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


ThemeKey Field

[image]

Microsoft WebMatrix 2 Beta
ThemeKeys..::..ThemeKey Field
ThemeKeys Class See Also

Theme key.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public const string ThemeKey
Visual Basic
Public Const ThemeKey As String

See Also

ThemeKeys Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


XmlDocExtensions Class

[image]

Microsoft WebMatrix 2 Beta
XmlDocExtensions Class
Members See Also

Class that contains extensions for XmlDocument.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static class XmlDocExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class XmlDocExtensions

Inheritance Hierarchy

System..::..Object
Microsoft.WebMatrix.Extensibility.Editor..::..XmlDocExtensions

See Also

XmlDocExtensions Members
Microsoft.WebMatrix.Extensibility.Editor Namespace


XmlDocExtensions Members

[image] [image]

Microsoft WebMatrix 2 Beta
XmlDocExtensions Members
XmlDocExtensions Class Methods See Also

The XmlDocExtensions type exposes the following members.

Methods

Name | Description
SerializeToXMLString | Serializes to an XML string.

See Also

XmlDocExtensions Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


XmlDocExtensions Methods

[image] [image]

Microsoft WebMatrix 2 Beta
XmlDocExtensions Methods
XmlDocExtensions Class See Also

The XmlDocExtensions type exposes the following members.

Methods

Name | Description
SerializeToXMLString | Serializes to an XML string.

See Also

XmlDocExtensions Class
Microsoft.WebMatrix.Extensibility.Editor Namespace


SerializeToXMLString Method

[image]

Microsoft WebMatrix 2 Beta
XmlDocExtensions..::..SerializeToXMLString Method
XmlDocExtensions Class See Also

Serializes to an XML string.

Namespace: Microsoft.WebMatrix.Extensibility.Editor
Assembly: Microsoft.WebMatrix.Extensibility (in Microsoft.WebMatrix.Extensibility.dll)

Syntax

C#
public static string SerializeToXMLString(
    this XmlDocument doc
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SerializeToXMLString ( _
    doc As XmlDocument _
) As String

Parameters

doc
Type: System.Xml..::..XmlDocument
XmlDocument instance.

Return Value

XML string.

See Also

XmlDocExtensions Class
Microsoft.WebMatrix.Extensibility.Editor Namespace